Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Преобразовать формулу в Application.WorksheetFunction - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Преобразовать формулу в Application.WorksheetFunction (Макросы/Sub)
Преобразовать формулу в Application.WorksheetFunction
Lich Дата: Четверг, 14.01.2021, 05:20 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 33
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Здравствуйте, подскажите, пожалуйста, как преобразовать формулу:
Код
=СУММПРОИЗВ((Лист1!B2:B15000>=--Лист2!A1)*(Лист1!B2:B15000<=--Лист2!A2)*(Лист1!E2:E15000="значение 1"))

в код формата Application.WorksheetFunction.SumProduct.
Вот так не работает:
[vba]
Код
Лист2.[D2] = Application.WorksheetFunction.SumProduct((Лист1.[B2:B15000] >= Лист2.[A1]) * (Лист1.[B2:B15000] <= Лист2.[A2]) * (Лист1.[E2:E15000] = "значение 1"))
[/vba]
К сообщению приложен файл: 9119510.xlsm(16.1 Kb)


Сообщение отредактировал Lich - Четверг, 14.01.2021, 05:21
 
Ответить
СообщениеЗдравствуйте, подскажите, пожалуйста, как преобразовать формулу:
Код
=СУММПРОИЗВ((Лист1!B2:B15000>=--Лист2!A1)*(Лист1!B2:B15000<=--Лист2!A2)*(Лист1!E2:E15000="значение 1"))

в код формата Application.WorksheetFunction.SumProduct.
Вот так не работает:
[vba]
Код
Лист2.[D2] = Application.WorksheetFunction.SumProduct((Лист1.[B2:B15000] >= Лист2.[A1]) * (Лист1.[B2:B15000] <= Лист2.[A2]) * (Лист1.[E2:E15000] = "значение 1"))
[/vba]

Автор - Lich
Дата добавления - 14.01.2021 в 05:20
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Преобразовать формулу в Application.WorksheetFunction (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!