Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/по событию изм ячейки вставка формулы и значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » по событию изм ячейки вставка формулы и значения (Макросы/Sub)
по событию изм ячейки вставка формулы и значения
micholap_denis Дата: Четверг, 15.04.2021, 18:20 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
здравствуйте, помогите пожалуйста. требуется доработать макрос что бы при изменении любой ячейки вместо в ст Отметка вставлялась "1" а в ст Формула 1 вставляется формула допустим [@7]*[@8]
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("A3:G1000, I3:J1000")) Is Nothing Then Cells(Target.Row, 9) = 1
    
End Sub

[/vba]
К сообщению приложен файл: 9708528.xlsb(17.2 Kb)


Сообщение отредактировал micholap_denis - Четверг, 15.04.2021, 18:21
 
Ответить
Сообщениездравствуйте, помогите пожалуйста. требуется доработать макрос что бы при изменении любой ячейки вместо в ст Отметка вставлялась "1" а в ст Формула 1 вставляется формула допустим [@7]*[@8]
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("A3:G1000, I3:J1000")) Is Nothing Then Cells(Target.Row, 9) = 1
    
End Sub

[/vba]

Автор - micholap_denis
Дата добавления - 15.04.2021 в 18:20
Pelena Дата: Четверг, 15.04.2021, 19:43 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17775
Репутация: 3956 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Так? Столбец Отметка не нашла
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("A3:G1000, I3:J1000")) Is Nothing Then Cells(Target.Row, 9).FormulaR1C1 = "=[@7]*[@8]"
End Sub
[/vba]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Так? Столбец Отметка не нашла
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("A3:G1000, I3:J1000")) Is Nothing Then Cells(Target.Row, 9).FormulaR1C1 = "=[@7]*[@8]"
End Sub
[/vba]

Автор - Pelena
Дата добавления - 15.04.2021 в 19:43
micholap_denis Дата: Четверг, 15.04.2021, 19:50 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
а как будет если нужно чтоб в ст 9 вставилась формула а в ст 5 к примеру "1"


Сообщение отредактировал micholap_denis - Четверг, 15.04.2021, 19:59
 
Ответить
Сообщениеа как будет если нужно чтоб в ст 9 вставилась формула а в ст 5 к примеру "1"

Автор - micholap_denis
Дата добавления - 15.04.2021 в 19:50
Pelena Дата: Четверг, 15.04.2021, 20:02 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17775
Репутация: 3956 ±
Замечаний: ±

Excel 2016 & Mac Excel
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("A3:G1000, I3:J1000")) Is Nothing Then
        Cells(Target.Row, 9).FormulaR1C1 = "=[@7]*[@8]"
        Cells(Target.Row, 5) = 1
    End If
End Sub
[/vba]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("A3:G1000, I3:J1000")) Is Nothing Then
        Cells(Target.Row, 9).FormulaR1C1 = "=[@7]*[@8]"
        Cells(Target.Row, 5) = 1
    End If
End Sub
[/vba]

Автор - Pelena
Дата добавления - 15.04.2021 в 20:02
micholap_denis Дата: Четверг, 15.04.2021, 20:02 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
спасибо!!!хорошего вечера вам
 
Ответить
Сообщениеспасибо!!!хорошего вечера вам

Автор - micholap_denis
Дата добавления - 15.04.2021 в 20:02
micholap_denis Дата: Четверг, 15.04.2021, 20:17 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, подскажите как в макросе прописать формулу
Код
=ОКРУГЛ(ЕСЛИ(Баланс[@[Приход/расход]]="Приход";1;-1)*Баланс[@Количество]*Баланс[@[Цена]]*ЕСЛИ(И(Баланс[@Валюта]="BYR";Баланс[@[Дата платежа]]<ДАТА(2016;7;1));0,0001;1);4)
 
Ответить
СообщениеPelena, подскажите как в макросе прописать формулу
Код
=ОКРУГЛ(ЕСЛИ(Баланс[@[Приход/расход]]="Приход";1;-1)*Баланс[@Количество]*Баланс[@[Цена]]*ЕСЛИ(И(Баланс[@Валюта]="BYR";Баланс[@[Дата платежа]]<ДАТА(2016;7;1));0,0001;1);4)

Автор - micholap_denis
Дата добавления - 15.04.2021 в 20:17
Pelena Дата: Четверг, 15.04.2021, 21:20 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 17775
Репутация: 3956 ±
Замечаний: ±

Excel 2016 & Mac Excel
Включите макрорекодер, напишите формулу в ячейке, остановите запись и посмотрите, что получилось. Можно просто скопировать и вставить в Ваш макрос


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВключите макрорекодер, напишите формулу в ячейке, остановите запись и посмотрите, что получилось. Можно просто скопировать и вставить в Ваш макрос

Автор - Pelena
Дата добавления - 15.04.2021 в 21:20
micholap_denis Дата: Четверг, 15.04.2021, 22:31 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
спасибо...думал там мудровать нужно что то)
 
Ответить
Сообщениеспасибо...думал там мудровать нужно что то)

Автор - micholap_denis
Дата добавления - 15.04.2021 в 22:31
Мир MS Excel » Вопросы и решения » Вопросы по VBA » по событию изм ячейки вставка формулы и значения (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!