Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подставить формулу vba - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Подставить формулу vba (Макросы/Sub)
Подставить формулу vba
Alex2354 Дата: Суббота, 19.03.2022, 11:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.

Подскажите, пожалуйста, в чем ошибка:

[vba]
Код
Sub Макрос1()
    Range("J25").Formula = "=СЧЁТЕСЛИ(N$1:N23;1)"
End Sub
[/vba]

Спасибо.
К сообщению приложен файл: 6898297.xlsm(17.1 Kb)
 
Ответить
СообщениеДобрый день.

Подскажите, пожалуйста, в чем ошибка:

[vba]
Код
Sub Макрос1()
    Range("J25").Formula = "=СЧЁТЕСЛИ(N$1:N23;1)"
End Sub
[/vba]

Спасибо.

Автор - Alex2354
Дата добавления - 19.03.2022 в 11:08
Nic70y Дата: Суббота, 19.03.2022, 11:16 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7857
Репутация: 1891 ±
Замечаний: 0% ±

Excel 2010
[vba]
Код
    Range("J25").FormulaLocal = "=СЧЁТЕСЛИ(N$1:N23;1)"
[/vba]или[vba]
Код
    Range("J25").FormulaR1C1 = "=COUNTIF(R1C[4]:R[-2]C[4],1)"
[/vba]


ЮMoney 41001841029809
 
Ответить
Сообщение[vba]
Код
    Range("J25").FormulaLocal = "=СЧЁТЕСЛИ(N$1:N23;1)"
[/vba]или[vba]
Код
    Range("J25").FormulaR1C1 = "=COUNTIF(R1C[4]:R[-2]C[4],1)"
[/vba]

Автор - Nic70y
Дата добавления - 19.03.2022 в 11:16
bmv98rus Дата: Суббота, 19.03.2022, 14:38 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3953
Репутация: 732 ±
Замечаний: 0% ±

Excel 2013/2016
Range("J25").FormulaLocal = "=СЧЁТЕСЛИ(N$1:N23;1)"
ну это смотря у кого какая локал. Я б всеж к
[vba]
Код
    Range("J25").Formula = "=COUNTIF(N$1:N23,1)"
[/vba]
cклонял


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Range("J25").FormulaLocal = "=СЧЁТЕСЛИ(N$1:N23;1)"
ну это смотря у кого какая локал. Я б всеж к
[vba]
Код
    Range("J25").Formula = "=COUNTIF(N$1:N23,1)"
[/vba]
cклонял

Автор - bmv98rus
Дата добавления - 19.03.2022 в 14:38
Alex2354 Дата: Воскресенье, 20.03.2022, 12:38 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Спасибо. Первый вариант понравился больше.
Почему то с просто ВПР работает. А с тоже самое, но под ЕСНД ошибка
Чем они отличаются то? :o

[vba]
Код
Sub Макрос()
     
    Application.ScreenUpdating = False
    Application.Calculation = xlCalculationManual
    
    
    Range("B1:B200").FormulaLocal = "=ВПР(A1;Лист2!A1:F200;2;ЛОЖЬ)"
    Range("B1:B200").FormulaLocal = "=ЕСНД(ВПР(A1;Лист2!A1:F200;2;ЛОЖЬ);"")"
    
    
    Application.Calculation = xlCalculationAutomatic
    Application.ScreenUpdating = True
    
End Sub
[/vba]

bmv98rus, Тоже спасибо.
на маленьком файлике получается, А когда вставляю в большой, где значения диапазона N$23:N$222 вычисляется формулой ниже, то ошибка
Код
=ЕСЛИ(H23<>"";СЧЁТЕСЛИ(H$23:H23;H23);"")

Эти формулы эквивалентны?

[vba]
Код
    Range("I225").Formula = "=COUNTIF(N$23:N$222;1)"
    Range("I225").FormulaLocal = "=СЧЁТЕСЛИ(N$23:N$222;1)"
[/vba]
К сообщению приложен файл: 4815851.xlsm(21.3 Kb)
 
Ответить
СообщениеNic70y, Спасибо. Первый вариант понравился больше.
Почему то с просто ВПР работает. А с тоже самое, но под ЕСНД ошибка
Чем они отличаются то? :o

[vba]
Код
Sub Макрос()
     
    Application.ScreenUpdating = False
    Application.Calculation = xlCalculationManual
    
    
    Range("B1:B200").FormulaLocal = "=ВПР(A1;Лист2!A1:F200;2;ЛОЖЬ)"
    Range("B1:B200").FormulaLocal = "=ЕСНД(ВПР(A1;Лист2!A1:F200;2;ЛОЖЬ);"")"
    
    
    Application.Calculation = xlCalculationAutomatic
    Application.ScreenUpdating = True
    
End Sub
[/vba]

bmv98rus, Тоже спасибо.
на маленьком файлике получается, А когда вставляю в большой, где значения диапазона N$23:N$222 вычисляется формулой ниже, то ошибка
Код
=ЕСЛИ(H23<>"";СЧЁТЕСЛИ(H$23:H23;H23);"")

Эти формулы эквивалентны?

[vba]
Код
    Range("I225").Formula = "=COUNTIF(N$23:N$222;1)"
    Range("I225").FormulaLocal = "=СЧЁТЕСЛИ(N$23:N$222;1)"
[/vba]

Автор - Alex2354
Дата добавления - 20.03.2022 в 12:38
RAN Дата: Воскресенье, 20.03.2022, 12:48 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 5638
Репутация: 1144 ±
Замечаний: 0% ±

2010
Эти формулы эквивалентны?

Если исправить ошибку, то да.
См. формулу bmv98rus.


Быть или не быть, вот в чем загвоздка!
 
Ответить
Сообщение
Эти формулы эквивалентны?

Если исправить ошибку, то да.
См. формулу bmv98rus.

Автор - RAN
Дата добавления - 20.03.2022 в 12:48
Alex2354 Дата: Воскресенье, 20.03.2022, 20:01 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

RAN, Спасибо, был невнимательным. :( Сделал :D

[vba]
Код
Range("B3:B252").Formula = "=IFNA(VLOOKUP(A3,'Лист1!$A:$AC,16,FALSE),"""")"
[/vba]


Сообщение отредактировал Serge_007 - Понедельник, 21.03.2022, 09:08
 
Ответить
СообщениеRAN, Спасибо, был невнимательным. :( Сделал :D

[vba]
Код
Range("B3:B252").Formula = "=IFNA(VLOOKUP(A3,'Лист1!$A:$AC,16,FALSE),"""")"
[/vba]

Автор - Alex2354
Дата добавления - 20.03.2022 в 20:01
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Подставить формулу vba (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!