Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Уникальные значения по условию! - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Уникальные значения по условию! (Макросы/Sub)
Уникальные значения по условию!
ekut Дата: Понедельник, 31.10.2022, 05:13 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 194
Репутация: 3 ±
Замечаний: 0% ±

Excel 2007
Уважаемые Екселитсы! Если не трудно, помогите макросом проставить уникальные значения по условию! Благодарю заранее!!!!
К сообщению приложен файл: __.xls(48.5 Kb)


Сообщение отредактировал ekut - Понедельник, 31.10.2022, 05:14
 
Ответить
СообщениеУважаемые Екселитсы! Если не трудно, помогите макросом проставить уникальные значения по условию! Благодарю заранее!!!!

Автор - ekut
Дата добавления - 31.10.2022 в 05:13
msi2102 Дата: Понедельник, 31.10.2022, 09:03 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 89 ±
Замечаний: 0% ±

Excel 2007
Может так?
Код
=ИНДЕКС(Подписи!$B$1:$B$30;ПОИСКПОЗ(A16;Подписи!$A$1:$A$30;0))
К сообщению приложен файл: 6270832.xls(53.5 Kb)
 
Ответить
СообщениеМожет так?
Код
=ИНДЕКС(Подписи!$B$1:$B$30;ПОИСКПОЗ(A16;Подписи!$A$1:$A$30;0))

Автор - msi2102
Дата добавления - 31.10.2022 в 09:03
NikitaDvorets Дата: Понедельник, 31.10.2022, 13:50 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 384
Репутация: 77 ±
Замечаний: 0% ±

Excel 2019
ekut,
Вариант - выборка макросом уникальных значений из матрицы и расшифровка в соответствии со списком "Подписи".
К сообщению приложен файл: TEST-227_-___31.xlsm(31.5 Kb)
 
Ответить
Сообщениеekut,
Вариант - выборка макросом уникальных значений из матрицы и расшифровка в соответствии со списком "Подписи".

Автор - NikitaDvorets
Дата добавления - 31.10.2022 в 13:50
ekut Дата: Понедельник, 31.10.2022, 13:55 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 194
Репутация: 3 ±
Замечаний: 0% ±

Excel 2007
Спасибо огромное! Работает!!!! Но при изменении в табеле и нажатии клавиши повторно, немного глючит. не стирает старые. Смотрите, изначально уникальные срабатывали при изменении автоматически, это очень удобно (без клавиш)


Сообщение отредактировал ekut - Понедельник, 31.10.2022, 14:15
 
Ответить
СообщениеСпасибо огромное! Работает!!!! Но при изменении в табеле и нажатии клавиши повторно, немного глючит. не стирает старые. Смотрите, изначально уникальные срабатывали при изменении автоматически, это очень удобно (без клавиш)

Автор - ekut
Дата добавления - 31.10.2022 в 13:55
NikitaDvorets Дата: Понедельник, 31.10.2022, 15:45 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 384
Репутация: 77 ±
Замечаний: 0% ±

Excel 2019
Цитата
Но при изменении в табеле

А это уже новая вводная...... поправлю...
 
Ответить
Сообщение
Цитата
Но при изменении в табеле

А это уже новая вводная...... поправлю...

Автор - NikitaDvorets
Дата добавления - 31.10.2022 в 15:45
NikitaDvorets Дата: Понедельник, 31.10.2022, 16:11 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 384
Репутация: 77 ±
Замечаний: 0% ±

Excel 2019
Исправленная версия, user-friendly, прилагается.
К сообщению приложен файл: 2835714.xlsm(29.7 Kb)
 
Ответить
СообщениеИсправленная версия, user-friendly, прилагается.

Автор - NikitaDvorets
Дата добавления - 31.10.2022 в 16:11
ekut Дата: Понедельник, 31.10.2022, 17:36 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 194
Репутация: 3 ±
Замечаний: 0% ±

Excel 2007
Я Вам очееень благодарна!!!!!!!
 
Ответить
СообщениеЯ Вам очееень благодарна!!!!!!!

Автор - ekut
Дата добавления - 31.10.2022 в 17:36
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Уникальные значения по условию! (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!