Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск точек в окружности - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Поиск точек в окружности
danissimo1231 Дата: Пятница, 06.10.2023, 19:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день,
Стоит задача для каждой точки найти количество точек, попадающих в окружность радиусом 600.
Используя знания тригонометрии, удалость решить задачу для 1 конкретной точки. По формуле (x-a)^2+(y-b)^2<=R^2, центр окружности координата точки. Протянуть данную функцию не получается, так как все упирается в центр круга определенной точки.
Вопрос: можно ли и как создать пользовательскую функцию (макрос) для поиска количества точек, удовлетворяющих данному условию, для каждой отдельной точки.
p.s. В VBA новичёк(
К сообщению приложен файл: 6091691.xlsx (13.7 Kb)
 
Ответить
СообщениеДобрый день,
Стоит задача для каждой точки найти количество точек, попадающих в окружность радиусом 600.
Используя знания тригонометрии, удалость решить задачу для 1 конкретной точки. По формуле (x-a)^2+(y-b)^2<=R^2, центр окружности координата точки. Протянуть данную функцию не получается, так как все упирается в центр круга определенной точки.
Вопрос: можно ли и как создать пользовательскую функцию (макрос) для поиска количества точек, удовлетворяющих данному условию, для каждой отдельной точки.
p.s. В VBA новичёк(

Автор - danissimo1231
Дата добавления - 06.10.2023 в 19:44
Pelena Дата: Пятница, 06.10.2023, 21:45 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 19211
Репутация: 4427 ±
Замечаний: ±

Excel 365 & Mac Excel
Здравствуйте.
Код
=СУММПРОИЗВ(--(($B$2:$B$22-B2)^2+($C$2:$C$22-C2)^2<=$H$1^2))
К сообщению приложен файл: 2424119.xlsx (15.3 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММПРОИЗВ(--(($B$2:$B$22-B2)^2+($C$2:$C$22-C2)^2<=$H$1^2))

Автор - Pelena
Дата добавления - 06.10.2023 в 21:45
cmivadwot Дата: Пятница, 06.10.2023, 22:08 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 459
Репутация: 86 ±
Замечаний: 0% ±

365
Pelena, Вечер добрый. А я чет борщнул.. без пространственного мышления)))) как все просто...
К сообщению приложен файл: 555555566666.xlsx (19.5 Kb)


Сообщение отредактировал cmivadwot - Пятница, 06.10.2023, 22:15
 
Ответить
СообщениеPelena, Вечер добрый. А я чет борщнул.. без пространственного мышления)))) как все просто...

Автор - cmivadwot
Дата добавления - 06.10.2023 в 22:08
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!