Домашняя страница Undo Do Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Извлечь данные из объединенных ячеек - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вопросы по Excel для Mac » Извлечь данные из объединенных ячеек (извлечь информацию из объединенных ячеек)
Извлечь данные из объединенных ячеек
Snow Дата: Вторник, 27.12.2022, 16:04 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 97
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
С наступающим ! hands
Помогите, кто чем может ))
Как из таблицы с объединенными ячейками и смещенными строками извлечь краткую информацию?
К сообщению приложен файл: 9489841.xls(25.0 Kb)


Сообщение отредактировал Snow - Вторник, 27.12.2022, 16:14
 
Ответить
СообщениеС наступающим ! hands
Помогите, кто чем может ))
Как из таблицы с объединенными ячейками и смещенными строками извлечь краткую информацию?

Автор - Snow
Дата добавления - 27.12.2022 в 16:04
Serge_007 Дата: Вторник, 27.12.2022, 16:32 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15645
Репутация: 2575 ±
Замечаний: ±

Excel 2016
С наступающим
И Вас так же)

У Вас точно вопрос по MacExcel?

Для Нетто формула массива:
Код
=ИНДЕКС(G$9:G$40;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(--ПОДСТАВИТЬ(A$8:A$40;",";));СТРОКА(A$1:A$32));СТРОКА(A1)))
Остальные - по аналогии
К сообщению приложен файл: 20221227_Snow.xls(32.5 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
С наступающим
И Вас так же)

У Вас точно вопрос по MacExcel?

Для Нетто формула массива:
Код
=ИНДЕКС(G$9:G$40;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(--ПОДСТАВИТЬ(A$8:A$40;",";));СТРОКА(A$1:A$32));СТРОКА(A1)))
Остальные - по аналогии

Автор - Serge_007
Дата добавления - 27.12.2022 в 16:32
_Boroda_ Дата: Вторник, 27.12.2022, 16:54 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16550
Репутация: 6441 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Серег, я тоже сначала также пропустил. Там в последнем блоке не одно значение. Предположу, что их и не два может быть )))

Для первых пяти столбцов такой вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС($G$1:$AN$99;ПОИСКПОЗ(0=0;ИНДЕКС($G$1:$G$99;НАИМЕНЬШИЙ(ЕСЛИ($G$1:$G$99=$BB$5;СТРОКА($1:$99));СТРОКА(BB1))):$G$99=0;)+НАИМЕНЬШИЙ(ЕСЛИ($G$1:$G$99=$BB$5;СТРОКА($1:$99));СТРОКА(BB1))-2;ПОИСКПОЗ(BB$5;$G$7:$AN$7;));"")

Для шестого попроще )))
Код
=ЕСЛИОШИБКА(ИНДЕКС($AU$1:$AU$99;НАИМЕНЬШИЙ(ЕСЛИ($G$1:$G$99=$BB$5;СТРОКА($1:$99));СТРОКА(BG1))-3);"")
К сообщению приложен файл: 9489841_1.xls(38.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСерег, я тоже сначала также пропустил. Там в последнем блоке не одно значение. Предположу, что их и не два может быть )))

Для первых пяти столбцов такой вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС($G$1:$AN$99;ПОИСКПОЗ(0=0;ИНДЕКС($G$1:$G$99;НАИМЕНЬШИЙ(ЕСЛИ($G$1:$G$99=$BB$5;СТРОКА($1:$99));СТРОКА(BB1))):$G$99=0;)+НАИМЕНЬШИЙ(ЕСЛИ($G$1:$G$99=$BB$5;СТРОКА($1:$99));СТРОКА(BB1))-2;ПОИСКПОЗ(BB$5;$G$7:$AN$7;));"")

Для шестого попроще )))
Код
=ЕСЛИОШИБКА(ИНДЕКС($AU$1:$AU$99;НАИМЕНЬШИЙ(ЕСЛИ($G$1:$G$99=$BB$5;СТРОКА($1:$99));СТРОКА(BG1))-3);"")

Автор - _Boroda_
Дата добавления - 27.12.2022 в 16:54
Serge_007 Дата: Вторник, 27.12.2022, 17:38 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15645
Репутация: 2575 ±
Замечаний: ±

Excel 2016
в последнем блоке не одно значение
Саш, последний блок - это номер?
Если да, то его я на ОАО ориентировал:
Код
=ИНДЕКС(AU$1:AU$40;НАИМЕНЬШИЙ(ЕСЛИ(A$1:A$40="ОАО";СТРОКА(A$1:A$40));СТРОКА(A1)))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
в последнем блоке не одно значение
Саш, последний блок - это номер?
Если да, то его я на ОАО ориентировал:
Код
=ИНДЕКС(AU$1:AU$40;НАИМЕНЬШИЙ(ЕСЛИ(A$1:A$40="ОАО";СТРОКА(A$1:A$40));СТРОКА(A1)))

Автор - Serge_007
Дата добавления - 27.12.2022 в 17:38
_Boroda_ Дата: Вторник, 27.12.2022, 17:55 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16550
Репутация: 6441 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не, внизу последний. Там на экране все одинаковые, а ниже более другой )))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе, внизу последний. Там на экране все одинаковые, а ниже более другой )))

Автор - _Boroda_
Дата добавления - 27.12.2022 в 17:55
Snow Дата: Среда, 28.12.2022, 13:36 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 97
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
Вы такие хорошенькие!
Спасибо!



Сообщение отредактировал Snow - Среда, 28.12.2022, 13:38
 
Ответить
СообщениеВы такие хорошенькие!
Спасибо!


Автор - Snow
Дата добавления - 28.12.2022 в 13:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вопросы по Excel для Mac » Извлечь данные из объединенных ячеек (извлечь информацию из объединенных ячеек)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!