Домашняя страница Undo Do Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка данных - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вопросы по Excel для Mac » Выборка данных
Выборка данных
sodcover Дата: Понедельник, 25.09.2023, 06:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Имеются данные потерь картофеля от заболевания за пять лет в конкретном регионе России. В каждом регионе есть несколько повторений. Необходимо узнать сколько раз в процентном соотношении за пятилетний период встречались значения потерь картофеля <10; 10-20; >20 суммарно внутри каждого региона.
[admin]Тема закрыта. Дублирование[/admin]
К сообщению приложен файл: 4721811.xlsx (24.0 Kb)


Сообщение отредактировал Pelena - Понедельник, 25.09.2023, 11:04
 
Ответить
СообщениеИмеются данные потерь картофеля от заболевания за пять лет в конкретном регионе России. В каждом регионе есть несколько повторений. Необходимо узнать сколько раз в процентном соотношении за пятилетний период встречались значения потерь картофеля <10; 10-20; >20 суммарно внутри каждого региона.
[admin]Тема закрыта. Дублирование[/admin]

Автор - sodcover
Дата добавления - 25.09.2023 в 06:45
Pelena Дата: Понедельник, 25.09.2023, 10:46 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 19173
Репутация: 4413 ±
Замечаний: ±

Excel 365 & Mac Excel
Если заменить #Н/Д на пустую ячейку, то можно так
Код
=ЕСЛИ($A23="";СУММПРОИЗВ(($B$2:$F$44>20)*($A$2:$A$44=$A22)*($B$2:$F$44<>""))/СУММПРОИЗВ(($A$2:$A$44=$A22)*($B$2:$F$44<>""));"")
К сообщению приложен файл: 8202235.xlsx (28.2 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЕсли заменить #Н/Д на пустую ячейку, то можно так
Код
=ЕСЛИ($A23="";СУММПРОИЗВ(($B$2:$F$44>20)*($A$2:$A$44=$A22)*($B$2:$F$44<>""))/СУММПРОИЗВ(($A$2:$A$44=$A22)*($B$2:$F$44<>""));"")

Автор - Pelena
Дата добавления - 25.09.2023 в 10:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вопросы по Excel для Mac » Выборка данных
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!