Домашняя страница Undo Do Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формат кода поля при слиянии с excel - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Word » Формат кода поля при слиянии с excel
Формат кода поля при слиянии с excel
maximich Дата: Вторник, 08.09.2020, 12:58 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Уважаемые форумчане, здравствуйте!
Создал слияние шаблона word с таблицой excel, но возникла одна проблема, а именно, когда я в word подтягиваю числовые данные из excel, мне необходимо чтобы разряды числа были отделены пробелом, для этого написал в word код поля word следующего вида: [vba]
Код
{ MERGEFIELD ЦД \# "# ### ##0,00 руб."}
[/vba]
Когда подтягивается 7-9 значное число, то все отлично:

но когда подтягивается число 4-6 значное число, то перед числом появляется два пробела:

Помогите пожалуйста поправить код поля word [vba]
Код
{ MERGEFIELD ЦД \# "# ### ##0,00 руб."}
[/vba], чтобы этих лишних пробелов небыло.
Заранее спасибо!
Кросс https://www.cyberforum.ru/ms-word/thread2696386.html
https://www.excel-vba.ru/forum/index.php?topic=6345.new#new


Сообщение отредактировал maximich - Среда, 09.09.2020, 10:55
 
Ответить
СообщениеУважаемые форумчане, здравствуйте!
Создал слияние шаблона word с таблицой excel, но возникла одна проблема, а именно, когда я в word подтягиваю числовые данные из excel, мне необходимо чтобы разряды числа были отделены пробелом, для этого написал в word код поля word следующего вида: [vba]
Код
{ MERGEFIELD ЦД \# "# ### ##0,00 руб."}
[/vba]
Когда подтягивается 7-9 значное число, то все отлично:

но когда подтягивается число 4-6 значное число, то перед числом появляется два пробела:

Помогите пожалуйста поправить код поля word [vba]
Код
{ MERGEFIELD ЦД \# "# ### ##0,00 руб."}
[/vba], чтобы этих лишних пробелов небыло.
Заранее спасибо!
Кросс https://www.cyberforum.ru/ms-word/thread2696386.html
https://www.excel-vba.ru/forum/index.php?topic=6345.new#new

Автор - maximich
Дата добавления - 08.09.2020 в 12:58
Pelena Дата: Вторник, 08.09.2020, 14:09 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16631
Репутация: 3595 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Думаю, в самом вордовском документе не получится. Можно в таблице Excel сделать доп. столбец с формулой типа
Код
=ТЕКСТ(A1;"# ##0,00")

таким образом перевести число в текст и уже этот столбец использовать в слиянии


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Думаю, в самом вордовском документе не получится. Можно в таблице Excel сделать доп. столбец с формулой типа
Код
=ТЕКСТ(A1;"# ##0,00")

таким образом перевести число в текст и уже этот столбец использовать в слиянии

Автор - Pelena
Дата добавления - 08.09.2020 в 14:09
maximich Дата: Вторник, 08.09.2020, 14:21 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Думаю, в самом вордовском документе не получится

Жаль. Но все равно спасибо
 
Ответить
Сообщение
Думаю, в самом вордовском документе не получится

Жаль. Но все равно спасибо

Автор - maximich
Дата добавления - 08.09.2020 в 14:21
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Word » Формат кода поля при слиянии с excel
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!