Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт непустых значений - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт непустых значений (Формулы/Formulas)
Подсчёт непустых значений
Сергей-К Дата: Воскресенье, 01.06.2014, 20:39 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день. Помогите исправить формулу по подсчёту непустых ячеек, работает некорректно. Требуется вести подсчёт заполненных клеток в диапазоне. Значения в диапазоне регулярно изменяются. Спасибо
К сообщению приложен файл: 3554660.xls(19.0 Kb)
 
Ответить
СообщениеДобрый день. Помогите исправить формулу по подсчёту непустых ячеек, работает некорректно. Требуется вести подсчёт заполненных клеток в диапазоне. Значения в диапазоне регулярно изменяются. Спасибо

Автор - Сергей-К
Дата добавления - 01.06.2014 в 20:39
shurikus Дата: Воскресенье, 01.06.2014, 20:46 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 44 ±
Замечаний: 0% ±

Excel 2007
А чем не устраивает функция СЧЁТЗ? В, так сказать, первозданном виде?
Код
=СЧЁТЗ(A3:A22)


Сообщение отредактировал shurikus - Воскресенье, 01.06.2014, 20:49
 
Ответить
СообщениеА чем не устраивает функция СЧЁТЗ? В, так сказать, первозданном виде?
Код
=СЧЁТЗ(A3:A22)

Автор - shurikus
Дата добавления - 01.06.2014 в 20:46
Сергей-К Дата: Воскресенье, 01.06.2014, 20:59 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Извеняюсь. Не правильно привёл условия задачи. Требуется составить формулу, которая посчитает количество ячеек, но только тех, что отображают в себе любое значение: числа, текст, ошибки; но не будет считать те ячейки, которые содержат формулы с пустым результатом. Файл исправленный выложил. Спасибо
К сообщению приложен файл: 6175041.xls(22.0 Kb)


Сообщение отредактировал Сергей-К - Воскресенье, 01.06.2014, 20:59
 
Ответить
СообщениеИзвеняюсь. Не правильно привёл условия задачи. Требуется составить формулу, которая посчитает количество ячеек, но только тех, что отображают в себе любое значение: числа, текст, ошибки; но не будет считать те ячейки, которые содержат формулы с пустым результатом. Файл исправленный выложил. Спасибо

Автор - Сергей-К
Дата добавления - 01.06.2014 в 20:59
shurikus Дата: Воскресенье, 01.06.2014, 21:15 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 44 ±
Замечаний: 0% ±

Excel 2007
Можно из общего счета вычесть пустоты :)
Код
=СЧЁТЗ(A3:A22)-СЧИТАТЬПУСТОТЫ(A3:A22)
 
Ответить
СообщениеМожно из общего счета вычесть пустоты :)
Код
=СЧЁТЗ(A3:A22)-СЧИТАТЬПУСТОТЫ(A3:A22)

Автор - shurikus
Дата добавления - 01.06.2014 в 21:15
Сергей-К Дата: Воскресенье, 01.06.2014, 21:23 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Ух-ты, а я и не знал про такую функцию. Спасибо, shurikus. hands
 
Ответить
СообщениеУх-ты, а я и не знал про такую функцию. Спасибо, shurikus. hands

Автор - Сергей-К
Дата добавления - 01.06.2014 в 21:23
shurikus Дата: Воскресенье, 01.06.2014, 21:28 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 44 ±
Замечаний: 0% ±

Excel 2007
Как вариант, можно подсчитать все отдельно и сложить...
Код
=СЧЁТЕСЛИ(A3:A22;">0")+СУММПРОИЗВ(--(A3:A22>""))
 
Ответить
СообщениеКак вариант, можно подсчитать все отдельно и сложить...
Код
=СЧЁТЕСЛИ(A3:A22;">0")+СУММПРОИЗВ(--(A3:A22>""))

Автор - shurikus
Дата добавления - 01.06.2014 в 21:28
AlexM Дата: Воскресенье, 01.06.2014, 22:10 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Можно так
Код
=СУММПРОИЗВ(--(A3:A22<>""))
или массивной
Код
=СУММ(--(A3:A22<>""))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеМожно так
Код
=СУММПРОИЗВ(--(A3:A22<>""))
или массивной
Код
=СУММ(--(A3:A22<>""))

Автор - AlexM
Дата добавления - 01.06.2014 в 22:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт непустых значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!