Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчёт количества уникальных текстовых значений по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт количества уникальных текстовых значений по условию (Формулы/Formulas)
Расчёт количества уникальных текстовых значений по условию
Bamboo Дата: Среда, 02.07.2014, 12:09 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте.
Помогите пожалуйста.

Нужна формула, чтобы рассчитать количество уникальных текстовых значений для записей удовлетворяющих условию. По аналогию с решением здесь: , но здесь оно для числовых данных.
На пример, нужно, определить количество поставщиков каждого вида товара.
Пример см. в файле.

Нужна именно формула, в крайнем случае макрос, т.к. необходимо будет обработать слишком большой массив.

Заранее спасибо!
К сообщению приложен файл: 2313225.xlsx(8.4 Kb)


Сообщение отредактировал Bamboo - Среда, 02.07.2014, 12:09
 
Ответить
СообщениеЗдравствуйте.
Помогите пожалуйста.

Нужна формула, чтобы рассчитать количество уникальных текстовых значений для записей удовлетворяющих условию. По аналогию с решением здесь: , но здесь оно для числовых данных.
На пример, нужно, определить количество поставщиков каждого вида товара.
Пример см. в файле.

Нужна именно формула, в крайнем случае макрос, т.к. необходимо будет обработать слишком большой массив.

Заранее спасибо!

Автор - Bamboo
Дата добавления - 02.07.2014 в 12:09
ArkaIIIa Дата: Среда, 02.07.2014, 12:10 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 890
Репутация: 115 ±
Замечаний: 0% ±

2010
Bamboo
Так это простое СЧЕТЕСЛИ.

в B22
Код
=СЧЁТЕСЛИ($B$4:$B$18;A22)

И протягивайте вниз
 
Ответить
СообщениеBamboo
Так это простое СЧЕТЕСЛИ.

в B22
Код
=СЧЁТЕСЛИ($B$4:$B$18;A22)

И протягивайте вниз

Автор - ArkaIIIa
Дата добавления - 02.07.2014 в 12:10
ArkaIIIa Дата: Среда, 02.07.2014, 12:12 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 890
Репутация: 115 ±
Замечаний: 0% ±

2010
Кстати, я так и не понял в чем уникальность текстовых значений...
 
Ответить
СообщениеКстати, я так и не понял в чем уникальность текстовых значений...

Автор - ArkaIIIa
Дата добавления - 02.07.2014 в 12:12
Hugo Дата: Среда, 02.07.2014, 12:16 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3070
Репутация: 662 ±
Замечаний: 0% ±

Нужна именно формула, в крайнем случае макрос, т.к. необходимо будет обработать слишком большой массив.

я сказал бы иначе - "нужен именно макрос, в крайнем случае формула, т.к. необходимо будет обработать слишком большой массив." Но как хотите...


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069
 
Ответить
Сообщение
Нужна именно формула, в крайнем случае макрос, т.к. необходимо будет обработать слишком большой массив.

я сказал бы иначе - "нужен именно макрос, в крайнем случае формула, т.к. необходимо будет обработать слишком большой массив." Но как хотите...

Автор - Hugo
Дата добавления - 02.07.2014 в 12:16
Bamboo Дата: Среда, 02.07.2014, 12:37 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо большое!

Я не совсем точно изложил задачу в примере: один и тот же поставщик может поставить один и тот же товар несколько раз, при этом сосчитать его нужно только один раз, т.е. нужно только количество уникальных значений поставщиков.

Я исправил пример в файле, там же посчитано со СЧЕТЕСЛИ и показана разница.
К сообщению приложен файл: 5011375.xlsx(8.9 Kb)


Сообщение отредактировал Bamboo - Среда, 02.07.2014, 12:38
 
Ответить
СообщениеСпасибо большое!

Я не совсем точно изложил задачу в примере: один и тот же поставщик может поставить один и тот же товар несколько раз, при этом сосчитать его нужно только один раз, т.е. нужно только количество уникальных значений поставщиков.

Я исправил пример в файле, там же посчитано со СЧЕТЕСЛИ и показана разница.

Автор - Bamboo
Дата добавления - 02.07.2014 в 12:37
_Boroda_ Дата: Среда, 02.07.2014, 12:55 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ((B$4:B$20=A24)/СЧЁТЕСЛИ(A$4:A$20;A$4:A$20))
К сообщению приложен файл: 5011375_1.xlsx(9.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ((B$4:B$20=A24)/СЧЁТЕСЛИ(A$4:A$20;A$4:A$20))

Автор - _Boroda_
Дата добавления - 02.07.2014 в 12:55
Bamboo Дата: Среда, 02.07.2014, 14:11 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_

Спасибо большое!

Я не понимаю логики этой формулы отсюда вопрос: "Вставил в свой файл, формула дала дробные значения в (в~100 раз меньше фактических), а должны быть целые числа. В чем может быть проблема?"

Работает конечно же очень медленно.
 
Ответить
Сообщение_Boroda_

Спасибо большое!

Я не понимаю логики этой формулы отсюда вопрос: "Вставил в свой файл, формула дала дробные значения в (в~100 раз меньше фактических), а должны быть целые числа. В чем может быть проблема?"

Работает конечно же очень медленно.

Автор - Bamboo
Дата добавления - 02.07.2014 в 14:11
_Boroda_ Дата: Среда, 02.07.2014, 14:23 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ну да, там не совсем то
вот так
Код
=СУММ(--ЕЧИСЛО(1/(ПОИСКПОЗ(A$4:A$20&F3;A$4:A$20&B$4:B$20;)=СТРОКА(A$1:A$17))))

формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
К сообщению приложен файл: 5011375_2.xlsx(9.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНу да, там не совсем то
вот так
Код
=СУММ(--ЕЧИСЛО(1/(ПОИСКПОЗ(A$4:A$20&F3;A$4:A$20&B$4:B$20;)=СТРОКА(A$1:A$17))))

формула массива. Вводится одновременным нажатием Контрл Шифт Ентер

Автор - _Boroda_
Дата добавления - 02.07.2014 в 14:23
Bamboo Дата: Среда, 02.07.2014, 14:51 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_

Спасибо большое!

В функции СТРОКА как то странной указан диапазон А1:А17, хотя значения находятся в диапазоне А4:А20. Такое ощущение, что он сместился. Если же исправляешь на правильный диапазон, то функция возвращает 0.

См. файл примера
К сообщению приложен файл: 6125008.xlsx(9.0 Kb)
 
Ответить
Сообщение_Boroda_

Спасибо большое!

В функции СТРОКА как то странной указан диапазон А1:А17, хотя значения находятся в диапазоне А4:А20. Такое ощущение, что он сместился. Если же исправляешь на правильный диапазон, то функция возвращает 0.

См. файл примера

Автор - Bamboo
Дата добавления - 02.07.2014 в 14:51
_Boroda_ Дата: Среда, 02.07.2014, 15:02 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если же исправляешь на правильный диапазон, то функция возвращает 0
Я знаю. А кто вообще Вам сказал, что 4:20 в СТРОКА - это правильный диапазон? Ничего никуда не сместилось. Хотите 4:20 - пишите СТРОКА(A$4:A$20)-3
Нам нужен массив 1,2,3,...16,17. СТРОКА(1:17) как раз его и дает


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Если же исправляешь на правильный диапазон, то функция возвращает 0
Я знаю. А кто вообще Вам сказал, что 4:20 в СТРОКА - это правильный диапазон? Ничего никуда не сместилось. Хотите 4:20 - пишите СТРОКА(A$4:A$20)-3
Нам нужен массив 1,2,3,...16,17. СТРОКА(1:17) как раз его и дает

Автор - _Boroda_
Дата добавления - 02.07.2014 в 15:02
Bamboo Дата: Среда, 02.07.2014, 16:50 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_

Спасибо, получилось! но выборочно проверить очень тяжело, т.к. медленно работает.
Логика хитрая была!
 
Ответить
Сообщение _Boroda_

Спасибо, получилось! но выборочно проверить очень тяжело, т.к. медленно работает.
Логика хитрая была!

Автор - Bamboo
Дата добавления - 02.07.2014 в 16:50
lacosst Дата: Четверг, 04.06.2015, 16:45 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Подскажите пожалуйста, можно ли эту формулу использовать не для заданного диапазона, а на для всего (A:A)
Код
=СУММ(--ЕЧИСЛО(1/(ПОИСКПОЗ(A$4:A$20&F3;A$4:A$20&B$4:B$20;)=СТРОКА(A$1:A$17))))
 
Ответить
СообщениеПодскажите пожалуйста, можно ли эту формулу использовать не для заданного диапазона, а на для всего (A:A)
Код
=СУММ(--ЕЧИСЛО(1/(ПОИСКПОЗ(A$4:A$20&F3;A$4:A$20&B$4:B$20;)=СТРОКА(A$1:A$17))))

Автор - lacosst
Дата добавления - 04.06.2015 в 16:45
lacosst Дата: Пятница, 05.06.2015, 13:18 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, У меня динамический диапазон, т.е. каждый день новый набор данных от 100 до 500 значений, а иногда может быть и несколько тысяч, если сделать выборку за несколько дней.

Решил проблему, задал большой диапазон, я почему-то думал что нельзя чтоб были пустые ячейки)).
[moder]Поздравляю!
Эта тема закрыта.


Сообщение отредактировал _Boroda_ - Пятница, 05.06.2015, 13:26
 
Ответить
Сообщение_Boroda_, У меня динамический диапазон, т.е. каждый день новый набор данных от 100 до 500 значений, а иногда может быть и несколько тысяч, если сделать выборку за несколько дней.

Решил проблему, задал большой диапазон, я почему-то думал что нельзя чтоб были пустые ячейки)).
[moder]Поздравляю!
Эта тема закрыта.

Автор - lacosst
Дата добавления - 05.06.2015 в 13:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт количества уникальных текстовых значений по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!