Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как развернуть строку (столбец)? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как развернуть строку (столбец)?
Как развернуть строку (столбец)?
RAN Дата: Понедельник, 25.06.2012, 16:57 | Сообщение № 1
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5252
Репутация: 1054 ±
Замечаний: 0% ±

2010
Приветствую!
Можно-ли используя стандартные средства интерфейса развернуть строку (столбец).
В файле пример того, как не нужно.
К сообщению приложен файл: 5883586.xls(38.5 Kb)


Быть или не быть, вот в чем загвоздка!

Сообщение отредактировал RAN - Понедельник, 25.06.2012, 16:58
 
Ответить
СообщениеПриветствую!
Можно-ли используя стандартные средства интерфейса развернуть строку (столбец).
В файле пример того, как не нужно.

Автор - RAN
Дата добавления - 25.06.2012 в 16:57
Serge_007 Дата: Понедельник, 25.06.2012, 17:09 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13303
Репутация: ±
Замечаний: ±

Excel 2010
Код
=НАИБОЛЬШИЙ($A$2:$J$2;СТОЛБЕЦ())
простая для чисел
Для текста:
Код
=ИНДЕКС($A6:$J6;;НАИБОЛЬШИЙ(СТОЛБЕЦ($A:$J);СТОЛБЕЦ()))
формула массива
Код
=ИНДЕКС($A6:$J6;;СЧЁТЗ($A6:$J6)-СТОЛБЕЦ()+1)
простая


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=НАИБОЛЬШИЙ($A$2:$J$2;СТОЛБЕЦ())
простая для чисел
Для текста:
Код
=ИНДЕКС($A6:$J6;;НАИБОЛЬШИЙ(СТОЛБЕЦ($A:$J);СТОЛБЕЦ()))
формула массива
Код
=ИНДЕКС($A6:$J6;;СЧЁТЗ($A6:$J6)-СТОЛБЕЦ()+1)
простая

Автор - Serge_007
Дата добавления - 25.06.2012 в 17:09
RAN Дата: Понедельник, 25.06.2012, 17:42 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5252
Репутация: 1054 ±
Замечаний: 0% ±

2010
Serge_007, ты не понял.
Средствами интерфейса, а не формулами.
Ну типа мышкой пощелкать... smile


Быть или не быть, вот в чем загвоздка!
 
Ответить
Сообщение Serge_007, ты не понял.
Средствами интерфейса, а не формулами.
Ну типа мышкой пощелкать... smile

Автор - RAN
Дата добавления - 25.06.2012 в 17:42
Serge_007 Дата: Понедельник, 25.06.2012, 17:49 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13303
Репутация: ±
Замечаний: ±

Excel 2010
Quote (RAN)
Средствами интерфейса, а не формулами

А функции для формул по-твоему не на интерфейсе можно выбирать? wink
Да и строка формул тоже на нём. И мастер функций вызывается из него

2007/2010 Excel: Группа Сортировка и фильтр, Сортировка - Параметры - Столбцы диапазона
Но, ясен перец, это на месте сортировка


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Quote (RAN)
Средствами интерфейса, а не формулами

А функции для формул по-твоему не на интерфейсе можно выбирать? wink
Да и строка формул тоже на нём. И мастер функций вызывается из него

2007/2010 Excel: Группа Сортировка и фильтр, Сортировка - Параметры - Столбцы диапазона
Но, ясен перец, это на месте сортировка

Автор - Serge_007
Дата добавления - 25.06.2012 в 17:49
vikttur Дата: Понедельник, 25.06.2012, 19:24 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2923
Репутация: 525 ±
Замечаний: 0% ±

Quote (Serge_007)
простая для чисел

А если перемешано?
Code
=ИНДЕКС($A$6:$J$6;11-СТОЛБЕЦ(A1))

Вместо "11" можно СЧЕТЗ()

Как "типа мышкой" - не знаю. Развернуть монитор на 180. Но тогда 6 и 9 можно перепутать smile


Сообщение отредактировал vikttur - Понедельник, 25.06.2012, 19:25
 
Ответить
Сообщение
Quote (Serge_007)
простая для чисел

А если перемешано?
Code
=ИНДЕКС($A$6:$J$6;11-СТОЛБЕЦ(A1))

Вместо "11" можно СЧЕТЗ()

Как "типа мышкой" - не знаю. Развернуть монитор на 180. Но тогда 6 и 9 можно перепутать smile

Автор - vikttur
Дата добавления - 25.06.2012 в 19:24
Serge_007 Дата: Понедельник, 25.06.2012, 19:37 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13303
Репутация: ±
Замечаний: ±

Excel 2010
Quote (vikttur)
Вместо "11" можно СЧЕТЗ()

Лучше, наверное, ЧИСЛСТОЛБ(), если пустые будут.
Хотя в примере их нет...


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Quote (vikttur)
Вместо "11" можно СЧЕТЗ()

Лучше, наверное, ЧИСЛСТОЛБ(), если пустые будут.
Хотя в примере их нет...

Автор - Serge_007
Дата добавления - 25.06.2012 в 19:37
RAN Дата: Понедельник, 25.06.2012, 21:02 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5252
Репутация: 1054 ±
Замечаний: 0% ±

2010
В примере, в примере...
Написал ответ, да отвлекли - отправить не нажал. biggrin
Сортировка - она отсортирует в обратном порядке, а не развернет. А меня интересует аналог транспонирования. Но не на 90 градусов, а на 180.
Макрос - это хорошо, а если надо работать на компе, где их нет?
Вы думаете, я эти формулы запомню и воспроизведу по памяти?
Я с 0 макрос быстрее напишу!... biggrin
Т.е. в интерфейсе ничего подобного нет? И будем юзать макрос?


Быть или не быть, вот в чем загвоздка!
 
Ответить
СообщениеВ примере, в примере...
Написал ответ, да отвлекли - отправить не нажал. biggrin
Сортировка - она отсортирует в обратном порядке, а не развернет. А меня интересует аналог транспонирования. Но не на 90 градусов, а на 180.
Макрос - это хорошо, а если надо работать на компе, где их нет?
Вы думаете, я эти формулы запомню и воспроизведу по памяти?
Я с 0 макрос быстрее напишу!... biggrin
Т.е. в интерфейсе ничего подобного нет? И будем юзать макрос?

Автор - RAN
Дата добавления - 25.06.2012 в 21:02
Serge_007 Дата: Понедельник, 25.06.2012, 21:03 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 13303
Репутация: ±
Замечаний: ±

Excel 2010
Quote (RAN)
отсортирует в обратном порядке, а не развернет

А в чём разница?!


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Quote (RAN)
отсортирует в обратном порядке, а не развернет

А в чём разница?!

Автор - Serge_007
Дата добавления - 25.06.2012 в 21:03
RAN Дата: Понедельник, 25.06.2012, 21:08 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5252
Репутация: 1054 ±
Замечаний: 0% ±

2010
а-б-в <=> в-б-а

а-в-б <=> б-в-а


Быть или не быть, вот в чем загвоздка!
 
Ответить
Сообщениеа-б-в <=> в-б-а

а-в-б <=> б-в-а

Автор - RAN
Дата добавления - 25.06.2012 в 21:08
Serge_007 Дата: Понедельник, 25.06.2012, 21:10 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 13303
Репутация: ±
Замечаний: ±

Excel 2010
А, ну да...
Значит запиши формулы на бумажке smile
Нет таких средств в Excel, да и не нужны они обычно юзерам...
Цель-то какая? Глядишь - что нибудь да придумаем smile


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеА, ну да...
Значит запиши формулы на бумажке smile
Нет таких средств в Excel, да и не нужны они обычно юзерам...
Цель-то какая? Глядишь - что нибудь да придумаем smile

Автор - Serge_007
Дата добавления - 25.06.2012 в 21:10
RAN Дата: Понедельник, 25.06.2012, 21:41 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5252
Репутация: 1054 ±
Замечаний: 0% ±

2010
Меня в основном интересовало ЛЬЗЯ (я плохо искал) / НЕЛЬЗЯ (будем макрос юзать). smile
Придется портабле надстройку сделать.


Быть или не быть, вот в чем загвоздка!
 
Ответить
СообщениеМеня в основном интересовало ЛЬЗЯ (я плохо искал) / НЕЛЬЗЯ (будем макрос юзать). smile
Придется портабле надстройку сделать.

Автор - RAN
Дата добавления - 25.06.2012 в 21:41
SM Дата: Понедельник, 25.06.2012, 21:55 | Сообщение № 12
Группа: Друзья
Ранг: Участник
Сообщений: 64
Репутация: 59 ±
Замечаний: 0% ±

2003
Вариант:

Код
=ИНДЕКС($A$6:$J$6;СТОЛБЕЦ($J$6)-СТОЛБЕЦ()+1)


Excel изощрён, но не злонамерен
 
Ответить
СообщениеВариант:

Код
=ИНДЕКС($A$6:$J$6;СТОЛБЕЦ($J$6)-СТОЛБЕЦ()+1)

Автор - SM
Дата добавления - 25.06.2012 в 21:55
Serge_007 Дата: Понедельник, 25.06.2012, 21:59 | Сообщение № 13
Группа: Админы
Ранг: Местный житель
Сообщений: 13303
Репутация: ±
Замечаний: ±

Excel 2010
Quote (SM)
=ИНДЕКС($A$6:$J$6;СТОЛБЕЦ($J$6)-СТОЛБЕЦ()+1)

Quote (Serge_007)
=ИНДЕКС($A6:$J6;;СЧЁТЗ($A6:$J6)-СТОЛБЕЦ()+1)

Quote (vikttur)
=ИНДЕКС($A$6:$J$6;11-СТОЛБЕЦ(A1))


Вобщем-то это уже предлагалось smile


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Quote (SM)
=ИНДЕКС($A$6:$J$6;СТОЛБЕЦ($J$6)-СТОЛБЕЦ()+1)

Quote (Serge_007)
=ИНДЕКС($A6:$J6;;СЧЁТЗ($A6:$J6)-СТОЛБЕЦ()+1)

Quote (vikttur)
=ИНДЕКС($A$6:$J$6;11-СТОЛБЕЦ(A1))


Вобщем-то это уже предлагалось smile

Автор - Serge_007
Дата добавления - 25.06.2012 в 21:59
Gustav Дата: Понедельник, 25.06.2012, 22:36 | Сообщение № 14
Группа: Друзья
Ранг: Старожил
Сообщений: 1772
Репутация: 706 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Quote (RAN)
Сортировка - она отсортирует в обратном порядке, а не развернет.

Дык добавить ниже индексную строку от 1 до 10 и по ней отсортировать столбцы в пределах диапазона из двух строк:

а б в г д е ё ж з и
10 9 8 7 6 5 4 3 2 1

и з ж ё е д г в б а
1 2 3 4 5 6 7 8 9 10


Мой tip box - яд 41001663842605
 
Ответить
Сообщение
Quote (RAN)
Сортировка - она отсортирует в обратном порядке, а не развернет.

Дык добавить ниже индексную строку от 1 до 10 и по ней отсортировать столбцы в пределах диапазона из двух строк:

а б в г д е ё ж з и
10 9 8 7 6 5 4 3 2 1

и з ж ё е д г в б а
1 2 3 4 5 6 7 8 9 10

Автор - Gustav
Дата добавления - 25.06.2012 в 22:36
Alex_ST Дата: Пятница, 10.01.2014, 21:43 | Сообщение № 15
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3107
Репутация: 586 ±
Замечаний: 0% ±

2003
Да, вариант с временным индексным столбцом, похоже, самый универсальный.



С уважением,
Алексей
MS Excel 2003 - the best!!!
 
Ответить
СообщениеДа, вариант с временным индексным столбцом, похоже, самый универсальный.

Автор - Alex_ST
Дата добавления - 10.01.2014 в 21:43
_Boroda_ Дата: Пятница, 10.01.2014, 22:25 | Сообщение № 16
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15768
Репутация: 6152 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Дык я ж про него тебе в твоей теме и написал своим вторым постом


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДык я ж про него тебе в твоей теме и написал своим вторым постом

Автор - _Boroda_
Дата добавления - 10.01.2014 в 22:25
Alex_ST Дата: Пятница, 10.01.2014, 23:26 | Сообщение № 17
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3107
Репутация: 586 ±
Замечаний: 0% ±

2003
Саш, я там же и ответил:
Спасибо, ребята.
Вариант с дополнительным нумерованным столбцом и последующей сортировкой по нему - то что надо

А здесь отписался для оценки трудов плодов :D Андрея и Кости



С уважением,
Алексей
MS Excel 2003 - the best!!!
 
Ответить
СообщениеСаш, я там же и ответил:
Спасибо, ребята.
Вариант с дополнительным нумерованным столбцом и последующей сортировкой по нему - то что надо

А здесь отписался для оценки трудов плодов :D Андрея и Кости

Автор - Alex_ST
Дата добавления - 10.01.2014 в 23:26
_Boroda_ Дата: Суббота, 11.01.2014, 01:07 | Сообщение № 18
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15768
Репутация: 6152 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А я как-то прозевал ответ этот. Мдя, после праздников нужно еще выходные недельки на 2 делать. А то усталость от отдыха накапливается.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА я как-то прозевал ответ этот. Мдя, после праздников нужно еще выходные недельки на 2 делать. А то усталость от отдыха накапливается.

Автор - _Boroda_
Дата добавления - 11.01.2014 в 01:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как развернуть строку (столбец)?
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!