Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/больше 0 либо меньше или равно 1000 это 1 или "до.." при усл - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » больше 0 либо меньше или равно 1000 это 1 или "до.." при усл (Формулы/Formulas)
больше 0 либо меньше или равно 1000 это 1 или "до.." при усл
Sharf1 Дата: Воскресенье, 04.10.2015, 17:59 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. В ячейке А1 содержится наименование продукции, в ячейке С1 вес продукции. Нужно в ячейку В1 вписать число которое будет соответствовать условию: если в А1 указано что угодно, кроме слова "яйцо", а в ячейке С1 число которое больше 0 либо меньше или равно тысячи, то это 1 (больше 1000 либо меньше или равно 2000, то это 2 и т.д.). Но если в ячейке А1 указано "яйцо", а вячейке С1 число соответствующее определённому количеству коробок (от 1 до 360 = 1 коробка, от 361 до 720 = 2-е коробки и т.д. с шагом 360) и если число коробок меньше 10, то в ячейку В1 вписывается "до 10", если равно или больше 10 коробок, то вписывается "от 10".
 
Ответить
СообщениеЗдравствуйте. В ячейке А1 содержится наименование продукции, в ячейке С1 вес продукции. Нужно в ячейку В1 вписать число которое будет соответствовать условию: если в А1 указано что угодно, кроме слова "яйцо", а в ячейке С1 число которое больше 0 либо меньше или равно тысячи, то это 1 (больше 1000 либо меньше или равно 2000, то это 2 и т.д.). Но если в ячейке А1 указано "яйцо", а вячейке С1 число соответствующее определённому количеству коробок (от 1 до 360 = 1 коробка, от 361 до 720 = 2-е коробки и т.д. с шагом 360) и если число коробок меньше 10, то в ячейку В1 вписывается "до 10", если равно или больше 10 коробок, то вписывается "от 10".

Автор - Sharf1
Дата добавления - 04.10.2015 в 17:59
ShAM Дата: Воскресенье, 04.10.2015, 18:03 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1279
Репутация: 218 ±
Замечаний: 0% ±

Excel 2010
В файле покажите что, куда, зачем.
 
Ответить
СообщениеВ файле покажите что, куда, зачем.

Автор - ShAM
Дата добавления - 04.10.2015 в 18:03
Sharf1 Дата: Воскресенье, 04.10.2015, 18:19 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Извините. Условия поменялись. Прошу админов удалить тему.
 
Ответить
СообщениеИзвините. Условия поменялись. Прошу админов удалить тему.

Автор - Sharf1
Дата добавления - 04.10.2015 в 18:19
Serge_007 Дата: Воскресенье, 04.10.2015, 18:28 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13303
Репутация: ±
Замечаний: ±

Excel 2010
Темы с форума не удаляются


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеТемы с форума не удаляются

Автор - Serge_007
Дата добавления - 04.10.2015 в 18:28
gling Дата: Воскресенье, 04.10.2015, 18:38 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2016
Репутация: 508 ±
Замечаний: 0% ±

2010
Ответ
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("яйцо";A1;1));ЕСЛИ(ЦЕЛОЕ(C1/361)+1<10;"до 10 равно "&ЦЕЛОЕ(C1/361)+1&" коробок";"от 10 равно "&ЦЕЛОЕ(C1/361)+1&" коробок");ЦЕЛОЕ(C1/1000)+1)


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 04.10.2015, 23:51
 
Ответить
СообщениеОтвет
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("яйцо";A1;1));ЕСЛИ(ЦЕЛОЕ(C1/361)+1<10;"до 10 равно "&ЦЕЛОЕ(C1/361)+1&" коробок";"от 10 равно "&ЦЕЛОЕ(C1/361)+1&" коробок");ЦЕЛОЕ(C1/1000)+1)

Автор - gling
Дата добавления - 04.10.2015 в 18:38
Sharf1 Дата: Понедельник, 05.10.2015, 13:14 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Уважаемый gling, предложил замечательный вариант для описаных мной выше условий. Однако, как я писал ранее условия изменились. Шаг остался 360, но появились дополнительные требования к количеству коробок. Прикладываю образец какие данные должны выводиться в ячейке В1.
К сообщению приложен файл: 8658020.xls(72.5 Kb)
 
Ответить
СообщениеУважаемый gling, предложил замечательный вариант для описаных мной выше условий. Однако, как я писал ранее условия изменились. Шаг остался 360, но появились дополнительные требования к количеству коробок. Прикладываю образец какие данные должны выводиться в ячейке В1.

Автор - Sharf1
Дата добавления - 05.10.2015 в 13:14
Pelena Дата: Понедельник, 05.10.2015, 14:48 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 15242
Репутация: 3340 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Так можно
Код
=ЕСЛИ(A3="яйцо";ПРОСМОТР(ОКРВВЕРХ(C3/360;1);{0;11;51;101;1001};{"до 10";"11-50";"51-100";"101-1000";"свыше 1000"});ОКРВВЕРХ(C3/1000;1))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак можно
Код
=ЕСЛИ(A3="яйцо";ПРОСМОТР(ОКРВВЕРХ(C3/360;1);{0;11;51;101;1001};{"до 10";"11-50";"51-100";"101-1000";"свыше 1000"});ОКРВВЕРХ(C3/1000;1))

Автор - Pelena
Дата добавления - 05.10.2015 в 14:48
Sharf1 Дата: Понедельник, 05.10.2015, 15:47 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Получается! Если скрестить вариант уважаемого gling и уважаемого Pelena :D

Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("яйцо";A1;1));ПРОСМОТР(ОКРВВЕРХ(C1/360;1);{0;11;51;101;1001};{"до 10";"11-50";"51-100";"101-1000";"свыше 1000"});ОКРВВЕРХ(C1/1000;1))

[moder]Оформите формулу тегами (кнопка f)![/moder]


Сообщение отредактировал Sharf1 - Понедельник, 05.10.2015, 19:33
 
Ответить
СообщениеПолучается! Если скрестить вариант уважаемого gling и уважаемого Pelena :D

Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("яйцо";A1;1));ПРОСМОТР(ОКРВВЕРХ(C1/360;1);{0;11;51;101;1001};{"до 10";"11-50";"51-100";"101-1000";"свыше 1000"});ОКРВВЕРХ(C1/1000;1))

[moder]Оформите формулу тегами (кнопка f)![/moder]

Автор - Sharf1
Дата добавления - 05.10.2015 в 15:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » больше 0 либо меньше или равно 1000 это 1 или "до.." при усл (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!