Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/=(A1*B1)+(C1*D1)+... найти сумму произведений соседних ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » =(A1*B1)+(C1*D1)+... найти сумму произведений соседних ячеек (Формулы/Formulas)
=(A1*B1)+(C1*D1)+... найти сумму произведений соседних ячеек
alexburlutsky Дата: Пятница, 01.01.2016, 20:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
=(A1*B1)+(C1*D1)+... - надо прописать эту операцию одной формулой, и без необходимости изменять эту формулу при добавлении новых столбцов.

Спасибо!
[moder]Файл с примером приложите в соответствии с Правилами форума[/moder]
К сообщению приложен файл: 0678257.xlsx(9Kb)


Сообщение отредактировал alexburlutsky - Пятница, 01.01.2016, 22:07
 
Ответить
Сообщение=(A1*B1)+(C1*D1)+... - надо прописать эту операцию одной формулой, и без необходимости изменять эту формулу при добавлении новых столбцов.

Спасибо!
[moder]Файл с примером приложите в соответствии с Правилами форума[/moder]

Автор - alexburlutsky
Дата добавления - 01.01.2016 в 20:14
Nic70y Дата: Пятница, 01.01.2016, 21:40 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3691
Репутация: 763 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ(A1:A8*B1:B8+C1:C8*D1:D8)
и т.д.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(A1:A8*B1:B8+C1:C8*D1:D8)
и т.д.

Автор - Nic70y
Дата добавления - 01.01.2016 в 21:40
alexburlutsky Дата: Пятница, 01.01.2016, 22:06 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Nic70y, Эта формула мне известна, она решает проблему с количеством строк, но не с их длиной. Я не хочу создавать гигантскую формулу на несколько стренациц, чтобы вывести одну цифру, и постоянно ее редактировать когда в строке появляются значения в новых столбцах.


Сообщение отредактировал alexburlutsky - Пятница, 01.01.2016, 22:06
 
Ответить
СообщениеNic70y, Эта формула мне известна, она решает проблему с количеством строк, но не с их длиной. Я не хочу создавать гигантскую формулу на несколько стренациц, чтобы вывести одну цифру, и постоянно ее редактировать когда в строке появляются значения в новых столбцах.

Автор - alexburlutsky
Дата добавления - 01.01.2016 в 22:06
krosav4ig Дата: Пятница, 01.01.2016, 22:20 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1425
Репутация: 587 ±
Замечаний: 0% ±

Excel 2007, 2013
alexburlutsky,
Модератор:
Файл с примером приложите в соответствии с Правилами форума


(_)Õvõ(_)
 
Ответить
Сообщениеalexburlutsky,
Модератор:
Файл с примером приложите в соответствии с Правилами форума

Автор - krosav4ig
Дата добавления - 01.01.2016 в 22:20
Светлый Дата: Пятница, 01.01.2016, 22:41 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 231
Репутация: 59 ±
Замечаний: 0% ±

Excel 2007
Как вариант, можно такую формулу построить:
Код
=СУММПРОИЗВ(ВЫБОР(СТРОКА(1:6);E2;G2;I2;K2;M2;O2);ВЫБОР(СТРОКА(1:6);F2;H2;J2;L2;N2;P2))

Можно продлить до 254 строк и соответственно список ячеек тоже продолжить.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеКак вариант, можно такую формулу построить:
Код
=СУММПРОИЗВ(ВЫБОР(СТРОКА(1:6);E2;G2;I2;K2;M2;O2);ВЫБОР(СТРОКА(1:6);F2;H2;J2;L2;N2;P2))

Можно продлить до 254 строк и соответственно список ячеек тоже продолжить.

Автор - Светлый
Дата добавления - 01.01.2016 в 22:41
Pelena Дата: Пятница, 01.01.2016, 22:50 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 10482
Репутация: 2367 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Или такой вариант
Код
=СУММПРОИЗВ((E1:Z1="Кол-во")*E2:Z2*(F1:AA1="Цена")*F2:AA2)

Диапазон можно увеличить с запасом


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИли такой вариант
Код
=СУММПРОИЗВ((E1:Z1="Кол-во")*E2:Z2*(F1:AA1="Цена")*F2:AA2)

Диапазон можно увеличить с запасом

Автор - Pelena
Дата добавления - 01.01.2016 в 22:50
AlexM Дата: Суббота, 02.01.2016, 01:00 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3242
Репутация: 810 ±
Замечаний: 0% ±

Формулу Елены можно написать так
Код
=СУММПРОИЗВ((E1:Z1="Кол-во")*E2:Z2*F2:AA2)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеФормулу Елены можно написать так
Код
=СУММПРОИЗВ((E1:Z1="Кол-во")*E2:Z2*F2:AA2)

Автор - AlexM
Дата добавления - 02.01.2016 в 01:00
Светлый Дата: Суббота, 02.01.2016, 11:12 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 231
Репутация: 59 ±
Замечаний: 0% ±

Excel 2007
Можно ещё экзотическую формулу:
Код
=СУММПРОИЗВ(ИНДЕКС(2:2;0;Ч(ИНДЕКС(СТРОКА(1:120)*2+3;)));ИНДЕКС(2:2;0;Ч(ИНДЕКС(СТРОКА(1:120)*2+4;))))

или, прошу прощения у AlexM, немного сократить его формулу:
Код
=СУММПРОИЗВ((E1:Z1=$E1)*E2:Z2*F2:AA2)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 02.01.2016, 11:32
 
Ответить
СообщениеМожно ещё экзотическую формулу:
Код
=СУММПРОИЗВ(ИНДЕКС(2:2;0;Ч(ИНДЕКС(СТРОКА(1:120)*2+3;)));ИНДЕКС(2:2;0;Ч(ИНДЕКС(СТРОКА(1:120)*2+4;))))

или, прошу прощения у AlexM, немного сократить его формулу:
Код
=СУММПРОИЗВ((E1:Z1=$E1)*E2:Z2*F2:AA2)

Автор - Светлый
Дата добавления - 02.01.2016 в 11:12
Udik Дата: Суббота, 02.01.2016, 13:41 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1300
Репутация: 162 ±
Замечаний: 0% ±

Excel 2013
такое ещё можно
Код
=СУММПРОИЗВ((ЕНЕЧЁТ(СТОЛБЕЦ(E2:S2)))*E2:S2;F2:T2)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениетакое ещё можно
Код
=СУММПРОИЗВ((ЕНЕЧЁТ(СТОЛБЕЦ(E2:S2)))*E2:S2;F2:T2)

Автор - Udik
Дата добавления - 02.01.2016 в 13:41
alexburlutsky Дата: Суббота, 02.01.2016, 17:19 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Проблема решена, выбрал последний вариант так как нет привязки к верхним заголовкам.

Всем огромнейшее спасибо! :)
 
Ответить
СообщениеПроблема решена, выбрал последний вариант так как нет привязки к верхним заголовкам.

Всем огромнейшее спасибо! :)

Автор - alexburlutsky
Дата добавления - 02.01.2016 в 17:19
AlexM Дата: Суббота, 02.01.2016, 17:23 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3242
Репутация: 810 ±
Замечаний: 0% ±

нет привязки к верхним заголовкам
Чуть короче
Код
=СУММПРОИЗВ((-1^СТОЛБЕЦ(E2:S2)<0)*E2:S2;F2:T2)
и работает во всех версиях Excel


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
нет привязки к верхним заголовкам
Чуть короче
Код
=СУММПРОИЗВ((-1^СТОЛБЕЦ(E2:S2)<0)*E2:S2;F2:T2)
и работает во всех версиях Excel

Автор - AlexM
Дата добавления - 02.01.2016 в 17:23
alexburlutsky Дата: Суббота, 02.01.2016, 17:38 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
AlexM, Спасибо!
 
Ответить
СообщениеAlexM, Спасибо!

Автор - alexburlutsky
Дата добавления - 02.01.2016 в 17:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » =(A1*B1)+(C1*D1)+... найти сумму произведений соседних ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!