Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Условное форматирование по условию с другого листа. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условное форматирование по условию с другого листа. (Формулы/Formulas)
Условное форматирование по условию с другого листа.
bumnik Дата: Суббота, 02.01.2016, 16:16 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007,2010
Здравствуйте! Условным форматированием выделяются ячейки по условию с другого листа. Не получается выделить ячейки если в условии есть знак %. Или... то, что необходимо выделить я закрасил оранжевым.
К сообщению приложен файл: _2.20.xlsx(48Kb)
 
Ответить
СообщениеЗдравствуйте! Условным форматированием выделяются ячейки по условию с другого листа. Не получается выделить ячейки если в условии есть знак %. Или... то, что необходимо выделить я закрасил оранжевым.

Автор - bumnik
Дата добавления - 02.01.2016 в 16:16
bumnik Дата: Суббота, 02.01.2016, 16:58 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007,2010
Код
=СУММ(('Общий табель'!$C$6:$C$18=БДМ№1!$C5)*(('Общий табель'!$D$6:$D$18<>БДМ№1!$D5)=(ПРАВСИМВ(БДМ№1!$D5;1)="%"))*('Общий табель'!E$6:E$18<"А")*('Общий табель'!E$6:E$18<>""))*(БДМ№1!E$4=СЕГОДНЯ())

=СУММ(('Общий табель'!$C$6:$C$18=БДМ№1!$C5)*('Общий табель'!$D$6:$D$18=БДМ№1!$D5)*('Общий табель'!E$6:E$18<"А")*('Общий табель'!E$6:E$18<>""))*(БДМ№1!E$4=СЕГОДНЯ())

что-то получилось, но не очень красиво.
К сообщению приложен файл: _2.2.xlsx(48Kb)


Сообщение отредактировал bumnik - Суббота, 02.01.2016, 17:07
 
Ответить
Сообщение
Код
=СУММ(('Общий табель'!$C$6:$C$18=БДМ№1!$C5)*(('Общий табель'!$D$6:$D$18<>БДМ№1!$D5)=(ПРАВСИМВ(БДМ№1!$D5;1)="%"))*('Общий табель'!E$6:E$18<"А")*('Общий табель'!E$6:E$18<>""))*(БДМ№1!E$4=СЕГОДНЯ())

=СУММ(('Общий табель'!$C$6:$C$18=БДМ№1!$C5)*('Общий табель'!$D$6:$D$18=БДМ№1!$D5)*('Общий табель'!E$6:E$18<"А")*('Общий табель'!E$6:E$18<>""))*(БДМ№1!E$4=СЕГОДНЯ())

что-то получилось, но не очень красиво.

Автор - bumnik
Дата добавления - 02.01.2016 в 16:58
Udik Дата: Суббота, 02.01.2016, 17:25 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1298
Репутация: 161 ±
Замечаний: 0% ±

Excel 2013
Как-то не очень понятно, что Вы хотите получить


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеКак-то не очень понятно, что Вы хотите получить

Автор - Udik
Дата добавления - 02.01.2016 в 17:25
bumnik Дата: Суббота, 02.01.2016, 17:33 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007,2010
Udik, выделить ячейку с фамилией и профессией 1) такой же как на листе "общий табель" и 2) в окончании которой есть знак %.
 
Ответить
СообщениеUdik, выделить ячейку с фамилией и профессией 1) такой же как на листе "общий табель" и 2) в окончании которой есть знак %.

Автор - bumnik
Дата добавления - 02.01.2016 в 17:33
Udik Дата: Суббота, 02.01.2016, 17:53 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1298
Репутация: 161 ±
Замечаний: 0% ±

Excel 2013
Два типа ячеек или чтобы оба правила одновременно соблюдались?


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеДва типа ячеек или чтобы оба правила одновременно соблюдались?

Автор - Udik
Дата добавления - 02.01.2016 в 17:53
bumnik Дата: Суббота, 02.01.2016, 17:57 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007,2010
Udik, оба правила одновременно.
 
Ответить
СообщениеUdik, оба правила одновременно.

Автор - bumnik
Дата добавления - 02.01.2016 в 17:57
Udik Дата: Суббота, 02.01.2016, 19:17 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1298
Репутация: 161 ±
Замечаний: 0% ±

Excel 2013
хотел массив формулу применить, но с УФ не выходит
==
вот обычная
Код
=ЕСЛИ(ПРАВСИМВ($D5)="%";СУММПРОИЗВ(Ч('Общий табель'!$C$6:$C$18=$C5);Ч(ПОДСТАВИТЬ($D5;" %";"")='Общий табель'!$D$6:$D$18));0)

УФ для 1 столбца проверил
К сообщению приложен файл: t2.xlsx(51Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Суббота, 02.01.2016, 19:48
 
Ответить
Сообщениехотел массив формулу применить, но с УФ не выходит
==
вот обычная
Код
=ЕСЛИ(ПРАВСИМВ($D5)="%";СУММПРОИЗВ(Ч('Общий табель'!$C$6:$C$18=$C5);Ч(ПОДСТАВИТЬ($D5;" %";"")='Общий табель'!$D$6:$D$18));0)

УФ для 1 столбца проверил

Автор - Udik
Дата добавления - 02.01.2016 в 19:17
Pelena Дата: Суббота, 02.01.2016, 19:52 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 10414
Репутация: 2358 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Как вариант (если правильно поняла)
Код
=СУММ(('Общий табель'!$C$6:$C$18=БДМ№1!$C5)*(('Общий табель'!$D$6:$D$18=БДМ№1!$D5)+(ПРАВСИМВ(БДМ№1!$D5)="%"))*('Общий табель'!E$6:E$18<"А")*('Общий табель'!E$6:E$18<>""))*(БДМ№1!E$4=СЕГОДНЯ())

хотел массив формулу применить, но с УФ не выходит

Формулы массива работают в УФ, причём их не надо вводить тремя пальцами
К сообщению приложен файл: 6633856.xlsx(45Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак вариант (если правильно поняла)
Код
=СУММ(('Общий табель'!$C$6:$C$18=БДМ№1!$C5)*(('Общий табель'!$D$6:$D$18=БДМ№1!$D5)+(ПРАВСИМВ(БДМ№1!$D5)="%"))*('Общий табель'!E$6:E$18<"А")*('Общий табель'!E$6:E$18<>""))*(БДМ№1!E$4=СЕГОДНЯ())

хотел массив формулу применить, но с УФ не выходит

Формулы массива работают в УФ, причём их не надо вводить тремя пальцами

Автор - Pelena
Дата добавления - 02.01.2016 в 19:52
Udik Дата: Суббота, 02.01.2016, 20:01 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1298
Репутация: 161 ±
Замечаний: 0% ±

Excel 2013
причём их не надо вводить тремя пальцами

хы, а я упорно пытался


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщение
причём их не надо вводить тремя пальцами

хы, а я упорно пытался

Автор - Udik
Дата добавления - 02.01.2016 в 20:01
bumnik Дата: Суббота, 02.01.2016, 20:08 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007,2010
Udik, Pelena, Всем СПАСИБО!!! с наступающим Рождеством! Всем ЗДОРОВЬЯ!!!
 
Ответить
СообщениеUdik, Pelena, Всем СПАСИБО!!! с наступающим Рождеством! Всем ЗДОРОВЬЯ!!!

Автор - bumnik
Дата добавления - 02.01.2016 в 20:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условное форматирование по условию с другого листа. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!