Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Содержит ли ячейка слова из других ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Содержит ли ячейка слова из других ячеек (Формулы/Formulas)
Содержит ли ячейка слова из других ячеек
Viktoria2291 Дата: Понедельник, 04.01.2016, 12:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, уважаемые форумчане. Помогите, пожалуйста, решить такую задачу.
Есть файл, в файле 2 столбца: В и С. Оба столбца содержат текстовую информацию. В ячейках столбца В содержатся полные названия продукции, состоящие из нескольких слов. В ячейках столбца С содержатся названия линий продаж. Мое задание: определить содержит ли каждое название продукции название линии продаж. Соответственно, мне нужно каждую ячейку столбца B сравнить во всем столбцом C, если хоть одно слово совпадает, то в столбце Е написать "правда", ну или как-то по-другому отметить.
Файлик с примером прикрепила.
Я пробовала разные функции, но ничего не получается, макрос тоже не получается..
Была бы вам очень благодарна за помощь, очень нужно!
К сообщению приложен файл: Template.xlsx(10Kb)
 
Ответить
СообщениеЗдравствуйте, уважаемые форумчане. Помогите, пожалуйста, решить такую задачу.
Есть файл, в файле 2 столбца: В и С. Оба столбца содержат текстовую информацию. В ячейках столбца В содержатся полные названия продукции, состоящие из нескольких слов. В ячейках столбца С содержатся названия линий продаж. Мое задание: определить содержит ли каждое название продукции название линии продаж. Соответственно, мне нужно каждую ячейку столбца B сравнить во всем столбцом C, если хоть одно слово совпадает, то в столбце Е написать "правда", ну или как-то по-другому отметить.
Файлик с примером прикрепила.
Я пробовала разные функции, но ничего не получается, макрос тоже не получается..
Была бы вам очень благодарна за помощь, очень нужно!

Автор - Viktoria2291
Дата добавления - 04.01.2016 в 12:31
Serge_007 Дата: Понедельник, 04.01.2016, 12:37 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13122
Репутация: ±
Замечаний: ±

Excel 2010
Viktoria2291, здравствуйте

Код
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК(СЖПРОБЕЛЫ(C$4:C$13);B4)))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеViktoria2291, здравствуйте

Код
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК(СЖПРОБЕЛЫ(C$4:C$13);B4)))

Автор - Serge_007
Дата добавления - 04.01.2016 в 12:37
buchlotnik Дата: Понедельник, 04.01.2016, 13:15 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2628
Репутация: 751 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Viktoria2291, здравствуйте для разнообразия через ПРОСМОТР
Код
=1-ЕОШИБКА(ПРОСМОТР(;-1/ПОИСК(СЖПРОБЕЛЫ($C$4:$C$13);B4))^0)
К сообщению приложен файл: 9721613.xlsx(11Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 04.01.2016, 13:16
 
Ответить
СообщениеViktoria2291, здравствуйте для разнообразия через ПРОСМОТР
Код
=1-ЕОШИБКА(ПРОСМОТР(;-1/ПОИСК(СЖПРОБЕЛЫ($C$4:$C$13);B4))^0)

Автор - buchlotnik
Дата добавления - 04.01.2016 в 13:15
sv2014 Дата: Вторник, 05.01.2016, 12:50 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 165
Репутация: 37 ±
Замечаний: 0% ±

Excel 2013
Viktoria2291, добрый день,Ваша тема продублирована на дружественном форуме,вот мой вариант макроса
здесь,используйте,например WinRaR,кнопка use1

[vba]
Код
Sub replica2(r As Range)
    Dim i&, x, c As Range
    For Each c In r: c = Trim(c): Next
    x = Range("B4:E" & Range("B" & Rows.Count).End(xlUp).Row).Value
        With CreateObject("vbscript.regexp"): .Pattern = Join(Application.Transpose(r), "|")
        For i = 1 To UBound(x)
           If .test(x(i, 1)) Then x(i, 4) = True Else x(i, 4) = False
        Next
      End With
    Range("B4").Resize(UBound(x), UBound(x, 2)).Value = x
End Sub
[/vba]
[vba]
Код
Sub use1()
replica2 Range("C4:C" & Range("C" & Rows.Count).End(xlUp).Row)
End Sub
[/vba]
К сообщению приложен файл: example_4_01_20.rar(15Kb)
 
Ответить
СообщениеViktoria2291, добрый день,Ваша тема продублирована на дружественном форуме,вот мой вариант макроса
здесь,используйте,например WinRaR,кнопка use1

[vba]
Код
Sub replica2(r As Range)
    Dim i&, x, c As Range
    For Each c In r: c = Trim(c): Next
    x = Range("B4:E" & Range("B" & Rows.Count).End(xlUp).Row).Value
        With CreateObject("vbscript.regexp"): .Pattern = Join(Application.Transpose(r), "|")
        For i = 1 To UBound(x)
           If .test(x(i, 1)) Then x(i, 4) = True Else x(i, 4) = False
        Next
      End With
    Range("B4").Resize(UBound(x), UBound(x, 2)).Value = x
End Sub
[/vba]
[vba]
Код
Sub use1()
replica2 Range("C4:C" & Range("C" & Rows.Count).End(xlUp).Row)
End Sub
[/vba]

Автор - sv2014
Дата добавления - 05.01.2016 в 12:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Содержит ли ячейка слова из других ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!