Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск значения ячейки из соседнего столбца по критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значения ячейки из соседнего столбца по критериям (Формулы/Formulas)
поиск значения ячейки из соседнего столбца по критериям
skr Дата: Среда, 06.01.2016, 13:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Вроде примитивная задача.
Необходимо возратить в ячейку значение столбца A напротив последнего ненулевого значения столбца B
А также возратить в ячейку значение столбца A напротив следующего за последним ненулевым значением столбца B
Заранее благодарю.
К сообщению приложен файл: 8990991.xls(26Kb)
 
Ответить
СообщениеДобрый день. Вроде примитивная задача.
Необходимо возратить в ячейку значение столбца A напротив последнего ненулевого значения столбца B
А также возратить в ячейку значение столбца A напротив следующего за последним ненулевым значением столбца B
Заранее благодарю.

Автор - skr
Дата добавления - 06.01.2016 в 13:02
Nic70y Дата: Среда, 06.01.2016, 13:07 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3925
Репутация: 832 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС(A:A;СУММПРОИЗВ(МАКС((B:B>0)*СТРОКА(B:B))))
Код
=ИНДЕКС(A:A;ПОИСКПОЗ(0;B:B;))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ИНДЕКС(A:A;СУММПРОИЗВ(МАКС((B:B>0)*СТРОКА(B:B))))
Код
=ИНДЕКС(A:A;ПОИСКПОЗ(0;B:B;))

Автор - Nic70y
Дата добавления - 06.01.2016 в 13:07
buchlotnik Дата: Среда, 06.01.2016, 13:08 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2628
Репутация: 751 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ПРОСМОТР(9^9;1/B1:B40;A1:A40)
Код
=ПРОСМОТР(9^9;1/B1:B40;A2:A41)
К сообщению приложен файл: 8512120.xls(26Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=ПРОСМОТР(9^9;1/B1:B40;A1:A40)
Код
=ПРОСМОТР(9^9;1/B1:B40;A2:A41)

Автор - buchlotnik
Дата добавления - 06.01.2016 в 13:08
gling Дата: Среда, 06.01.2016, 13:14 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1518
Репутация: 377 ±
Замечаний: 0% ±

2010
Здравствуйте.
Цитата
напротив последнего ненулевого значения
может наоборот напротив первого нулевого
Код
=ИНДЕКС($A$1:$A$40;ПОИСКПОЗ(0;$B$1:$B$40;0)-1)
Код

=ИНДЕКС($A$1:$A$40;ПОИСКПОЗ(0;$B$1:$B$40;0))


Сообщение отредактировал gling - Среда, 06.01.2016, 13:15
 
Ответить
СообщениеЗдравствуйте.
Цитата
напротив последнего ненулевого значения
может наоборот напротив первого нулевого
Код
=ИНДЕКС($A$1:$A$40;ПОИСКПОЗ(0;$B$1:$B$40;0)-1)
Код

=ИНДЕКС($A$1:$A$40;ПОИСКПОЗ(0;$B$1:$B$40;0))

Автор - gling
Дата добавления - 06.01.2016 в 13:14
jakim Дата: Среда, 06.01.2016, 13:24 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 764
Репутация: 197 ±
Замечаний: 0% ±

Если в стобце А цифры расположены в порядке возрастания то можно применить и такие формулы

Код
=AGGREGATE(14;6;A1:A40/(B1:B40<>0);1)

Код
=AGGREGATE(15;6;A1:A40/(B1:B40=0);1)
 
Ответить
Сообщение
Если в стобце А цифры расположены в порядке возрастания то можно применить и такие формулы

Код
=AGGREGATE(14;6;A1:A40/(B1:B40<>0);1)

Код
=AGGREGATE(15;6;A1:A40/(B1:B40=0);1)

Автор - jakim
Дата добавления - 06.01.2016 в 13:24
skr Дата: Среда, 06.01.2016, 13:31 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем спасибо. Действительно все просто.
buchlotnik как всегда удивил. Если не секрет можно пояснить. 9 в степени 9?
 
Ответить
СообщениеВсем спасибо. Действительно все просто.
buchlotnik как всегда удивил. Если не секрет можно пояснить. 9 в степени 9?

Автор - skr
Дата добавления - 06.01.2016 в 13:31
skr Дата: Среда, 06.01.2016, 13:38 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо jakim, что открыл для меня такую интересную функцию
 
Ответить
СообщениеСпасибо jakim, что открыл для меня такую интересную функцию

Автор - skr
Дата добавления - 06.01.2016 в 13:38
buchlotnik Дата: Среда, 06.01.2016, 13:46 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2628
Репутация: 751 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
9 в степени 9
просто очень большое число, чтоб ПРОСМОТР() раньше конца столбца поиск не закончил (по факту после 1/B1:B40 массив состоит из каких-то значений и ошибок деления на ноль, ПРОСМОТР ищет очень большое число, не находит и останавливается на последнем числовом значении)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 06.01.2016, 13:48
 
Ответить
Сообщение
Цитата
9 в степени 9
просто очень большое число, чтоб ПРОСМОТР() раньше конца столбца поиск не закончил (по факту после 1/B1:B40 массив состоит из каких-то значений и ошибок деления на ноль, ПРОСМОТР ищет очень большое число, не находит и останавливается на последнем числовом значении)

Автор - buchlotnik
Дата добавления - 06.01.2016 в 13:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значения ячейки из соседнего столбца по критериям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!