Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сводная таблица суммы формулами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сводная таблица суммы формулами (Формулы/Formulas)
Сводная таблица суммы формулами
Мурад Дата: Четверг, 14.01.2016, 16:54 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 415
Репутация: 17 ±
Замечаний: 0% ±

Excel 2007
Привет! Как реализовать аналог сводной таблицы формулами? В частности, для приложенного примера. Спасибо!
К сообщению приложен файл: example.xlsx(10Kb)
 
Ответить
СообщениеПривет! Как реализовать аналог сводной таблицы формулами? В частности, для приложенного примера. Спасибо!

Автор - Мурад
Дата добавления - 14.01.2016 в 16:54
Мурад Дата: Четверг, 14.01.2016, 17:19 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 415
Репутация: 17 ±
Замечаний: 0% ±

Excel 2007
Если в атрибуте3 вас смущают "б" и "в" их можно заменить на другие. В принципе, наименования атрибутов одного уровня не будут повторяться в других уровнях.
 
Ответить
СообщениеЕсли в атрибуте3 вас смущают "б" и "в" их можно заменить на другие. В принципе, наименования атрибутов одного уровня не будут повторяться в других уровнях.

Автор - Мурад
Дата добавления - 14.01.2016 в 17:19
TimSha Дата: Четверг, 14.01.2016, 17:31 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 491
Репутация: 76 ±
Замечаний: 0% ±

Excel 2013 Pro +
Как реализовать

Выбрать уникальные из первых трех полей, а далее элементарно - СУММЕСЛИ...
Можно воспользоваться и редизайнером. Как вариант/ы, разумеется... ;)


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)

Сообщение отредактировал TimSha - Четверг, 14.01.2016, 17:35
 
Ответить
Сообщение
Как реализовать

Выбрать уникальные из первых трех полей, а далее элементарно - СУММЕСЛИ...
Можно воспользоваться и редизайнером. Как вариант/ы, разумеется... ;)

Автор - TimSha
Дата добавления - 14.01.2016 в 17:31
gling Дата: Четверг, 14.01.2016, 19:25 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1402
Репутация: 343 ±
Замечаний: 0% ±

2010
Может так надо?
Код
=СУММПРОИЗВ(($B$2:$D$19=A22)*($E$2:$E$19))
К сообщению приложен файл: example-6-.xlsx(11Kb)
 
Ответить
СообщениеМожет так надо?
Код
=СУММПРОИЗВ(($B$2:$D$19=A22)*($E$2:$E$19))

Автор - gling
Дата добавления - 14.01.2016 в 19:25
Мурад Дата: Пятница, 15.01.2016, 12:42 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 415
Репутация: 17 ±
Замечаний: 0% ±

Excel 2007
gling, Спасибо! Не знал, что Суммпроизв работает с многомерными массивами :)
 
Ответить
Сообщениеgling, Спасибо! Не знал, что Суммпроизв работает с многомерными массивами :)

Автор - Мурад
Дата добавления - 15.01.2016 в 12:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сводная таблица суммы формулами (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!