Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма по отдельности написанных через дробь чисел. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по отдельности написанных через дробь чисел. (Формулы/Formulas)
Сумма по отдельности написанных через дробь чисел.
mikolafnv Дата: Пятница, 15.01.2016, 11:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Уважаемые ГУРУ EXCEL!!! Интересует формула подсчета суммы чисел написанных через дробь, помогите если не затруднит. Спасибо!!! hands
К сообщению приложен файл: 9775291.xlsx(10Kb)
 
Ответить
СообщениеУважаемые ГУРУ EXCEL!!! Интересует формула подсчета суммы чисел написанных через дробь, помогите если не затруднит. Спасибо!!! hands

Автор - mikolafnv
Дата добавления - 15.01.2016 в 11:09
_Boroda_ Дата: Пятница, 15.01.2016, 11:19 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(--ЛЕВБ(0&A3:E3;ПОИСК("/";A3:E3)))&"/"&СУММПРОИЗВ(--ПСТР(A3:E3&0;ПОИСК("/";A3:E3)+1;9))/10

или формула массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=СУММ(--ЛЕВБ(0&A3:E3;ПОИСК("/";A3:E3)))&"/"&СУММ(--ПСТР(A3:E3&0;ПОИСК("/";A3:E3)+1;9))/10


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(--ЛЕВБ(0&A3:E3;ПОИСК("/";A3:E3)))&"/"&СУММПРОИЗВ(--ПСТР(A3:E3&0;ПОИСК("/";A3:E3)+1;9))/10

или формула массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=СУММ(--ЛЕВБ(0&A3:E3;ПОИСК("/";A3:E3)))&"/"&СУММ(--ПСТР(A3:E3&0;ПОИСК("/";A3:E3)+1;9))/10

Автор - _Boroda_
Дата добавления - 15.01.2016 в 11:19
pabchek Дата: Пятница, 15.01.2016, 11:19 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 745
Репутация: 168 ±
Замечаний: 0% ±

Excel 2007
У меня вот так получилось. Формула массива (кнтрл+шифт+ентер одновременно)
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(A3:E3;1;ПОИСК("/";A3:E3)-1);0))&"/"&СУММ(ЕСЛИОШИБКА(--ПСТР(A3:E3;ПОИСК("/";A3:E3)+1;9);0))
К сообщению приложен файл: 6112271.xlsx(9Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеУ меня вот так получилось. Формула массива (кнтрл+шифт+ентер одновременно)
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(A3:E3;1;ПОИСК("/";A3:E3)-1);0))&"/"&СУММ(ЕСЛИОШИБКА(--ПСТР(A3:E3;ПОИСК("/";A3:E3)+1;9);0))

Автор - pabchek
Дата добавления - 15.01.2016 в 11:19
Nic70y Дата: Пятница, 15.01.2016, 11:30 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4078
Репутация: 870 ±
Замечаний: 0% ±

Excel 2013
для разнообразия
Код
=СУММПРОИЗВ(ЦЕЛОЕ(ПОДСТАВИТЬ(A3:E3;"/";",")))&"/"&СУММПРОИЗВ(--ПРАВБ(ПОДСТАВИТЬ(A3:E3;"/";"000000000000000");15))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениедля разнообразия
Код
=СУММПРОИЗВ(ЦЕЛОЕ(ПОДСТАВИТЬ(A3:E3;"/";",")))&"/"&СУММПРОИЗВ(--ПРАВБ(ПОДСТАВИТЬ(A3:E3;"/";"000000000000000");15))

Автор - Nic70y
Дата добавления - 15.01.2016 в 11:30
mikolafnv Дата: Пятница, 15.01.2016, 11:47 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Можно еще по такому примеру, требования те же самые. Спасибо!
К сообщению приложен файл: 15.01.16.xlsx(15Kb)


Сообщение отредактировал mikolafnv - Пятница, 15.01.2016, 12:16
 
Ответить
СообщениеМожно еще по такому примеру, требования те же самые. Спасибо!

Автор - mikolafnv
Дата добавления - 15.01.2016 в 11:47
sv2014 Дата: Пятница, 15.01.2016, 15:06 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 166
Репутация: 37 ±
Замечаний: 0% ±

Excel 2013
mikolafnv, добрый день вариант формулами aaa1 aaa2 vvv,в ячейках красного цвета.

[vba]
Код
Function vvv(r1 As Range, r2 As Range)
  Dim x1, x2, y1, y2
   x1 = Val(Split(r1, "/")(0))
   y1 = Val(Split(r1, "/")(1))
   x2 = Val(Split(r2, "/")(0))
   y2 = Val(Split(r2, "/")(1))
   vvv = x1 + x2 & "/" & y1 + y2
End Function
[/vba]

[vba]
Код
Function aaa1$(rng As Range)
    Dim x, y, r As Range
For Each r In rng
If r.Offset(-1, 0).Value = "Д" Then
   x = x + Val(Split(r, "/")(0))
   y = y + Val(Split(r, "/")(1))
End If
Next
    aaa1 = x & "/" & y
End Function
[/vba]

[vba]
Код
Function aaa2$(rng As Range)
    Dim x, y, r As Range
For Each r In rng
If r.Offset(-1, 0).Value = "Н" Then
   x = x + Val(Split(r, "/")(0))
   y = y + Val(Split(r, "/")(1))
End If
Next
    aaa2 = x & "/" & y
End Function
[/vba]
К сообщению приложен файл: example_16_01_2.xls(48Kb)


Сообщение отредактировал sv2014 - Пятница, 15.01.2016, 15:23
 
Ответить
Сообщениеmikolafnv, добрый день вариант формулами aaa1 aaa2 vvv,в ячейках красного цвета.

[vba]
Код
Function vvv(r1 As Range, r2 As Range)
  Dim x1, x2, y1, y2
   x1 = Val(Split(r1, "/")(0))
   y1 = Val(Split(r1, "/")(1))
   x2 = Val(Split(r2, "/")(0))
   y2 = Val(Split(r2, "/")(1))
   vvv = x1 + x2 & "/" & y1 + y2
End Function
[/vba]

[vba]
Код
Function aaa1$(rng As Range)
    Dim x, y, r As Range
For Each r In rng
If r.Offset(-1, 0).Value = "Д" Then
   x = x + Val(Split(r, "/")(0))
   y = y + Val(Split(r, "/")(1))
End If
Next
    aaa1 = x & "/" & y
End Function
[/vba]

[vba]
Код
Function aaa2$(rng As Range)
    Dim x, y, r As Range
For Each r In rng
If r.Offset(-1, 0).Value = "Н" Then
   x = x + Val(Split(r, "/")(0))
   y = y + Val(Split(r, "/")(1))
End If
Next
    aaa2 = x & "/" & y
End Function
[/vba]

Автор - sv2014
Дата добавления - 15.01.2016 в 15:06
_Boroda_ Дата: Пятница, 15.01.2016, 16:09 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Формулами
К сообщению приложен файл: 15.01.16_1.xlsx(15Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФормулами

Автор - _Boroda_
Дата добавления - 15.01.2016 в 16:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по отдельности написанных через дробь чисел. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!