Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверка текста в ячейке1 и подстановка знака в ячейке2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка текста в ячейке1 и подстановка знака в ячейке2 (Формулы/Formulas)
Проверка текста в ячейке1 и подстановка знака в ячейке2
ZBestNub Дата: Пятница, 15.01.2016, 12:46 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!

Задача такая:

Есть тип операции "пополнение", "списание", "покупка" и т.д. в одном столбце
и
числа в другом.

Не получается написать формулу, которая бы проверяла ячейку с текстом на совпадение и, если истина - подставляло бы знак "-" к числам в другой ячейке
[moder]Кладите файл-пример
К сообщению приложен файл: Book.xlsx(9Kb)


Сообщение отредактировал ZBestNub - Пятница, 15.01.2016, 12:52
 
Ответить
СообщениеДобрый день!

Задача такая:

Есть тип операции "пополнение", "списание", "покупка" и т.д. в одном столбце
и
числа в другом.

Не получается написать формулу, которая бы проверяла ячейку с текстом на совпадение и, если истина - подставляло бы знак "-" к числам в другой ячейке
[moder]Кладите файл-пример

Автор - ZBestNub
Дата добавления - 15.01.2016 в 12:46
_Boroda_ Дата: Пятница, 15.01.2016, 12:58 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11327
Репутация: 4676 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно? В соседнюю ячейку
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A2;E$2:E$99;));-B2;B2)

В строках 23, 24 и 29 сделайте нормальные числа, а не текст
К сообщению приложен файл: Book_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно? В соседнюю ячейку
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A2;E$2:E$99;));-B2;B2)

В строках 23, 24 и 29 сделайте нормальные числа, а не текст

Автор - _Boroda_
Дата добавления - 15.01.2016 в 12:58
abtextime Дата: Пятница, 15.01.2016, 13:10 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(ВПР(A2;$A$31:$B$36;2;0)="плюс";B2;-B2)

чуть по-другому, но суть та же, что у мэтра _Boroda_
К сообщению приложен файл: _Book.xlsx(10Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(ВПР(A2;$A$31:$B$36;2;0)="плюс";B2;-B2)

чуть по-другому, но суть та же, что у мэтра _Boroda_

Автор - abtextime
Дата добавления - 15.01.2016 в 13:10
ZBestNub Дата: Пятница, 15.01.2016, 13:11 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A2;E$2:E$99;));-B2;B2)

Да, так, спасибо! =)

Извиняюсь, вопрос к Мэтру -)
А если мне необходимо в отдельную ячейку дополнительно суммировать все цифры, которые без знака минус (простой вариант), либо все цифры из строк, содержащих "Зачисление"
Пример файла тот же в принципе.
[moder]Второй вопрос нарушает п. 5g Правил форума[/moder]

Хм.
5.
На форуме запрещено:
g - использовать при написании постов крупный шрифт (крупнее 12 pt), а так же набирать всё сообщение прописными буквами;

1. Шрифт не менял.
2. Курсив вообще не использовал.

Нащальникэ, что я нарушил-то в итоге?(( Так надеялся на Вашу помощь :(


Сообщение отредактировал ZBestNub - Пятница, 15.01.2016, 15:37
 
Ответить
Сообщение
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A2;E$2:E$99;));-B2;B2)

Да, так, спасибо! =)

Извиняюсь, вопрос к Мэтру -)
А если мне необходимо в отдельную ячейку дополнительно суммировать все цифры, которые без знака минус (простой вариант), либо все цифры из строк, содержащих "Зачисление"
Пример файла тот же в принципе.
[moder]Второй вопрос нарушает п. 5g Правил форума[/moder]

Хм.
5.
На форуме запрещено:
g - использовать при написании постов крупный шрифт (крупнее 12 pt), а так же набирать всё сообщение прописными буквами;

1. Шрифт не менял.
2. Курсив вообще не использовал.

Нащальникэ, что я нарушил-то в итоге?(( Так надеялся на Вашу помощь :(

Автор - ZBestNub
Дата добавления - 15.01.2016 в 13:11
китин Дата: Пятница, 15.01.2016, 14:52 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4331
Репутация: 673 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так, пока МЭТРа нету [moder]Ответ удален


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал _Boroda_ - Пятница, 15.01.2016, 15:07
 
Ответить
Сообщениетак, пока МЭТРа нету [moder]Ответ удален

Автор - китин
Дата добавления - 15.01.2016 в 14:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка текста в ячейке1 и подстановка знака в ячейке2 (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!