Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заливка ячеек между датами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заливка ячеек между датами (Формулы/Formulas)
Заливка ячеек между датами
CHEVRYACHOK Дата: Пятница, 15.01.2016, 16:40 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер!
Подскажите, пожалуйста, как можно сделать заливку между двумя датами, которые соответствуют месяцам.
В примере показано визуально.
Заранее благодарен!
К сообщению приложен файл: 2054793.xlsx(9Kb)
 
Ответить
СообщениеДобрый вечер!
Подскажите, пожалуйста, как можно сделать заливку между двумя датами, которые соответствуют месяцам.
В примере показано визуально.
Заранее благодарен!

Автор - CHEVRYACHOK
Дата добавления - 15.01.2016 в 16:40
_Boroda_ Дата: Пятница, 15.01.2016, 16:47 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вот изврат в условном форматировании (для текущего года)
Код
=ТЕКСТ(МЕДИАНА($C8:$D8;1&E$6);"МММ")=E$6

Или классика
Код
=($C8<=--(1&E$6))*(КОНМЕСЯЦА($D8;0)>=--(1&E$6))

Код
=И(--(1&E$6)>=$C8;--(1&E$6)<=$D8)
К сообщению приложен файл: 2054793_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вот изврат в условном форматировании (для текущего года)
Код
=ТЕКСТ(МЕДИАНА($C8:$D8;1&E$6);"МММ")=E$6

Или классика
Код
=($C8<=--(1&E$6))*(КОНМЕСЯЦА($D8;0)>=--(1&E$6))

Код
=И(--(1&E$6)>=$C8;--(1&E$6)<=$D8)

Автор - _Boroda_
Дата добавления - 15.01.2016 в 16:47
SLAVICK Дата: Пятница, 15.01.2016, 16:53 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1924
Репутация: 650 ±
Замечаний: 0% ±

2007,2010,2013,2016
Условное форматирование:
Код
=И(--ТЕКСТ(1&E$6;0)>=$C8;--ТЕКСТ(1&E$6;0)<=$D8)

или короче:
Код
=И(--(1&E$6)>=$C8;--(1&E$6)<=$D8)
К сообщению приложен файл: 1300372.xlsx(9Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеУсловное форматирование:
Код
=И(--ТЕКСТ(1&E$6;0)>=$C8;--ТЕКСТ(1&E$6;0)<=$D8)

или короче:
Код
=И(--(1&E$6)>=$C8;--(1&E$6)<=$D8)

Автор - SLAVICK
Дата добавления - 15.01.2016 в 16:53
CHEVRYACHOK Дата: Пятница, 15.01.2016, 17:08 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо!
Скажите, если в одной строке не будет дат, то закрашиваются все 12 мес. Этого можно как-то избежать?
 
Ответить
СообщениеСпасибо!
Скажите, если в одной строке не будет дат, то закрашиваются все 12 мес. Этого можно как-то избежать?

Автор - CHEVRYACHOK
Дата добавления - 15.01.2016 в 17:08
CHEVRYACHOK Дата: Пятница, 15.01.2016, 17:10 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
SLAVICK, большое спасибо! )))
 
Ответить
СообщениеSLAVICK, большое спасибо! )))

Автор - CHEVRYACHOK
Дата добавления - 15.01.2016 в 17:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заливка ячеек между датами (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!