Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нахождение фрагмента в ячейке и присваивание ему значения. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение фрагмента в ячейке и присваивание ему значения. (Формулы/Formulas)
Нахождение фрагмента в ячейке и присваивание ему значения.
of1 Дата: Вторник, 19.01.2016, 17:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Помогите, пожалуйста. Задача в следующем. Есть массив значений. В нем определенному сочетанию цифр и определенному сочетанию букв присвоено какое-то значение. Есть таблица, в ней три столбца. В первый выгружаются цифро-буквенные значения. Необходимо,чтобы во второй столбец автоматически заполнялось значение, присвоенное сочетанию цифр из массива, в третий столбец - значение, присвоенное сочетанию букв из массива. Массив - более ста значений.
К сообщению приложен файл: 1796027.xlsx(11Kb)
 
Ответить
СообщениеПомогите, пожалуйста. Задача в следующем. Есть массив значений. В нем определенному сочетанию цифр и определенному сочетанию букв присвоено какое-то значение. Есть таблица, в ней три столбца. В первый выгружаются цифро-буквенные значения. Необходимо,чтобы во второй столбец автоматически заполнялось значение, присвоенное сочетанию цифр из массива, в третий столбец - значение, присвоенное сочетанию букв из массива. Массив - более ста значений.

Автор - of1
Дата добавления - 19.01.2016 в 17:10
Pelena Дата: Вторник, 19.01.2016, 17:26 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10400
Репутация: 2354 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=ПРОСМОТР(2;1/ПОИСК($E$3:$E$6;A4);$F$3:$F$6)
К сообщению приложен файл: 2206383.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ПРОСМОТР(2;1/ПОИСК($E$3:$E$6;A4);$F$3:$F$6)

Автор - Pelena
Дата добавления - 19.01.2016 в 17:26
buchlotnik Дата: Вторник, 19.01.2016, 17:27 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2198
Репутация: 647 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ПРОСМОТР(;-ПОИСК($H$3:$H$6;A4);$I$3:$I$6)
К сообщению приложен файл: 9023104.xlsx(10Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=ПРОСМОТР(;-ПОИСК($H$3:$H$6;A4);$I$3:$I$6)

Автор - buchlotnik
Дата добавления - 19.01.2016 в 17:27
_Boroda_ Дата: Вторник, 19.01.2016, 17:51 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9818
Репутация: 4146 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А если будут пары 2063 и 63? Или SSS и SS
Предлагаю так
Код
=ВПР(-ПРОСМОТР(;-ПСТР(A4;1;СТРОКА(A$1:A$9)));H$3:I$7;2;)

Код
=ВПР(ПСТР(A4;ПРОСМОТР(;-ПСТР(A4;СТРОКА(A$1:A$9);1);СТРОКА(A$1:A$9))+1;9);J$3:K$7;2;)
К сообщению приложен файл: 9023104_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА если будут пары 2063 и 63? Или SSS и SS
Предлагаю так
Код
=ВПР(-ПРОСМОТР(;-ПСТР(A4;1;СТРОКА(A$1:A$9)));H$3:I$7;2;)

Код
=ВПР(ПСТР(A4;ПРОСМОТР(;-ПСТР(A4;СТРОКА(A$1:A$9);1);СТРОКА(A$1:A$9))+1;9);J$3:K$7;2;)

Автор - _Boroda_
Дата добавления - 19.01.2016 в 17:51
of1 Дата: Среда, 20.01.2016, 10:47 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=ВПР(ПСТР(A4;ПРОСМОТР(;-ПСТР(A4;СТРОКА(A$1:A$9);1);СТРОКА(A$1:A$9))+1;9);J$3:K$7;2;)


Все работает,спасибо!

Еще один вопрос. Как в формуле ограничить количество выбираемых и сравниваемых букв. К примеру обозначение 1111ABC.U1. Необходимо, чтобы сравнивалось только первые три буквы ABC
[moder]Огласите весь список типовых вариантов


Сообщение отредактировал _Boroda_ - Среда, 20.01.2016, 10:53
 
Ответить
Сообщение
=ВПР(ПСТР(A4;ПРОСМОТР(;-ПСТР(A4;СТРОКА(A$1:A$9);1);СТРОКА(A$1:A$9))+1;9);J$3:K$7;2;)


Все работает,спасибо!

Еще один вопрос. Как в формуле ограничить количество выбираемых и сравниваемых букв. К примеру обозначение 1111ABC.U1. Необходимо, чтобы сравнивалось только первые три буквы ABC
[moder]Огласите весь список типовых вариантов

Автор - of1
Дата добавления - 20.01.2016 в 10:47
of1 Дата: Среда, 20.01.2016, 14:03 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Типовые варианты могут значительно различаться по длине. Константой является наличие до 4-х цифр в начале и следующие за ними 3 буквы, к примеру:
1111ASD23.U1
1111ASD23.90N
111ASD.N
1111ASD
 
Ответить
СообщениеТиповые варианты могут значительно различаться по длине. Константой является наличие до 4-х цифр в начале и следующие за ними 3 буквы, к примеру:
1111ASD23.U1
1111ASD23.90N
111ASD.N
1111ASD

Автор - of1
Дата добавления - 20.01.2016 в 14:03
_Boroda_ Дата: Среда, 20.01.2016, 14:16 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9818
Репутация: 4146 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если
следующие за ними 3 буквы
, то замените здесь
))+1;9);J$3:K$7
9 на 3
Код
=ВПР(ПСТР(A4;ПРОСМОТР(;-ПСТР(A4;СТРОКА(A$1:A$9);1);СТРОКА(A$1:A$9))+1;3);J$3:K$7;2;)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли
следующие за ними 3 буквы
, то замените здесь
))+1;9);J$3:K$7
9 на 3
Код
=ВПР(ПСТР(A4;ПРОСМОТР(;-ПСТР(A4;СТРОКА(A$1:A$9);1);СТРОКА(A$1:A$9))+1;3);J$3:K$7;2;)

Автор - _Boroda_
Дата добавления - 20.01.2016 в 14:16
of1 Дата: Понедельник, 25.01.2016, 09:11 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо. Буду сидеть, разбираться.
 
Ответить
СообщениеСпасибо. Буду сидеть, разбираться.

Автор - of1
Дата добавления - 25.01.2016 в 09:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение фрагмента в ячейке и присваивание ему значения. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!