Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчёт при большом количестве условий [РЕШЕНО] - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт при большом количестве условий [РЕШЕНО] (Формулы/Formulas)
Расчёт при большом количестве условий [РЕШЕНО]
kremkov Дата: Четверг, 21.01.2016, 17:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Исходные данные. Пол человека, его ступень (4,5,6) и таблица результатов на бронзу серебро и золото. Мы вводим результат, который выполнил человек. Формула должна проверить какой у него пол, к какой ступени он относится и в зависимости от этого проверить на какую медаль он выполнил норматив. Результатом должна быть буква (б,с,з) или цвет ячейки. В идеале цвет ячейки в которую мы вводим результат или по соседству.
Думаю более менее понятно объяснил.
Я пытался сделать так
Код
=ЕСЛИ(B2="м";ПРОСМОТР(A2;{4;5;6};{ЕСЛИ(C2>=L4;"з";ЕСЛИ(C2>=K4;"с";ЕСЛИ(C2>=J4;"б";"нет")));ЕСЛИ(C2>=L6;"з";ЕСЛИ(C2>=K6;"с";ЕСЛИ(C2>=J6;"б";"нет")));ЕСЛИ(C2>=L8;"з";ЕСЛИ(C2>=K8;"с";ЕСЛИ(C2>=J8;"б";"нет")))});ПРОСМОТР(A2;{4;5;6};{ЕСЛИ(C2>=O4;"з";ЕСЛИ(C2>=N4;"с";ЕСЛИ(C2>=M4;"б";"нет")));ЕСЛИ(C2>=O6;"з";ЕСЛИ(C2>=N6;"с";ЕСЛИ(C2>=M6;"б";"нет")));ЕСЛИ(C2>=O8;"з";ЕСЛИ(C2>=N8;"с";ЕСЛИ(C2>=M8;"б";"нет")))}))

Но показывает ошибку на ЕСЛИ в функции ПРОСМОТР
[moder]Формулы нужно обтягивать кнопкой fx, а не спойлером.
Поправила.[/moder]
К сообщению приложен файл: 3536101.xls(30Kb)


Сообщение отредактировал kremkov - Пятница, 22.01.2016, 10:35
 
Ответить
СообщениеИсходные данные. Пол человека, его ступень (4,5,6) и таблица результатов на бронзу серебро и золото. Мы вводим результат, который выполнил человек. Формула должна проверить какой у него пол, к какой ступени он относится и в зависимости от этого проверить на какую медаль он выполнил норматив. Результатом должна быть буква (б,с,з) или цвет ячейки. В идеале цвет ячейки в которую мы вводим результат или по соседству.
Думаю более менее понятно объяснил.
Я пытался сделать так
Код
=ЕСЛИ(B2="м";ПРОСМОТР(A2;{4;5;6};{ЕСЛИ(C2>=L4;"з";ЕСЛИ(C2>=K4;"с";ЕСЛИ(C2>=J4;"б";"нет")));ЕСЛИ(C2>=L6;"з";ЕСЛИ(C2>=K6;"с";ЕСЛИ(C2>=J6;"б";"нет")));ЕСЛИ(C2>=L8;"з";ЕСЛИ(C2>=K8;"с";ЕСЛИ(C2>=J8;"б";"нет")))});ПРОСМОТР(A2;{4;5;6};{ЕСЛИ(C2>=O4;"з";ЕСЛИ(C2>=N4;"с";ЕСЛИ(C2>=M4;"б";"нет")));ЕСЛИ(C2>=O6;"з";ЕСЛИ(C2>=N6;"с";ЕСЛИ(C2>=M6;"б";"нет")));ЕСЛИ(C2>=O8;"з";ЕСЛИ(C2>=N8;"с";ЕСЛИ(C2>=M8;"б";"нет")))}))

Но показывает ошибку на ЕСЛИ в функции ПРОСМОТР
[moder]Формулы нужно обтягивать кнопкой fx, а не спойлером.
Поправила.[/moder]

Автор - kremkov
Дата добавления - 21.01.2016 в 17:13
Udik Дата: Четверг, 21.01.2016, 17:50 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1293
Репутация: 161 ±
Замечаний: 0% ±

Excel 2013
Вот вариант
Код

=ЕСЛИОШИБКА(ПРОСМОТР(C7;СМЕЩ($I$1;ПОИСКПОЗ(A7;$I$2:$I$8;0);1+3*(B7=$M$3);1;3);$J$2:$L$2);"-!!-")

Выводит полное название, переделать несложно. Чтобы формулы не наворачивать вынес ступени в левый столбец таблички. Цвет в УФ править.
К сообщению приложен файл: 4543585.xls(40Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Четверг, 21.01.2016, 18:02
 
Ответить
СообщениеВот вариант
Код

=ЕСЛИОШИБКА(ПРОСМОТР(C7;СМЕЩ($I$1;ПОИСКПОЗ(A7;$I$2:$I$8;0);1+3*(B7=$M$3);1;3);$J$2:$L$2);"-!!-")

Выводит полное название, переделать несложно. Чтобы формулы не наворачивать вынес ступени в левый столбец таблички. Цвет в УФ править.

Автор - Udik
Дата добавления - 21.01.2016 в 17:50
YouGreed Дата: Четверг, 21.01.2016, 17:59 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
kremkov, Портачит, нет времени доделать(с работы ухожу)
Код
=ПРОСМОТР($C2;ВЫБОР(ЕСЛИ($B2="м";1;2);ВЫБОР(ЕСЛИ($A2=4;1;ЕСЛИ($A2=5;2;3));$J$2:$L$2;$J$3:$L$3;$J$4:$L$4);ВЫБОР(ЕСЛИ($A2=4;1;ЕСЛИ($A2=5;2;3));$J$5:$L$5;$J$6:$L$6;$J$7:$L$7));$J$1:$L$1)
К сообщению приложен файл: --.xls(26Kb)
 
Ответить
Сообщениеkremkov, Портачит, нет времени доделать(с работы ухожу)
Код
=ПРОСМОТР($C2;ВЫБОР(ЕСЛИ($B2="м";1;2);ВЫБОР(ЕСЛИ($A2=4;1;ЕСЛИ($A2=5;2;3));$J$2:$L$2;$J$3:$L$3;$J$4:$L$4);ВЫБОР(ЕСЛИ($A2=4;1;ЕСЛИ($A2=5;2;3));$J$5:$L$5;$J$6:$L$6;$J$7:$L$7));$J$1:$L$1)

Автор - YouGreed
Дата добавления - 21.01.2016 в 17:59
_Boroda_ Дата: Четверг, 21.01.2016, 18:02 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9795
Репутация: 4138 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно? Немасивная формула
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(C2;ИНДЕКС((J$3:L$8;M$3:O$8);(A2-3)*2;;1+(B2="ж")));)

Раскраска и буквы - Условным форматированием
К сообщению приложен файл: 3536101_1.xls(46Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно? Немасивная формула
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(C2;ИНДЕКС((J$3:L$8;M$3:O$8);(A2-3)*2;;1+(B2="ж")));)

Раскраска и буквы - Условным форматированием

Автор - _Boroda_
Дата добавления - 21.01.2016 в 18:02
kremkov Дата: Пятница, 22.01.2016, 10:33 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо всем. Бороде + за самую короткую формулу
 
Ответить
СообщениеСпасибо всем. Бороде + за самую короткую формулу

Автор - kremkov
Дата добавления - 22.01.2016 в 10:33
_Boroda_ Дата: Пятница, 22.01.2016, 11:27 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9795
Репутация: 4138 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
[offtop]Спасибо за плюс.
kremkov, меня все время удивлял один товарищ, периодически задающий вопросы здесь. Удивлял своей формулировкой обоснования того, что кому-то из отвечающих репу поднял, а всем остальным - нет. Что-то типа Вашей "за самую короткую формулу". Но он учитель, у него это до костей мозга уже въелось. А Вы-то что? У Вас что, один плюс? Или они Вам денег стоят? Люди старались, думали, хотели Вам помочь, а Вы конкурс устраиваете. Зачем?
Это мое личное мнение, но я думаю, что правильнее было бы или ставить всем, кто предложил решение (а не просто отметился в теме каким-то комментарием), или не ставить никому.
Дмитрий, только не подумайте чего, я нисколько не утверждаю, что мое мнение именно самое верное, и ни к чему не призываю. Скорее, я просто высказываю его. Побурчать захотелось почему-то.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение[offtop]Спасибо за плюс.
kremkov, меня все время удивлял один товарищ, периодически задающий вопросы здесь. Удивлял своей формулировкой обоснования того, что кому-то из отвечающих репу поднял, а всем остальным - нет. Что-то типа Вашей "за самую короткую формулу". Но он учитель, у него это до костей мозга уже въелось. А Вы-то что? У Вас что, один плюс? Или они Вам денег стоят? Люди старались, думали, хотели Вам помочь, а Вы конкурс устраиваете. Зачем?
Это мое личное мнение, но я думаю, что правильнее было бы или ставить всем, кто предложил решение (а не просто отметился в теме каким-то комментарием), или не ставить никому.
Дмитрий, только не подумайте чего, я нисколько не утверждаю, что мое мнение именно самое верное, и ни к чему не призываю. Скорее, я просто высказываю его. Побурчать захотелось почему-то.

Автор - _Boroda_
Дата добавления - 22.01.2016 в 11:27
kremkov Дата: Пятница, 22.01.2016, 11:51 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
[offtop]_Boroda_, на самом деле Вас я отметил как наиболее подходящее решение для меня, а в репу получили все. А побурчать это хорошо, расслабляет.[/offtop]
[moder]Ну и славно. Извините, ежели чего не так - никого обидеть не хотел.


Сообщение отредактировал _Boroda_ - Пятница, 22.01.2016, 11:58
 
Ответить
Сообщение[offtop]_Boroda_, на самом деле Вас я отметил как наиболее подходящее решение для меня, а в репу получили все. А побурчать это хорошо, расслабляет.[/offtop]
[moder]Ну и славно. Извините, ежели чего не так - никого обидеть не хотел.

Автор - kremkov
Дата добавления - 22.01.2016 в 11:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт при большом количестве условий [РЕШЕНО] (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!