Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Авто. склонение слова"человек" в зависимости от кол-ва. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Авто. склонение слова"человек" в зависимости от кол-ва. (Формулы/Formulas)
Авто. склонение слова"человек" в зависимости от кол-ва.
DrMini Дата: Пятница, 22.01.2016, 10:31 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 193
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010, 2013
Можно сделать автоматическое написание количества людей (человек) прописью склоняя слово "человек"? Пробовал через условное форматирование, но видимо не туда копаю. Максимум будет 15 человек. Надо изменить слово "человек" на "человека" только 3 раза. Когда людей "два", "три", "четыре". Подскажите куда копать. Файл прилагаю.
К сообщению приложен файл: ____.xlsm(28Kb)
 
Ответить
СообщениеМожно сделать автоматическое написание количества людей (человек) прописью склоняя слово "человек"? Пробовал через условное форматирование, но видимо не туда копаю. Максимум будет 15 человек. Надо изменить слово "человек" на "человека" только 3 раза. Когда людей "два", "три", "четыре". Подскажите куда копать. Файл прилагаю.

Автор - DrMini
Дата добавления - 22.01.2016 в 10:31
YouGreed Дата: Пятница, 22.01.2016, 10:46 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
DrMini, Так?
Код
=ЕСЛИОШИБКА(ВПР($C$10;Человек;2;);"человек")
К сообщению приложен файл: 2491922.xlsm(27Kb)
 
Ответить
СообщениеDrMini, Так?
Код
=ЕСЛИОШИБКА(ВПР($C$10;Человек;2;);"человек")

Автор - YouGreed
Дата добавления - 22.01.2016 в 10:46
SLAVICK Дата: Пятница, 22.01.2016, 10:49 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1924
Репутация: 650 ±
Замечаний: 0% ±

2007,2010,2013,2016
Можно с вспомогательной таблицей + впр.
Тогда не нужно даже писать количество вручную - достаточно поменять цифру.
см. зеленые ячейки
К сообщению приложен файл: 7470572.xlsm(28Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеМожно с вспомогательной таблицей + впр.
Тогда не нужно даже писать количество вручную - достаточно поменять цифру.
см. зеленые ячейки

Автор - SLAVICK
Дата добавления - 22.01.2016 в 10:49
_Boroda_ Дата: Пятница, 22.01.2016, 11:00 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
формулой
Код
=МАКС(A13:A29)
и форматом ячейки
[<2]"человек";[>4]"человек";"человека"
К сообщению приложен файл: 2653450.xlsm(28Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеформулой
Код
=МАКС(A13:A29)
и форматом ячейки
[<2]"человек";[>4]"человек";"человека"

Автор - _Boroda_
Дата добавления - 22.01.2016 в 11:00
Wasilich Дата: Пятница, 22.01.2016, 11:06 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1100
Репутация: 298 ±
Замечаний: 0% ±

2003
Максимум будет 15 человек.

Код
=ЕСЛИ(ИЛИ(A1=2;A1=3;A1=4);"Человека";"Человек")

Код
=ЕСЛИ(ИЛИ(A1="два";A1="три";A1="четыре");"Человека";"Человек")


Сообщение отредактировал Wasilic - Пятница, 22.01.2016, 11:10
 
Ответить
Сообщение
Максимум будет 15 человек.

Код
=ЕСЛИ(ИЛИ(A1=2;A1=3;A1=4);"Человека";"Человек")

Код
=ЕСЛИ(ИЛИ(A1="два";A1="три";A1="четыре");"Человека";"Человек")

Автор - Wasilich
Дата добавления - 22.01.2016 в 11:06
китин Дата: Пятница, 22.01.2016, 11:07 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3724
Репутация: 587 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или так
Код
=ВПР(--ПРАВБ('#'!$A$1;1);{1;"человек":2;"человека":3;"человека":4;"человека":5;"человек":6;"человек":7;"человек":8;"человек":9;"человек":0;"человек"};2;0)
К сообщению приложен файл: DrMini.xlsm(27Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеили так
Код
=ВПР(--ПРАВБ('#'!$A$1;1);{1;"человек":2;"человека":3;"человека":4;"человека":5;"человек":6;"человек":7;"человек":8;"человек":9;"человек":0;"человек"};2;0)

Автор - китин
Дата добавления - 22.01.2016 в 11:07
DrMini Дата: Пятница, 22.01.2016, 11:33 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 193
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010, 2013
YouGreed, Не работает.
 
Ответить
СообщениеYouGreed, Не работает.

Автор - DrMini
Дата добавления - 22.01.2016 в 11:33
YouGreed Дата: Пятница, 22.01.2016, 11:36 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
DrMini, Поправил(( Файл смотрите.
К сообщению приложен файл: 9721782.xlsm(27Kb)
 
Ответить
СообщениеDrMini, Поправил(( Файл смотрите.

Автор - YouGreed
Дата добавления - 22.01.2016 в 11:36
DrMini Дата: Пятница, 22.01.2016, 11:37 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 193
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010, 2013
_Boroda_, Спасибо. yes Всё работает. И диапазон можно изменить.
hands hands hands
 
Ответить
Сообщение_Boroda_, Спасибо. yes Всё работает. И диапазон можно изменить.
hands hands hands

Автор - DrMini
Дата добавления - 22.01.2016 в 11:37
DrMini Дата: Пятница, 22.01.2016, 13:47 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 193
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010, 2013
YouGreed, При заполнении колонки "Фамилия Имя Отчество" количество не изменяется. Спасибо за участие. Проблема решена. _Boroda_, очень помог.
 
Ответить
СообщениеYouGreed, При заполнении колонки "Фамилия Имя Отчество" количество не изменяется. Спасибо за участие. Проблема решена. _Boroda_, очень помог.

Автор - DrMini
Дата добавления - 22.01.2016 в 13:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Авто. склонение слова"человек" в зависимости от кол-ва. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!