Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор значения из множества вариантов (упростить "если") - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения из множества вариантов (упростить "если") (Формулы/Formulas)
Выбор значения из множества вариантов (упростить "если")
Jopio Дата: Воскресенье, 24.01.2016, 09:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
соб-но сама формула
Код
=ЕСЛИ(C3="Ремонт у клиента";
(ЕСЛИ((F3-H3)<1000;(F3-H3)*$L$13;0))
+ЕСЛИ(((F3-H3)<2000)*И((F3-H3)>=1000);(F3-H3)*$L$14;0)
+ЕСЛИ(((F3-H3)<3000)*И((F3-H3)>=2000);(F3-H3)*$L$15;0)
+ЕСЛИ(((F3-H3)<4000)*И((F3-H3)>=3000);(F3-H3)*$L$16;0)
+ЕСЛИ((F3-H3)>=4000;(F3-H3)*$L$17;0))
+ЕСЛИ(C3="Дела";F3*$L$19;0)
+ЕСЛИ(C3="Гарантия";F3*$L$18;0)
+ЕСЛИ(ИЛИ((C3="Принял в ремонт");(C3="Выдал из ремонта"))*И(E3="Офис");$L$25;0)
+ЕСЛИ(ИЛИ((C3="Принял в ремонт");(C3="Выдал из ремонта"))*И(E3<>"Офис");F3;0)
+ЕСЛИ(C3="Ремонт в офисе";(F3-H3)*$L$24;0)


табличка прикреплена
проблема в том, что начальнику не нравится много вложенных "если"

"Ты сделал типа:
If i=2 then i:=3
If i=3 then i:=2

А я хочу
i:=5-i"

действительно-ли это можно как-то упростить? и если да, то как?
и да, в работе используется онлайн версия таблиц гугла, из-за чего не выходит сделать привязку к столбцу таблицы вроде [@Столбец], т.к. нельзя вставить таблицу... или это таки как-то можно, но я не нашёл как?
[moder]Дайте теме более конкретное название в соответствии с Правилами форума и оформите формулу тегами (кнопка fx). До исправления замечаний просьба помогающим не отвечать.Замечание устранено[/moder]
К сообщению приложен файл: 3395868.xlsx(13Kb)


Сообщение отредактировал Pelena - Воскресенье, 24.01.2016, 10:18
 
Ответить
Сообщениесоб-но сама формула
Код
=ЕСЛИ(C3="Ремонт у клиента";
(ЕСЛИ((F3-H3)<1000;(F3-H3)*$L$13;0))
+ЕСЛИ(((F3-H3)<2000)*И((F3-H3)>=1000);(F3-H3)*$L$14;0)
+ЕСЛИ(((F3-H3)<3000)*И((F3-H3)>=2000);(F3-H3)*$L$15;0)
+ЕСЛИ(((F3-H3)<4000)*И((F3-H3)>=3000);(F3-H3)*$L$16;0)
+ЕСЛИ((F3-H3)>=4000;(F3-H3)*$L$17;0))
+ЕСЛИ(C3="Дела";F3*$L$19;0)
+ЕСЛИ(C3="Гарантия";F3*$L$18;0)
+ЕСЛИ(ИЛИ((C3="Принял в ремонт");(C3="Выдал из ремонта"))*И(E3="Офис");$L$25;0)
+ЕСЛИ(ИЛИ((C3="Принял в ремонт");(C3="Выдал из ремонта"))*И(E3<>"Офис");F3;0)
+ЕСЛИ(C3="Ремонт в офисе";(F3-H3)*$L$24;0)


табличка прикреплена
проблема в том, что начальнику не нравится много вложенных "если"

"Ты сделал типа:
If i=2 then i:=3
If i=3 then i:=2

А я хочу
i:=5-i"

действительно-ли это можно как-то упростить? и если да, то как?
и да, в работе используется онлайн версия таблиц гугла, из-за чего не выходит сделать привязку к столбцу таблицы вроде [@Столбец], т.к. нельзя вставить таблицу... или это таки как-то можно, но я не нашёл как?
[moder]Дайте теме более конкретное название в соответствии с Правилами форума и оформите формулу тегами (кнопка fx). До исправления замечаний просьба помогающим не отвечать.Замечание устранено[/moder]

Автор - Jopio
Дата добавления - 24.01.2016 в 09:14
buchlotnik Дата: Воскресенье, 24.01.2016, 10:12 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 645 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Если вспомагательные таблицы немножко переделать можно так:
Код
=ЕСЛИ(E3="Офис";ВПР(C3;$Q$24:$R$26;2;0)*F3;ЕСЛИ(C3="Ремонт у клиента";ВПР(F3-H3;$Q$13:$R$21;2;1);ВПР(C3;$Q$13:$R$21;2;1))*(F3-H3))
К сообщению приложен файл: 5184301.xlsx(13Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеЕсли вспомагательные таблицы немножко переделать можно так:
Код
=ЕСЛИ(E3="Офис";ВПР(C3;$Q$24:$R$26;2;0)*F3;ЕСЛИ(C3="Ремонт у клиента";ВПР(F3-H3;$Q$13:$R$21;2;1);ВПР(C3;$Q$13:$R$21;2;1))*(F3-H3))

Автор - buchlotnik
Дата добавления - 24.01.2016 в 10:12
Jopio Дата: Воскресенье, 24.01.2016, 23:37 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Если вспомагательные таблицы немножко переделать можно так:

большое спасибо, принцип работы формулы понял. думаю, что-то такое как раз подойдёт (выглядит кратко и лаконично)
 
Ответить
Сообщение
Если вспомагательные таблицы немножко переделать можно так:

большое спасибо, принцип работы формулы понял. думаю, что-то такое как раз подойдёт (выглядит кратко и лаконично)

Автор - Jopio
Дата добавления - 24.01.2016 в 23:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения из множества вариантов (упростить "если") (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!