Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование значений при условии заполнения влияющих ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование значений при условии заполнения влияющих ячеек (Формулы/Formulas)
Суммирование значений при условии заполнения влияющих ячеек
VadimVV Дата: Понедельник, 25.01.2016, 11:22 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 79
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Добрый день.

Необходимо подсчитать сумму значений при заполнении ячеек, оказывающих влияние на итоговый результат.
Т.е. есть значение 250, которое выполняется с вероятностью 90, т.е. итог - 225.
Таких поля со значениями 4, полей для вероятности тоже 4. Если заполнено поле значения, но не заполнено поле вероятности, итоговое значение должно быть =0 (это важно).

Пробовал через логические функции, но, к сожалению, в этом случае должны быть заполнены все 4 поля вероятностей, даже если заполнено 1 или 2 поля значений.

Пример с описанием во вложении.
К сообщению приложен файл: 5502518.xlsx(13Kb)


Сообщение отредактировал VadimVV - Понедельник, 25.01.2016, 11:23
 
Ответить
СообщениеДобрый день.

Необходимо подсчитать сумму значений при заполнении ячеек, оказывающих влияние на итоговый результат.
Т.е. есть значение 250, которое выполняется с вероятностью 90, т.е. итог - 225.
Таких поля со значениями 4, полей для вероятности тоже 4. Если заполнено поле значения, но не заполнено поле вероятности, итоговое значение должно быть =0 (это важно).

Пробовал через логические функции, но, к сожалению, в этом случае должны быть заполнены все 4 поля вероятностей, даже если заполнено 1 или 2 поля значений.

Пример с описанием во вложении.

Автор - VadimVV
Дата добавления - 25.01.2016 в 11:22
buchlotnik Дата: Понедельник, 25.01.2016, 11:28 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=СУММПРОИЗВ((B3:B6)*(1-B8:B11)*(B8:B11<>0))

или так?
Код
=СУММПРОИЗВ((B3:B6)*(1-B8:B11)*(1-ЕПУСТО(B8:B11)))
К сообщению приложен файл: 47786.xlsx(14Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 25.01.2016, 11:32
 
Ответить
Сообщениетак нужно?
Код
=СУММПРОИЗВ((B3:B6)*(1-B8:B11)*(B8:B11<>0))

или так?
Код
=СУММПРОИЗВ((B3:B6)*(1-B8:B11)*(1-ЕПУСТО(B8:B11)))

Автор - buchlotnik
Дата добавления - 25.01.2016 в 11:28
VadimVV Дата: Понедельник, 25.01.2016, 11:39 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 79
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Да, первая формула подходит. Спасибо!
 
Ответить
СообщениеДа, первая формула подходит. Спасибо!

Автор - VadimVV
Дата добавления - 25.01.2016 в 11:39
pabchek Дата: Понедельник, 25.01.2016, 11:44 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
А мне показалось что нужно чтобы было 0 или ошибка, если одно из полей вероятности равно 0, а соответствующее значение из верхних ячеек 0 не равно. Если это верно, то предлагаю такую формулу
Код
=СУММПРОИЗВ(B3:B6*(1-B8:B11)*(СУММ((B3:B6<>0)-(B8:B11>0))=0))


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеА мне показалось что нужно чтобы было 0 или ошибка, если одно из полей вероятности равно 0, а соответствующее значение из верхних ячеек 0 не равно. Если это верно, то предлагаю такую формулу
Код
=СУММПРОИЗВ(B3:B6*(1-B8:B11)*(СУММ((B3:B6<>0)-(B8:B11>0))=0))

Автор - pabchek
Дата добавления - 25.01.2016 в 11:44
VadimVV Дата: Понедельник, 25.01.2016, 11:53 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 79
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Да, это тоже верно. Я просто не подумал, что если стоит 0 в вероятности, то значение дохода можно игнорировать и, соответственно, его не суммировать.
 
Ответить
СообщениеДа, это тоже верно. Я просто не подумал, что если стоит 0 в вероятности, то значение дохода можно игнорировать и, соответственно, его не суммировать.

Автор - VadimVV
Дата добавления - 25.01.2016 в 11:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование значений при условии заполнения влияющих ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!