Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Номер по порядку в таблице - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Номер по порядку в таблице (Формулы/Formulas)
Номер по порядку в таблице
ПАМ Дата: Понедельник, 25.01.2016, 13:38 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, Уважаемые знатоки Excel. Помогите пожалуйста мне разобраться.
У меня есть таблица в ней № по порядку (столбец А) и ФИО (столбец В - в примере просто имя).
Как мне найти нужный номер по ФИО сверху таблицы то есть если например мне нужен Саша то в ячейке (напр А1) его номер по порядку в данной таблице.

Пробовал функции ВПР, ГПР, ПОИСКПОЗ не получается, возможно недопонимаю смысл этих функций.

Помогите мне пожалуйста. Заранее благодарен от всей души. Спасибо.
К сообщению приложен файл: 1949784.xlsx(9Kb)
 
Ответить
СообщениеЗдравствуйте, Уважаемые знатоки Excel. Помогите пожалуйста мне разобраться.
У меня есть таблица в ней № по порядку (столбец А) и ФИО (столбец В - в примере просто имя).
Как мне найти нужный номер по ФИО сверху таблицы то есть если например мне нужен Саша то в ячейке (напр А1) его номер по порядку в данной таблице.

Пробовал функции ВПР, ГПР, ПОИСКПОЗ не получается, возможно недопонимаю смысл этих функций.

Помогите мне пожалуйста. Заранее благодарен от всей души. Спасибо.

Автор - ПАМ
Дата добавления - 25.01.2016 в 13:38
_Boroda_ Дата: Понедельник, 25.01.2016, 13:41 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вы почти правильно сделали
Код
=ПОИСКПОЗ(B4;B2:B6;0)

Код
=ИНДЕКС(A2:A6;ПОИСКПОЗ(B3;B2:B6;))

Код
=ПОИСКПОЗ("Сашок";B2:B6;0)

Если имена отсортированы, то
Код
=ПРОСМОТР(A9;B2:B6;A2:A6)
К сообщению приложен файл: 1949784_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВы почти правильно сделали
Код
=ПОИСКПОЗ(B4;B2:B6;0)

Код
=ИНДЕКС(A2:A6;ПОИСКПОЗ(B3;B2:B6;))

Код
=ПОИСКПОЗ("Сашок";B2:B6;0)

Если имена отсортированы, то
Код
=ПРОСМОТР(A9;B2:B6;A2:A6)

Автор - _Boroda_
Дата добавления - 25.01.2016 в 13:41
lFJl Дата: Понедельник, 25.01.2016, 13:42 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 231
Репутация: 5 ±
Замечаний: 0% ±

Excel 2007
Так?
К сообщению приложен файл: 6751656.xlsx(9Kb)
 
Ответить
СообщениеТак?

Автор - lFJl
Дата добавления - 25.01.2016 в 13:42
buchlotnik Дата: Понедельник, 25.01.2016, 13:44 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2630
Репутация: 751 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
диапазон поправьте
Код
=ПОИСКПОЗ(B4;B2:B6;0)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениедиапазон поправьте
Код
=ПОИСКПОЗ(B4;B2:B6;0)

Автор - buchlotnik
Дата добавления - 25.01.2016 в 13:44
ПАМ Дата: Понедельник, 25.01.2016, 13:45 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Александр, спасибо БОЛЬШОЕ, а можно как то изменить формулу, чтобы она искала через названия, а не по ячейкам?
Пример выложил
К сообщению приложен файл: 1406207.xlsx(9Kb)
 
Ответить
Сообщение_Boroda_, Александр, спасибо БОЛЬШОЕ, а можно как то изменить формулу, чтобы она искала через названия, а не по ячейкам?
Пример выложил

Автор - ПАМ
Дата добавления - 25.01.2016 в 13:45
ПАМ Дата: Понедельник, 25.01.2016, 13:46 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, lFJl, прошу прощения господа, ваше ответы не увидел пока писал ответ Многоуважаемому Александру!Спасибо и Вам тоже.
 
Ответить
Сообщениеbuchlotnik, lFJl, прошу прощения господа, ваше ответы не увидел пока писал ответ Многоуважаемому Александру!Спасибо и Вам тоже.

Автор - ПАМ
Дата добавления - 25.01.2016 в 13:46
ПАМ Дата: Понедельник, 25.01.2016, 13:49 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Ваш последний вариант для меня идеален спасибо ОГРОМНОЕ. Тему можно закрыть.

[p.s.]я просто вначале только Вашу 1 формулу увидел, поэтому добавил пост. Еще раз спасибо.
 
Ответить
Сообщение_Boroda_, Ваш последний вариант для меня идеален спасибо ОГРОМНОЕ. Тему можно закрыть.

[p.s.]я просто вначале только Вашу 1 формулу увидел, поэтому добавил пост. Еще раз спасибо.

Автор - ПАМ
Дата добавления - 25.01.2016 в 13:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Номер по порядку в таблице (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!