Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать количество выделенных цветом ячеек. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать количество выделенных цветом ячеек. (Формулы/Formulas)
Посчитать количество выделенных цветом ячеек.
baneska Дата: Понедельник, 25.01.2016, 13:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер. :)

С помощью УФ я выделила цветом нужные ячейки (столбец K - разница). Теперь, для моей задачи нужно выполнить следующее:
1. Посчитать количество волн, группы выделенных ячеек, с сортировкой по годам. Например, в 1914 году их нет, а в 1915 - одна волна (т.е. имеется в виду последовательно выделенные, без перерывов);
2. Посчитать продолжительность этих волн с сортировкой по годам. Например, в 1915 году - волна продолжалась 13 дней, а в в 1917 - 10 дней;
3. Амплитуду волн. Т.е. min и max температуры. Например, в 1915 году - min 1.348, max 7.248.

У самой, к сожалению, мозгов не хватает разобраться с этим. Помогите, пожалуйста, кто чем может.

lol

Заранее, большое спасибо. ))
К сообщению приложен файл: 9892242.xlsx(71Kb)


Новичок
 
Ответить
СообщениеДобрый вечер. :)

С помощью УФ я выделила цветом нужные ячейки (столбец K - разница). Теперь, для моей задачи нужно выполнить следующее:
1. Посчитать количество волн, группы выделенных ячеек, с сортировкой по годам. Например, в 1914 году их нет, а в 1915 - одна волна (т.е. имеется в виду последовательно выделенные, без перерывов);
2. Посчитать продолжительность этих волн с сортировкой по годам. Например, в 1915 году - волна продолжалась 13 дней, а в в 1917 - 10 дней;
3. Амплитуду волн. Т.е. min и max температуры. Например, в 1915 году - min 1.348, max 7.248.

У самой, к сожалению, мозгов не хватает разобраться с этим. Помогите, пожалуйста, кто чем может.

lol

Заранее, большое спасибо. ))

Автор - baneska
Дата добавления - 25.01.2016 в 13:39
YouGreed Дата: Понедельник, 25.01.2016, 14:18 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
baneska, Так-с, предлагаем.
Код
=СЧЁТЕСЛИМН($A$2:$A$1178;$K4;$H$2:$H$1178;5)

Нужно уточнение, счет максимальной продолжительности волны или сумма всех волн?
Код
=МИН(ЕСЛИ(($A$2:$A$1178=$K4)*($H$2:$H$1178=5)*$G$2:$G$1178>0;$G$2:$G$1178))

Формула массива, вводится Ctrl+Shift+Enter.
Наименьшее значение в волне.
Код
=МАКС(($A$2:$A$1178=$K4)*($H$2:$H$1178=5)*$G$2:$G$1178)

Формула массива.
Максимальное значение в волне.

Осталось посчитать кол-во волн.


Сообщение отредактировал YouGreed - Понедельник, 25.01.2016, 14:21
 
Ответить
Сообщениеbaneska, Так-с, предлагаем.
Код
=СЧЁТЕСЛИМН($A$2:$A$1178;$K4;$H$2:$H$1178;5)

Нужно уточнение, счет максимальной продолжительности волны или сумма всех волн?
Код
=МИН(ЕСЛИ(($A$2:$A$1178=$K4)*($H$2:$H$1178=5)*$G$2:$G$1178>0;$G$2:$G$1178))

Формула массива, вводится Ctrl+Shift+Enter.
Наименьшее значение в волне.
Код
=МАКС(($A$2:$A$1178=$K4)*($H$2:$H$1178=5)*$G$2:$G$1178)

Формула массива.
Максимальное значение в волне.

Осталось посчитать кол-во волн.

Автор - YouGreed
Дата добавления - 25.01.2016 в 14:18
_Boroda_ Дата: Понедельник, 25.01.2016, 14:27 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11501
Репутация: 4735 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Осталось посчитать кол-во волн.

Длинная, зато быстрая
Код
=СУММПРОИЗВ(--(--(ИНДЕКС(H$1:H$1178;ПОИСКПОЗ(K4;A$1:A$1178;)-1):ИНДЕКС(H$1:H$1178;ПОИСКПОЗ(K4;A$1:A$1178;)-2+СЧЁТЕСЛИ($A$1:$A$32;A$2))&ИНДЕКС(H$1:H$1178;ПОИСКПОЗ(K4;A$1:A$1178;)):ИНДЕКС(H$1:H$1178;ПОИСКПОЗ(K4;A$1:A$1178;)-1+СЧЁТЕСЛИ($A$1:$A$32;A$2)))=5))


Короткая, но медленнее
Код
=СУММПРОИЗВ(--((A$2:A$1178=K4)*(H$1:H$1177&H$2:H$1178)=5))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Осталось посчитать кол-во волн.

Длинная, зато быстрая
Код
=СУММПРОИЗВ(--(--(ИНДЕКС(H$1:H$1178;ПОИСКПОЗ(K4;A$1:A$1178;)-1):ИНДЕКС(H$1:H$1178;ПОИСКПОЗ(K4;A$1:A$1178;)-2+СЧЁТЕСЛИ($A$1:$A$32;A$2))&ИНДЕКС(H$1:H$1178;ПОИСКПОЗ(K4;A$1:A$1178;)):ИНДЕКС(H$1:H$1178;ПОИСКПОЗ(K4;A$1:A$1178;)-1+СЧЁТЕСЛИ($A$1:$A$32;A$2)))=5))


Короткая, но медленнее
Код
=СУММПРОИЗВ(--((A$2:A$1178=K4)*(H$1:H$1177&H$2:H$1178)=5))

Автор - _Boroda_
Дата добавления - 25.01.2016 в 14:27
baneska Дата: Понедельник, 25.01.2016, 14:30 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
YouGreed, Спасибо за отклик. ))
Нет нет, max это - максимальное значение в период определённой волны.


Новичок
 
Ответить
СообщениеYouGreed, Спасибо за отклик. ))
Нет нет, max это - максимальное значение в период определённой волны.

Автор - baneska
Дата добавления - 25.01.2016 в 14:30
YouGreed Дата: Понедельник, 25.01.2016, 14:33 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
baneska,
Код
=ЕСЛИ(МАКС(($A$2:$A$1178=$K4)*($H$2:$H$1178=5)*$B$2:$B$1178)-МИН(ЕСЛИ(($A$2:$A$1178=$K4)*($H$2:$H$1178=5)*$B$2:$B$1178>0;$B$2:$B$1178))>$Q4;2;ЕСЛИ($Q4=0;0;1))

Кол-во волн, но это так сказать, под результат сделана.

По поводу max. Т.е. нужно min и max значения самой длинной волны за год, так я понял?


Сообщение отредактировал YouGreed - Понедельник, 25.01.2016, 14:37
 
Ответить
Сообщениеbaneska,
Код
=ЕСЛИ(МАКС(($A$2:$A$1178=$K4)*($H$2:$H$1178=5)*$B$2:$B$1178)-МИН(ЕСЛИ(($A$2:$A$1178=$K4)*($H$2:$H$1178=5)*$B$2:$B$1178>0;$B$2:$B$1178))>$Q4;2;ЕСЛИ($Q4=0;0;1))

Кол-во волн, но это так сказать, под результат сделана.

По поводу max. Т.е. нужно min и max значения самой длинной волны за год, так я понял?

Автор - YouGreed
Дата добавления - 25.01.2016 в 14:33
baneska Дата: Понедельник, 25.01.2016, 16:28 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
YouGreed, Почти. :) Не обязательно самой длиной. Если их несколько за год, к примеру две волны за один год, то нужны min и max значения за обе волны.


Новичок
 
Ответить
СообщениеYouGreed, Почти. :) Не обязательно самой длиной. Если их несколько за год, к примеру две волны за один год, то нужны min и max значения за обе волны.

Автор - baneska
Дата добавления - 25.01.2016 в 16:28
YouGreed Дата: Понедельник, 25.01.2016, 16:32 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
baneska, Просмотрите файл.
К сообщению приложен файл: _-__-_.xlsx(73Kb)
 
Ответить
Сообщениеbaneska, Просмотрите файл.

Автор - YouGreed
Дата добавления - 25.01.2016 в 16:32
baneska Дата: Понедельник, 25.01.2016, 18:49 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
YouGreed, Боже, вы гений. Спасибо вам большое большое!! ))) girl_smile


Новичок
 
Ответить
СообщениеYouGreed, Боже, вы гений. Спасибо вам большое большое!! ))) girl_smile

Автор - baneska
Дата добавления - 25.01.2016 в 18:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать количество выделенных цветом ячеек. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!