Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/возврат значения первой ячейки столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » возврат значения первой ячейки столбца (Формулы/Formulas)
возврат значения первой ячейки столбца
Poligraf510 Дата: Вторник, 26.01.2016, 12:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Есть таблица с отрицательными и положительными цифрами, необходимо в каждой строке найти первое положительное число и вернуть значение первой ячейки столбца, в котором это число было найдено (в примере столбец итог)
К сообщению приложен файл: 4108128.xlsx(10Kb)


Сообщение отредактировал Poligraf510 - Вторник, 26.01.2016, 12:33
 
Ответить
СообщениеЕсть таблица с отрицательными и положительными цифрами, необходимо в каждой строке найти первое положительное число и вернуть значение первой ячейки столбца, в котором это число было найдено (в примере столбец итог)

Автор - Poligraf510
Дата добавления - 26.01.2016 в 12:31
Manyasha Дата: Вторник, 26.01.2016, 12:47 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1721
Репутация: 722 ±
Замечаний: 0% ±

Excel 2007, 2010
Poligraf510, так можно (формула массива)
Код
=МИН(ЕСЛИ(B2:G2>0;СТОЛБЕЦ(A2:F2);""))
К сообщению приложен файл: 4108128-1.xlsx(10Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеPoligraf510, так можно (формула массива)
Код
=МИН(ЕСЛИ(B2:G2>0;СТОЛБЕЦ(A2:F2);""))

Автор - Manyasha
Дата добавления - 26.01.2016 в 12:47
Pelena Дата: Вторник, 26.01.2016, 12:48 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 10414
Репутация: 2358 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Формула массива
Код
=ПОИСКПОЗ(ИСТИНА;B2:G2>0;0)
К сообщению приложен файл: 5299596.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива
Код
=ПОИСКПОЗ(ИСТИНА;B2:G2>0;0)

Автор - Pelena
Дата добавления - 26.01.2016 в 12:48
Poligraf510 Дата: Вторник, 26.01.2016, 13:10 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Да все хорошо с одним НО, если пример немного видоизменить и в строке 1 числа написать не по порядку, то массивы не работают в обоих способах.
К сообщению приложен файл: 9328541.xlsx(10Kb)


Сообщение отредактировал Poligraf510 - Вторник, 26.01.2016, 13:13
 
Ответить
СообщениеДа все хорошо с одним НО, если пример немного видоизменить и в строке 1 числа написать не по порядку, то массивы не работают в обоих способах.

Автор - Poligraf510
Дата добавления - 26.01.2016 в 13:10
Pelena Дата: Вторник, 26.01.2016, 13:15 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 10414
Репутация: 2358 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=ИНДЕКС($B$1:$G$1;ПОИСКПОЗ(ИСТИНА;B2:G2>0;0))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ИНДЕКС($B$1:$G$1;ПОИСКПОЗ(ИСТИНА;B2:G2>0;0))

Автор - Pelena
Дата добавления - 26.01.2016 в 13:15
Poligraf510 Дата: Вторник, 26.01.2016, 13:19 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, огромное спасибо, все так просто. Первый раз пишу на форуме и просто не ожидал просто мгновенного ответа. Еще раз спасибо
 
Ответить
СообщениеPelena, огромное спасибо, все так просто. Первый раз пишу на форуме и просто не ожидал просто мгновенного ответа. Еще раз спасибо

Автор - Poligraf510
Дата добавления - 26.01.2016 в 13:19
jakim Дата: Вторник, 26.01.2016, 17:25 | Сообщение № 7
Группа: Друзья
Ранг: Ветеран
Сообщений: 711
Репутация: 182 ±
Замечаний: 0% ±

Ещё две обычные формулы

Код
=SMALL(INDEX(B$1:G$1*(B2:G2>0);0);COUNTIF(B2:G2;"<0")+1)

Код
=AGGREGATE(15;6;B$1:G$1/(B2:G2>0);1)
 
Ответить
Сообщение
Ещё две обычные формулы

Код
=SMALL(INDEX(B$1:G$1*(B2:G2>0);0);COUNTIF(B2:G2;"<0")+1)

Код
=AGGREGATE(15;6;B$1:G$1/(B2:G2>0);1)

Автор - jakim
Дата добавления - 26.01.2016 в 17:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » возврат значения первой ячейки столбца (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!