Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Диаграмма загрузки станков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Диаграмма загрузки станков (Формулы/Formulas)
Диаграмма загрузки станков
DakotaCat Дата: Вторник, 26.01.2016, 16:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем доброго времени суток!
Задача такова: создать в эксель некое подобие диаграммы загрузки станков.
Пыталась сделать на основе диаграммы Ганта диаграмму загрузки производственных ЧПУ станков. Смысл диаграммы в том что бы видеть когда и на сколько дней (с какого по какое число) станок занят обработкой детали для планирования дальнейшего распределения ресурсов, в частности времени для написания управляющих программ для этих самых станков. Предпологалось что программист смотря на эту диаграмму принимал решение на какой станок ему целесообразнее готовить следующую УП исходя из временных затрат на ее написание.
Сама диаграмма строится путем закрашивания ячеек в колонке с соответствующей датой, для этого заполняется таблица на другом листе с соответствующими датами. Возникло невыероятное кол-во вопросов о том как научить эксель отделять время работы над разными деталями разными цветами, какими формулами/макросами считывать информацию с таблицы ну и в конце концов целесообразно ли это вообще делать в эксель?
Буду благодарна за любые советы по этому поводу!
Прикрепленный файл есть очень сырая черновая работа над этой задачей.
К сообщению приложен файл: _--.xlsx(52Kb)
 
Ответить
СообщениеВсем доброго времени суток!
Задача такова: создать в эксель некое подобие диаграммы загрузки станков.
Пыталась сделать на основе диаграммы Ганта диаграмму загрузки производственных ЧПУ станков. Смысл диаграммы в том что бы видеть когда и на сколько дней (с какого по какое число) станок занят обработкой детали для планирования дальнейшего распределения ресурсов, в частности времени для написания управляющих программ для этих самых станков. Предпологалось что программист смотря на эту диаграмму принимал решение на какой станок ему целесообразнее готовить следующую УП исходя из временных затрат на ее написание.
Сама диаграмма строится путем закрашивания ячеек в колонке с соответствующей датой, для этого заполняется таблица на другом листе с соответствующими датами. Возникло невыероятное кол-во вопросов о том как научить эксель отделять время работы над разными деталями разными цветами, какими формулами/макросами считывать информацию с таблицы ну и в конце концов целесообразно ли это вообще делать в эксель?
Буду благодарна за любые советы по этому поводу!
Прикрепленный файл есть очень сырая черновая работа над этой задачей.

Автор - DakotaCat
Дата добавления - 26.01.2016 в 16:33
Udik Дата: Вторник, 26.01.2016, 19:37 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1298
Репутация: 161 ±
Замечаний: 0% ±

Excel 2013
Пока не очень понятно чего требуется.
Для начала формула "раскраски", массивка
Код
{=ЕСЛИОШИБКА(ПОИСКПОЗ(1;($C9:$G9<=J$8)*(($C9:$G9+$D9:$H9)>J$8)*($C9:$G9>99);0);"")}

Для каждого периода строки выводит свою цифру, по ней красим УФ
К сообщению приложен файл: 6428498.xlsx(100Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Вторник, 26.01.2016, 19:58
 
Ответить
СообщениеПока не очень понятно чего требуется.
Для начала формула "раскраски", массивка
Код
{=ЕСЛИОШИБКА(ПОИСКПОЗ(1;($C9:$G9<=J$8)*(($C9:$G9+$D9:$H9)>J$8)*($C9:$G9>99);0);"")}

Для каждого периода строки выводит свою цифру, по ней красим УФ

Автор - Udik
Дата добавления - 26.01.2016 в 19:37
DakotaCat Дата: Пятница, 29.01.2016, 11:34 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Требуется, как мне кажется, какой то массив формул и макросов, по средствам которых заполнение таблицы влияло бы на отображаемую на диаграмме информацию. Вид может быть совсем иной нежели в моем примере, сама суть - видеть как загружены станки во времени для наиболее рационального распределения временных ресурсов.
 
Ответить
СообщениеТребуется, как мне кажется, какой то массив формул и макросов, по средствам которых заполнение таблицы влияло бы на отображаемую на диаграмме информацию. Вид может быть совсем иной нежели в моем примере, сама суть - видеть как загружены станки во времени для наиболее рационального распределения временных ресурсов.

Автор - DakotaCat
Дата добавления - 29.01.2016 в 11:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Диаграмма загрузки станков (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!