Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнивание значений двух листов и перенос значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнивание значений двух листов и перенос значений (Формулы/Formulas)
Сравнивание значений двух листов и перенос значений
night-souls Дата: Четверг, 28.01.2016, 19:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Сравнивание значений двух листов из Листа1 и Листа2. Сравниваются столбцы A, если значения строки в листе 1 и 2 совпали, то копируется информация из Листа2 столбца С из той же строки в Лист1 в столбец H.
Например в Листе1 есть значение б-27555 (столбец А), формула делает поиск этого значения в Листе2 (в столбце А), после совпадения значения копирует номер телефона (столбец С, Листа2), из строки со значением б-27555 Листа2 в столбец Н в Листе1.
К сообщению приложен файл: 1180923.xlsx(10Kb)
 
Ответить
СообщениеСравнивание значений двух листов из Листа1 и Листа2. Сравниваются столбцы A, если значения строки в листе 1 и 2 совпали, то копируется информация из Листа2 столбца С из той же строки в Лист1 в столбец H.
Например в Листе1 есть значение б-27555 (столбец А), формула делает поиск этого значения в Листе2 (в столбце А), после совпадения значения копирует номер телефона (столбец С, Листа2), из строки со значением б-27555 Листа2 в столбец Н в Листе1.

Автор - night-souls
Дата добавления - 28.01.2016 в 19:07
night-souls Дата: Четверг, 28.01.2016, 21:01 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИОШИБКА(ВПР(ЛЕВСИМВ(A2;ПОИСК(" ";A2)-1)&"*";Лист2!$B$3:$C$346;2;0);"")


Примерно такой формулой делали, но эта не подходит, часа полтора просидела и ничего не вышло =(
Помогите, очень нужно...
[moder]Формулы нужно обрамлять спецтегами - кнопка fx. Поправил Вам.


Сообщение отредактировал _Boroda_ - Четверг, 28.01.2016, 21:07
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР(ЛЕВСИМВ(A2;ПОИСК(" ";A2)-1)&"*";Лист2!$B$3:$C$346;2;0);"")


Примерно такой формулой делали, но эта не подходит, часа полтора просидела и ничего не вышло =(
Помогите, очень нужно...
[moder]Формулы нужно обрамлять спецтегами - кнопка fx. Поправил Вам.

Автор - night-souls
Дата добавления - 28.01.2016 в 21:01
_Boroda_ Дата: Четверг, 28.01.2016, 21:09 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ВПР(B2;Лист2!B$2:C$999;2;);"")
К сообщению приложен файл: 1180923_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ВПР(B2;Лист2!B$2:C$999;2;);"")

Автор - _Boroda_
Дата добавления - 28.01.2016 в 21:09
night-souls Дата: Четверг, 28.01.2016, 21:24 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, сработало, спасибо!
 
Ответить
Сообщение_Boroda_, сработало, спасибо!

Автор - night-souls
Дата добавления - 28.01.2016 в 21:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнивание значений двух листов и перенос значений (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!