Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/расчет пересечений по датам у одного и того же человека - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » расчет пересечений по датам у одного и того же человека (Формулы/Formulas)
расчет пересечений по датам у одного и того же человека
rubanok1982 Дата: Четверг, 28.01.2016, 23:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
У меня есть база данных по заявкам слушателей на курсы повышения квалификации. Мне надо выявить слушателей, которые необдуманно зарегистрировались на курсы, даты которых пересекаются. Уникальность слушателя я обычно делаю методом соединения ФИО, телефона и электронной почты (формулой "Сцепить").
Помогите мне составить такую формулу, которая в строке слушателя указала бы, что у него есть пересечения дат

В моем примере проблем нету только у Александра. а Светлане с Еленой свой образоватлеьный маршрут предстоит подкорректировать.

Заранее благодарю за помощь, чувствую, что проблема такого рода решаема, но сам не умею :-) я надеюсь на это
К сообщению приложен файл: 5694785.xlsx(10Kb)
 
Ответить
СообщениеУ меня есть база данных по заявкам слушателей на курсы повышения квалификации. Мне надо выявить слушателей, которые необдуманно зарегистрировались на курсы, даты которых пересекаются. Уникальность слушателя я обычно делаю методом соединения ФИО, телефона и электронной почты (формулой "Сцепить").
Помогите мне составить такую формулу, которая в строке слушателя указала бы, что у него есть пересечения дат

В моем примере проблем нету только у Александра. а Светлане с Еленой свой образоватлеьный маршрут предстоит подкорректировать.

Заранее благодарю за помощь, чувствую, что проблема такого рода решаема, но сам не умею :-) я надеюсь на это

Автор - rubanok1982
Дата добавления - 28.01.2016 в 23:03
_Boroda_ Дата: Четверг, 28.01.2016, 23:41 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11327
Репутация: 4676 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вот так выводит пересекающиеся
Код
=СУММПРОИЗВ((A$2:A$10=A2)*(B$2:B$10=B2)*(C$2:C$10=C2)*(F$2:F$10>=E2)*(E$2:E$10<=F2))>1
К сообщению приложен файл: 5694785_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВот так выводит пересекающиеся
Код
=СУММПРОИЗВ((A$2:A$10=A2)*(B$2:B$10=B2)*(C$2:C$10=C2)*(F$2:F$10>=E2)*(E$2:E$10<=F2))>1

Автор - _Boroda_
Дата добавления - 28.01.2016 в 23:41
rubanok1982 Дата: Пятница, 29.01.2016, 00:08 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Борода, спасибо большое! скажие мне недалекому, а как вы так сделали, что выделяются значения, а формул вообще нигде не видно. Простите если спрашиваю какие-то очевидные вещи
 
Ответить
СообщениеБорода, спасибо большое! скажие мне недалекому, а как вы так сделали, что выделяются значения, а формул вообще нигде не видно. Простите если спрашиваю какие-то очевидные вещи

Автор - rubanok1982
Дата добавления - 29.01.2016 в 00:08
_Boroda_ Дата: Пятница, 29.01.2016, 00:12 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11327
Репутация: 4676 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Смотрите вкладка Главная - Условное форматирование - Управление правилами
Эту же формулу можно в соседний столбец написать - тогда там будет выводить
Код
=ЕСЛИ(СУММПРОИЗВ((A$2:A$10=A2)*(B$2:B$10=B2)*(C$2:C$10=C2)*(F$2:F$10>=E2)*(E$2:E$10<=F2))>1;"Перехлест";"")
К сообщению приложен файл: 5694785_2.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСмотрите вкладка Главная - Условное форматирование - Управление правилами
Эту же формулу можно в соседний столбец написать - тогда там будет выводить
Код
=ЕСЛИ(СУММПРОИЗВ((A$2:A$10=A2)*(B$2:B$10=B2)*(C$2:C$10=C2)*(F$2:F$10>=E2)*(E$2:E$10<=F2))>1;"Перехлест";"")

Автор - _Boroda_
Дата добавления - 29.01.2016 в 00:12
rubanok1982 Дата: Пятница, 29.01.2016, 00:13 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Да, спасибо. Уже пробую :-) Благодарю Вас!
 
Ответить
СообщениеДа, спасибо. Уже пробую :-) Благодарю Вас!

Автор - rubanok1982
Дата добавления - 29.01.2016 в 00:13
_Boroda_ Дата: Пятница, 29.01.2016, 00:15 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11327
Репутация: 4676 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я там еще дописал в свой пред. пост


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЯ там еще дописал в свой пред. пост

Автор - _Boroda_
Дата добавления - 29.01.2016 в 00:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » расчет пересечений по датам у одного и того же человека (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!