Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Количество разных адресов, приходящихся на одно имя - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество разных адресов, приходящихся на одно имя (Формулы/Formulas)
Количество разных адресов, приходящихся на одно имя
d_vladislava Дата: Пятница, 29.01.2016, 22:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер. Помогите, пожалуйста, узнать сколько разных адресов из стобца B приходится на одно и то же имя, указанные в столбце А. Желаемый результат приложен.
К сообщению приложен файл: primer.xlsx(10Kb)


Сообщение отредактировал d_vladislava - Пятница, 29.01.2016, 22:20
 
Ответить
СообщениеДобрый вечер. Помогите, пожалуйста, узнать сколько разных адресов из стобца B приходится на одно и то же имя, указанные в столбце А. Желаемый результат приложен.

Автор - d_vladislava
Дата добавления - 29.01.2016 в 22:14
Nic70y Дата: Пятница, 29.01.2016, 23:09 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3926
Репутация: 832 ±
Замечаний: 0% ±

Excel 2013
Код
=СЧЁТЕСЛИМН($B$2:$B$10;"<>"&ВПР(D2;A$2:B$10;2;);A$2:A$10;D2)+1
ну и на всякий случай
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(D2;$A$2:$A$10;));0;СЧЁТЕСЛИМН($B$2:$B$10;"<>"&ВПР(D2;A$2:B$10;2;);A$2:A$10;D2)+1)
Код
=ЕСЛИ(СУММПРОИЗВ(МАКС((D2=A$2:A$10)*(B$2:B$10<>"")*СТРОКА($1:$9)))>0;1+СЧЁТЕСЛИМН($B$2:$B$10;"<>"&ИНДЕКС(B$2:B$10;СУММПРОИЗВ(МАКС((D2=A$2:A$10)*(B$2:B$10<>"")*СТРОКА($1:$9))));A$2:A$10;D2;B$2:B$10;"<>");0)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Пятница, 29.01.2016, 23:34
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИМН($B$2:$B$10;"<>"&ВПР(D2;A$2:B$10;2;);A$2:A$10;D2)+1
ну и на всякий случай
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(D2;$A$2:$A$10;));0;СЧЁТЕСЛИМН($B$2:$B$10;"<>"&ВПР(D2;A$2:B$10;2;);A$2:A$10;D2)+1)
Код
=ЕСЛИ(СУММПРОИЗВ(МАКС((D2=A$2:A$10)*(B$2:B$10<>"")*СТРОКА($1:$9)))>0;1+СЧЁТЕСЛИМН($B$2:$B$10;"<>"&ИНДЕКС(B$2:B$10;СУММПРОИЗВ(МАКС((D2=A$2:A$10)*(B$2:B$10<>"")*СТРОКА($1:$9))));A$2:A$10;D2;B$2:B$10;"<>");0)

Автор - Nic70y
Дата добавления - 29.01.2016 в 23:09
Pelena Дата: Пятница, 29.01.2016, 23:50 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11045
Репутация: 2468 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Вариант сводной
К сообщению приложен файл: primer-21-.xlsx(14Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант сводной

Автор - Pelena
Дата добавления - 29.01.2016 в 23:50
d_vladislava Дата: Четверг, 25.02.2016, 00:52 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, Pelena, извините, думала, что отписалась, а оказалось, что нет. Спасибо вам. Первый вариант Nic70y подошел)
 
Ответить
СообщениеNic70y, Pelena, извините, думала, что отписалась, а оказалось, что нет. Спасибо вам. Первый вариант Nic70y подошел)

Автор - d_vladislava
Дата добавления - 25.02.2016 в 00:52
nonameforme Дата: Вторник, 19.04.2016, 08:21 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Друзья привет!
Подскажите, почему в моем случае это не срабатывает?
[moder]У Вас немного другой случай. Создайте свою тему с описанием проблемы[/moder]
К сообщению приложен файл: 2014.xlsx(60Kb)


Сообщение отредактировал Pelena - Вторник, 19.04.2016, 08:36
 
Ответить
СообщениеДрузья привет!
Подскажите, почему в моем случае это не срабатывает?
[moder]У Вас немного другой случай. Создайте свою тему с описанием проблемы[/moder]

Автор - nonameforme
Дата добавления - 19.04.2016 в 08:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество разных адресов, приходящихся на одно имя (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!