Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сделать разделение на группы разрядов в текстовой ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать разделение на группы разрядов в текстовой ячейке (Формулы/Formulas)
Как сделать разделение на группы разрядов в текстовой ячейке
isbobrov Дата: Понедельник, 01.02.2016, 09:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Подскажите, пожалуйста. Есть 400 ячеек. В большинстве из них разное количество символов
К примеру:
| 1068345535
| 69867964
| 20112
| 3249333293313
| 3249

Необходимо сделать разделение на группы разрядов. Что будет много пробелов - ничего страшного.
Вид должен быть такой:

| 1 068 345 535
| 69 867 964
| 20 112
| 3 249 333 293 313
| 3 249

Получается через каждые 3 символа с правой стороны нужен пробел. Причем "| " обязательно должно стоять перед цифрами.
Заранее большое спасибо!
 
Ответить
СообщениеПодскажите, пожалуйста. Есть 400 ячеек. В большинстве из них разное количество символов
К примеру:
| 1068345535
| 69867964
| 20112
| 3249333293313
| 3249

Необходимо сделать разделение на группы разрядов. Что будет много пробелов - ничего страшного.
Вид должен быть такой:

| 1 068 345 535
| 69 867 964
| 20 112
| 3 249 333 293 313
| 3 249

Получается через каждые 3 символа с правой стороны нужен пробел. Причем "| " обязательно должно стоять перед цифрами.
Заранее большое спасибо!

Автор - isbobrov
Дата добавления - 01.02.2016 в 09:20
buchlotnik Дата: Понедельник, 01.02.2016, 09:22 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2207
Репутация: 659 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
можно так
Код
=ТЕКСТ(ПРАВСИМВ(A1;ДЛСТР(A1)-2);"| ### ### ### ### ### ### ###")


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 01.02.2016, 09:25
 
Ответить
Сообщениеможно так
Код
=ТЕКСТ(ПРАВСИМВ(A1;ДЛСТР(A1)-2);"| ### ### ### ### ### ### ###")

Автор - buchlotnik
Дата добавления - 01.02.2016 в 09:22
китин Дата: Понедельник, 01.02.2016, 09:27 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3723
Репутация: 587 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
на коленке
Код
="| "&ТЕКСТ(ПСТР(A1;ПОИСК(" ";A1);49);"# ##")
точнее при наличии файла примера


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениена коленке
Код
="| "&ТЕКСТ(ПСТР(A1;ПОИСК(" ";A1);49);"# ##")
точнее при наличии файла примера

Автор - китин
Дата добавления - 01.02.2016 в 09:27
_Boroda_ Дата: Понедельник, 01.02.2016, 09:29 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Только до 15 цифр
Еще такой вариант
Код
=ТЕКСТ(ПСТР(A1;2;99);"|"&ПОВТОР(" ###";5))

Кстати да, согласен с Игорем, повтор не нужен
Код
=ТЕКСТ(ПСТР(A1;2;99);"| "&"# ##")

Более того, и третья решетка не нужна
Код
=ТЕКСТ(ПСТР(A1;2;99);"| "&"# #")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТолько до 15 цифр
Еще такой вариант
Код
=ТЕКСТ(ПСТР(A1;2;99);"|"&ПОВТОР(" ###";5))

Кстати да, согласен с Игорем, повтор не нужен
Код
=ТЕКСТ(ПСТР(A1;2;99);"| "&"# ##")

Более того, и третья решетка не нужна
Код
=ТЕКСТ(ПСТР(A1;2;99);"| "&"# #")

Автор - _Boroda_
Дата добавления - 01.02.2016 в 09:29
isbobrov Дата: Понедельник, 01.02.2016, 09:30 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, спасибо большое за скорый и правильный ответ. Вы мне очень помогли!!!
 
Ответить
Сообщениеbuchlotnik, спасибо большое за скорый и правильный ответ. Вы мне очень помогли!!!

Автор - isbobrov
Дата добавления - 01.02.2016 в 09:30
isbobrov Дата: Понедельник, 01.02.2016, 09:30 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем спасибо большое!
 
Ответить
СообщениеВсем спасибо большое!

Автор - isbobrov
Дата добавления - 01.02.2016 в 09:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать разделение на группы разрядов в текстовой ячейке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!