Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Транспонировать в столбец длинную строку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Транспонировать в столбец длинную строку (Формулы/Formulas)
Транспонировать в столбец длинную строку
enzo Дата: Пятница, 05.02.2016, 09:22 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Всем доброго утра, сделали огромную выгрузку в горизонтальном виде , а мне нужно их перебить в один столбец по вертикали, для удобства , фильтра а далее и для сводной таблицы ( будут добавляться столбцы с инфой) в приложении высылаю файл
К сообщению приложен файл: _11.xlsx(11Kb)
 
Ответить
СообщениеВсем доброго утра, сделали огромную выгрузку в горизонтальном виде , а мне нужно их перебить в один столбец по вертикали, для удобства , фильтра а далее и для сводной таблицы ( будут добавляться столбцы с инфой) в приложении высылаю файл

Автор - enzo
Дата добавления - 05.02.2016 в 09:22
_Boroda_ Дата: Пятница, 05.02.2016, 09:36 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС($2:$2;ЧИСЛСТОЛБ(A2:D2)+СТРОКА(A1)*2-1)
Остальные формулы аналогичные
Если яблоки начинаются со столбца А, то кусок ЧИСЛСТОЛБ(A3:D3)+ не нужен.
Сначала думал одинаковой формулой для всех столбцов сделать, а потом подумал: "А зачем? Только тормозить будет больше."
К сообщению приложен файл: _11_1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС($2:$2;ЧИСЛСТОЛБ(A2:D2)+СТРОКА(A1)*2-1)
Остальные формулы аналогичные
Если яблоки начинаются со столбца А, то кусок ЧИСЛСТОЛБ(A3:D3)+ не нужен.
Сначала думал одинаковой формулой для всех столбцов сделать, а потом подумал: "А зачем? Только тормозить будет больше."

Автор - _Boroda_
Дата добавления - 05.02.2016 в 09:36
enzo Дата: Пятница, 05.02.2016, 09:54 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
то что надо было , спасибо!
 
Ответить
Сообщението что надо было , спасибо!

Автор - enzo
Дата добавления - 05.02.2016 в 09:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Транспонировать в столбец длинную строку (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!