Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск с выводом значений искомого - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск с выводом значений искомого (Формулы/Formulas)
Поиск с выводом значений искомого
serge_nt Дата: Суббота, 06.02.2016, 19:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Прошу помощи в решении такой задачи, есть таблица с данными: продукт, его калорийность, содержание углеводов, жиров и белков. Нужно на другом листе или файле (оба варианты подходят), вводя нужный продукт, получать справа от него, точно также как в исходной таблице, значения калорийности, углеводов и остальных значений. Искал на просторах интернета, искал на данном ресурсе, но не нашёл, так как даже не знаю какой функцией это реализуется.
Заранее, спасибо.
 
Ответить
СообщениеЗдравствуйте. Прошу помощи в решении такой задачи, есть таблица с данными: продукт, его калорийность, содержание углеводов, жиров и белков. Нужно на другом листе или файле (оба варианты подходят), вводя нужный продукт, получать справа от него, точно также как в исходной таблице, значения калорийности, углеводов и остальных значений. Искал на просторах интернета, искал на данном ресурсе, но не нашёл, так как даже не знаю какой функцией это реализуется.
Заранее, спасибо.

Автор - serge_nt
Дата добавления - 06.02.2016 в 19:17
_Boroda_ Дата: Суббота, 06.02.2016, 19:21 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Используйте функцию ВПР.
Без Вашего файла это все, что могу посоветовать


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИспользуйте функцию ВПР.
Без Вашего файла это все, что могу посоветовать

Автор - _Boroda_
Дата добавления - 06.02.2016 в 19:21
serge_nt Дата: Воскресенье, 07.02.2016, 07:52 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Без Вашего файла это все, что могу посоветовать

Вроде бы прикреплял, сейчас попробую ещё раз.

Прочитал про ВПР. В общем, функция решает задачу. Единственный момент, как возвратить все данные, связанные с искомой ячейкой?
К сообщению приложен файл: ____.xlsx(9Kb)


Сообщение отредактировал serge_nt - Воскресенье, 07.02.2016, 08:00
 
Ответить
Сообщение
Без Вашего файла это все, что могу посоветовать

Вроде бы прикреплял, сейчас попробую ещё раз.

Прочитал про ВПР. В общем, функция решает задачу. Единственный момент, как возвратить все данные, связанные с искомой ячейкой?

Автор - serge_nt
Дата добавления - 07.02.2016 в 07:52
Pelena Дата: Воскресенье, 07.02.2016, 08:14 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11605
Репутация: 2573 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
как возвратить все данные

Прописать функцию ВПР() для каждого столбца

В файле немного другой вариант. Использовала динамические имена, чтобы в таблицу можно было добавлять строчки
К сообщению приложен файл: -1-.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
как возвратить все данные

Прописать функцию ВПР() для каждого столбца

В файле немного другой вариант. Использовала динамические имена, чтобы в таблицу можно было добавлять строчки

Автор - Pelena
Дата добавления - 07.02.2016 в 08:14
МВТ Дата: Воскресенье, 07.02.2016, 08:17 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 476
Репутация: 136 ±
Замечаний: 0% ±

Excel 2007
Введите и протяните вправо (предполагается, что нумерация столбцов в поиске соответствует таковой в исходной таблице)
Код
=ЕСЛИОШИБКА(ВПР($A11;$A$2:$F$8;СТОЛБЕЦ();0);"")
 
Ответить
СообщениеВведите и протяните вправо (предполагается, что нумерация столбцов в поиске соответствует таковой в исходной таблице)
Код
=ЕСЛИОШИБКА(ВПР($A11;$A$2:$F$8;СТОЛБЕЦ();0);"")

Автор - МВТ
Дата добавления - 07.02.2016 в 08:17
TimSha Дата: Воскресенье, 07.02.2016, 08:41 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 522
Репутация: 82 ±
Замечаний: 0% ±

Excel 2013 Pro +
как возвратить все данные, связанные с искомой ячейкой?

Расширенный фильтр. Для выборки на другой лист вызывать РФ/AF с этого (другого) листа. Как вариант... ;)


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
Сообщение
как возвратить все данные, связанные с искомой ячейкой?

Расширенный фильтр. Для выборки на другой лист вызывать РФ/AF с этого (другого) листа. Как вариант... ;)

Автор - TimSha
Дата добавления - 07.02.2016 в 08:41
serge_nt Дата: Воскресенье, 07.02.2016, 11:13 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо, вам всем. Вы мне очень помогли, особенно Pelena.
 
Ответить
СообщениеСпасибо, вам всем. Вы мне очень помогли, особенно Pelena.

Автор - serge_nt
Дата добавления - 07.02.2016 в 11:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск с выводом значений искомого (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!