Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/счет значений по нескольким критериям, эксель 2003(!) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » счет значений по нескольким критериям, эксель 2003(!) (Формулы/Formulas)
счет значений по нескольким критериям, эксель 2003(!)
lordua Дата: Понедельник, 08.02.2016, 23:26 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Excel 2003
есть три колонки. первая - даты. заполнена не вся,, с пустыми ячейками, если пустая - какая нибудь гадость написана во втором столбце. третий столбец - специалисты, заполнен без пустых ячеек (но дополняется)
как посчитать сколько раз за конкретный месяц спец есть в первой колонке? формула, что есть, считает хрен пойми что, и работает только если в первом столбце нет пустых ячеек. будте добры, помогите
К сообщению приложен файл: 0850095.xls(17Kb)


Сообщение отредактировал lordua - Понедельник, 08.02.2016, 23:27
 
Ответить
Сообщениеесть три колонки. первая - даты. заполнена не вся,, с пустыми ячейками, если пустая - какая нибудь гадость написана во втором столбце. третий столбец - специалисты, заполнен без пустых ячеек (но дополняется)
как посчитать сколько раз за конкретный месяц спец есть в первой колонке? формула, что есть, считает хрен пойми что, и работает только если в первом столбце нет пустых ячеек. будте добры, помогите

Автор - lordua
Дата добавления - 08.02.2016 в 23:26
_Boroda_ Дата: Понедельник, 08.02.2016, 23:38 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9379
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
На формулу не ругайтесь - она считает так, как Вы ей указали. Дело в том, что 0 - это тоже январь, только 1900 года. Как это ни странно звучит, 0 - это НУЛЕВОЕ января 1900г. Попробуйте в ячейку с нулем поставить формат ДД.ММ.ГГГГ - увидите 00.01.1900
Вот так попробуйте
Код
=СУММПРОИЗВ((МЕСЯЦ(A$2:A$11)=B$14)*(C$2:C$11=A16)*(A$2:A$11>0))
К сообщению приложен файл: 0850095_1.xls(31Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНа формулу не ругайтесь - она считает так, как Вы ей указали. Дело в том, что 0 - это тоже январь, только 1900 года. Как это ни странно звучит, 0 - это НУЛЕВОЕ января 1900г. Попробуйте в ячейку с нулем поставить формат ДД.ММ.ГГГГ - увидите 00.01.1900
Вот так попробуйте
Код
=СУММПРОИЗВ((МЕСЯЦ(A$2:A$11)=B$14)*(C$2:C$11=A16)*(A$2:A$11>0))

Автор - _Boroda_
Дата добавления - 08.02.2016 в 23:38
lordua Дата: Понедельник, 08.02.2016, 23:43 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Excel 2003
_Boroda_, спасибо, щас попробую на живом файле. не подумал)

ОГРОМНОЕ спасибо!) да, оно!


Сообщение отредактировал lordua - Понедельник, 08.02.2016, 23:44
 
Ответить
Сообщение_Boroda_, спасибо, щас попробую на живом файле. не подумал)

ОГРОМНОЕ спасибо!) да, оно!

Автор - lordua
Дата добавления - 08.02.2016 в 23:43
Pelena Дата: Понедельник, 08.02.2016, 23:44 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9888
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Можно так ещё
Код
=СУММПРОИЗВ((ТЕКСТ($A$2:$A$11;"ММММГГГГ")=$B$15&2016)*($C$2:$C$11=A16))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожно так ещё
Код
=СУММПРОИЗВ((ТЕКСТ($A$2:$A$11;"ММММГГГГ")=$B$15&2016)*($C$2:$C$11=A16))

Автор - Pelena
Дата добавления - 08.02.2016 в 23:44
lordua Дата: Понедельник, 08.02.2016, 23:51 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Excel 2003
Можно так ещё

это уже вылизывание) спасибо) у меня принципиально не считало)

а хотя нет, не вылизывание.... другой вариант

завтра попробую, сегодня сил уже нет)

спасибо форуму) оперативно выдали пинков в нужных направлениях)


Сообщение отредактировал lordua - Понедельник, 08.02.2016, 23:54
 
Ответить
Сообщение
Можно так ещё

это уже вылизывание) спасибо) у меня принципиально не считало)

а хотя нет, не вылизывание.... другой вариант

завтра попробую, сегодня сил уже нет)

спасибо форуму) оперативно выдали пинков в нужных направлениях)

Автор - lordua
Дата добавления - 08.02.2016 в 23:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » счет значений по нескольким критериям, эксель 2003(!) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!