Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод значений, которые у (и неу)довлетворяют условию. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значений, которые у (и неу)довлетворяют условию. (Формулы/Formulas)
Вывод значений, которые у (и неу)довлетворяют условию.
olegus Дата: Вторник, 09.02.2016, 16:09 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день форумчане!
Помогите пожалуйста.
Данные в столбцах A:C являются ссылками на другие книги.
Очень хочу, чтобы данные из столбца A проверялись на соответствие данным в столбце B и, если они отсутствуют в столбце C, то выводились в столбце D.
Желательно формулой.
Заранее спасибо.
К сообщению приложен файл: 7166733.xls(98Kb)
 
Ответить
СообщениеДобрый день форумчане!
Помогите пожалуйста.
Данные в столбцах A:C являются ссылками на другие книги.
Очень хочу, чтобы данные из столбца A проверялись на соответствие данным в столбце B и, если они отсутствуют в столбце C, то выводились в столбце D.
Желательно формулой.
Заранее спасибо.

Автор - olegus
Дата добавления - 09.02.2016 в 16:09
pabchek Дата: Вторник, 09.02.2016, 16:27 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Если правильно понял. Так?
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A2;B$2:B$469;0));"нет в Справочнике";ЕСЛИ(ЕНД(ПОИСКПОЗ(A2;C$2:C$947;0));A2;"есть в Ведомости"))
К сообщению приложен файл: 6571979.xlsb(21Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 09.02.2016, 16:28
 
Ответить
СообщениеЕсли правильно понял. Так?
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A2;B$2:B$469;0));"нет в Справочнике";ЕСЛИ(ЕНД(ПОИСКПОЗ(A2;C$2:C$947;0));A2;"есть в Ведомости"))

Автор - pabchek
Дата добавления - 09.02.2016 в 16:27
olegus Дата: Вторник, 09.02.2016, 16:38 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо, но немного не то. В столбец D нужно ПРОСТО вывести данные из столбца A, которые есть в столбце B и отсутствуют в столбце C.
Особенно классно будет, если повторяющиеся значения в столбец D выводиться не будут (т.е. должно присутствовать по одному значению).
 
Ответить
СообщениеСпасибо, но немного не то. В столбец D нужно ПРОСТО вывести данные из столбца A, которые есть в столбце B и отсутствуют в столбце C.
Особенно классно будет, если повторяющиеся значения в столбец D выводиться не будут (т.е. должно присутствовать по одному значению).

Автор - olegus
Дата добавления - 09.02.2016 в 16:38
pabchek Дата: Вторник, 09.02.2016, 16:52 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Ну тогда так
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(ЕСЛИ(ЕНД(ПОИСКПОЗ(A5;B$2:B$469;0));"";ЕСЛИ(ЕНД(ПОИСКПОЗ(A5;C$2:C$947;0));A5;""));D$1:D4;0));A5;"")


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеНу тогда так
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(ЕСЛИ(ЕНД(ПОИСКПОЗ(A5;B$2:B$469;0));"";ЕСЛИ(ЕНД(ПОИСКПОЗ(A5;C$2:C$947;0));A5;""));D$1:D4;0));A5;"")

Автор - pabchek
Дата добавления - 09.02.2016 в 16:52
olegus Дата: Вторник, 09.02.2016, 16:56 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
pabchek, спасибо. А можно с примером? а то у меня при вставке в D2 на циклическую ссылку ругается...
 
Ответить
Сообщениеpabchek, спасибо. А можно с примером? а то у меня при вставке в D2 на циклическую ссылку ругается...

Автор - olegus
Дата добавления - 09.02.2016 в 16:56
pabchek Дата: Вторник, 09.02.2016, 17:14 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Да, я формулу не из первой ячейки вставил. Сорри. Вот корректная (с ней можно и без примера)
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(ЕСЛИ(ЕНД(ПОИСКПОЗ(A2;B$2:B$469;0));"";ЕСЛИ(ЕНД(ПОИСКПОЗ(A2;C$2:C$947;0));A2;""));D$1:D1;0));A2;"")

ну и до кучи еще одна
Код
=ЕСЛИ(СУММПРОИЗВ(МАКС(--(B$2:B$469=A2));МАКС(--(C$2:C$947<>A2));СУММ(--(D$1:D1=A2)))=0;A2;"")

еще, короче, но массивная
Код
=ЕСЛИ(МАКС(--(B$2:B$469=A2))*МАКС(--(C$2:C$947<>A2))*СУММ(--(D$1:D1=A2))=0;A2;"")


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 09.02.2016, 17:22
 
Ответить
СообщениеДа, я формулу не из первой ячейки вставил. Сорри. Вот корректная (с ней можно и без примера)
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(ЕСЛИ(ЕНД(ПОИСКПОЗ(A2;B$2:B$469;0));"";ЕСЛИ(ЕНД(ПОИСКПОЗ(A2;C$2:C$947;0));A2;""));D$1:D1;0));A2;"")

ну и до кучи еще одна
Код
=ЕСЛИ(СУММПРОИЗВ(МАКС(--(B$2:B$469=A2));МАКС(--(C$2:C$947<>A2));СУММ(--(D$1:D1=A2)))=0;A2;"")

еще, короче, но массивная
Код
=ЕСЛИ(МАКС(--(B$2:B$469=A2))*МАКС(--(C$2:C$947<>A2))*СУММ(--(D$1:D1=A2))=0;A2;"")

Автор - pabchek
Дата добавления - 09.02.2016 в 17:14
_Boroda_ Дата: Среда, 10.02.2016, 01:30 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно в столбец D просто списком без пробелов
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$2:A$999;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ(D$1:D1;A$2:A$999)=0)*ЕЧИСЛО(ПОИСКПОЗ(A$2:A$999;B$2:B$469;))*ЕНД(ПОИСКПОЗ(A$2:A$999;C$2:C$947;)););));"")

Немассивная. Но задумчивая.
К сообщению приложен файл: 7166733_1.xlsx(32Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно в столбец D просто списком без пробелов
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$2:A$999;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ(D$1:D1;A$2:A$999)=0)*ЕЧИСЛО(ПОИСКПОЗ(A$2:A$999;B$2:B$469;))*ЕНД(ПОИСКПОЗ(A$2:A$999;C$2:C$947;)););));"")

Немассивная. Но задумчивая.

Автор - _Boroda_
Дата добавления - 10.02.2016 в 01:30
olegus Дата: Среда, 10.02.2016, 07:59 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо за помощь.
 
Ответить
СообщениеСпасибо за помощь.

Автор - olegus
Дата добавления - 10.02.2016 в 07:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значений, которые у (и неу)довлетворяют условию. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!