Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Двойное применение ВПР - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Двойное применение ВПР (Формулы/Formulas)
Двойное применение ВПР
ex Дата: Среда, 10.02.2016, 21:32 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер. Есть таблица, в которой отражаются данные по продажам. Нужно осуществить поиск в этой таблице сразу по двум столбцам. Например, в первом столбце находим магазин Магнит, во втором товар Яблоки и выводим соответствующую сумму. Подскажите, как это сделать (с применением ВПР или другим образом), желательно без макросов.
К сообщению приложен файл: 3655484.xlsx(11Kb)
 
Ответить
СообщениеДобрый вечер. Есть таблица, в которой отражаются данные по продажам. Нужно осуществить поиск в этой таблице сразу по двум столбцам. Например, в первом столбце находим магазин Магнит, во втором товар Яблоки и выводим соответствующую сумму. Подскажите, как это сделать (с применением ВПР или другим образом), желательно без макросов.

Автор - ex
Дата добавления - 10.02.2016 в 21:32
buchlotnik Дата: Среда, 10.02.2016, 21:52 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
например, так (массивка)
Код
=ИНДЕКС(C2:C9;ПОИСКПОЗ(E3&F3;A2:A9&B2:B9;0))
или немассивка
Код
=-ПРОСМОТР(;-C2:C9/(A2:A9=E3)/(B2:B9=F3))
Код
=ПРОСМОТР(9^9;C2:C9/(A2:A9=E3)/(B2:B9=F3))
и до кучи
Код
=СУММПРОИЗВ((A2:A9=E3)*(B2:B9=F3)*C2:C9)
Код
=СУММЕСЛИМН(C2:C9;A2:A9;E3;B2:B9;F3)
К сообщению приложен файл: 6576005.xlsx(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 10.02.2016, 22:23
 
Ответить
Сообщениенапример, так (массивка)
Код
=ИНДЕКС(C2:C9;ПОИСКПОЗ(E3&F3;A2:A9&B2:B9;0))
или немассивка
Код
=-ПРОСМОТР(;-C2:C9/(A2:A9=E3)/(B2:B9=F3))
Код
=ПРОСМОТР(9^9;C2:C9/(A2:A9=E3)/(B2:B9=F3))
и до кучи
Код
=СУММПРОИЗВ((A2:A9=E3)*(B2:B9=F3)*C2:C9)
Код
=СУММЕСЛИМН(C2:C9;A2:A9;E3;B2:B9;F3)

Автор - buchlotnik
Дата добавления - 10.02.2016 в 21:52
ex Дата: Четверг, 11.02.2016, 00:48 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо. А в варианте с функцией ПРОСМОТР почему используется знак минус перед диапазоном, что это дает?
 
Ответить
СообщениеСпасибо. А в варианте с функцией ПРОСМОТР почему используется знак минус перед диапазоном, что это дает?

Автор - ex
Дата добавления - 11.02.2016 в 00:48
buchlotnik Дата: Четверг, 11.02.2016, 09:41 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
конструкция
Код
ПРОСМОТР(;
ищет первое нулевое значение, соответственно, конструкция
Код
-C2:C9/(A2:A9=E3)/(B2:B9=F3)
выдаёт в случае совпадения параметров или ноль или отрицательное число, которое ПРОСМОТР() и находит. Формула работает с нулевыми и положительными значениями, если м.б. отрицательные - используйте
Код
=ПРОСМОТР(9^9;C2:C9/(A2:A9=E3)/(B2:B9=F3))
- эта формула ищет просто очень большое число (9^9)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеконструкция
Код
ПРОСМОТР(;
ищет первое нулевое значение, соответственно, конструкция
Код
-C2:C9/(A2:A9=E3)/(B2:B9=F3)
выдаёт в случае совпадения параметров или ноль или отрицательное число, которое ПРОСМОТР() и находит. Формула работает с нулевыми и положительными значениями, если м.б. отрицательные - используйте
Код
=ПРОСМОТР(9^9;C2:C9/(A2:A9=E3)/(B2:B9=F3))
- эта формула ищет просто очень большое число (9^9)

Автор - buchlotnik
Дата добавления - 11.02.2016 в 09:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Двойное применение ВПР (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!