Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборочное суммирование - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборочное суммирование (Формулы/Formulas)
Выборочное суммирование
VIDEO56 Дата: Пятница, 12.02.2016, 09:59 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Всем доброго здоровья и удачной пятницы.
Прошу подсказать формулу (подозреваю что она массивная), чтобы просуммировать значения избегая формулы суммеслимн.
В примере все думаю понятно.
К сообщению приложен файл: 8151896.xlsm(12Kb)


Всем удачного дня!
 
Ответить
СообщениеВсем доброго здоровья и удачной пятницы.
Прошу подсказать формулу (подозреваю что она массивная), чтобы просуммировать значения избегая формулы суммеслимн.
В примере все думаю понятно.

Автор - VIDEO56
Дата добавления - 12.02.2016 в 09:59
Nic70y Дата: Пятница, 12.02.2016, 10:02 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
не массивная
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСКПОЗ(A2:A6;P2:P8;))*D2:D6)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениене массивная
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСКПОЗ(A2:A6;P2:P8;))*D2:D6)

Автор - Nic70y
Дата добавления - 12.02.2016 в 10:02
VIDEO56 Дата: Пятница, 12.02.2016, 10:04 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Nic70y, Спасибо за скорость и качество!
Удачных выходных!


Всем удачного дня!
 
Ответить
СообщениеNic70y, Спасибо за скорость и качество!
Удачных выходных!

Автор - VIDEO56
Дата добавления - 12.02.2016 в 10:04
buchlotnik Дата: Пятница, 12.02.2016, 10:06 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Код
=СУММПРОИЗВ(D2:D6*ЕЧИСЛО(ПОИСКПОЗ(A2:A6;P2:P8;0)))
К сообщению приложен файл: 1640149.xlsm(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(D2:D6*ЕЧИСЛО(ПОИСКПОЗ(A2:A6;P2:P8;0)))

Автор - buchlotnik
Дата добавления - 12.02.2016 в 10:06
VIDEO56 Дата: Пятница, 12.02.2016, 10:12 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Есть особенность. В исходном файле формула которая не дает корректно считать.
К сообщению приложен файл: 9130449.xlsm(12Kb)


Всем удачного дня!
 
Ответить
СообщениеЕсть особенность. В исходном файле формула которая не дает корректно считать.

Автор - VIDEO56
Дата добавления - 12.02.2016 в 10:12
Nic70y Дата: Пятница, 12.02.2016, 10:15 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСКПОЗ(A2:A6;P2:P8;))*(0&D2:D6))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСКПОЗ(A2:A6;P2:P8;))*(0&D2:D6))

Автор - Nic70y
Дата добавления - 12.02.2016 в 10:15
китин Дата: Пятница, 12.02.2016, 10:18 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Максим ну дык поменяйте в ЕСЛИ "" на 0(ноль)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеМаксим ну дык поменяйте в ЕСЛИ "" на 0(ноль)

Автор - китин
Дата добавления - 12.02.2016 в 10:18
VIDEO56 Дата: Пятница, 12.02.2016, 10:18 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Nic70y, еще раз респект!


Всем удачного дня!
 
Ответить
СообщениеNic70y, еще раз респект!

Автор - VIDEO56
Дата добавления - 12.02.2016 в 10:18
VIDEO56 Дата: Пятница, 12.02.2016, 10:20 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
китин, не нужны 0 в пустых ячейках. Так то понятно что с "" формула будет спотыкаться.
Все ровно спасибо


Всем удачного дня!
 
Ответить
Сообщениекитин, не нужны 0 в пустых ячейках. Так то понятно что с "" формула будет спотыкаться.
Все ровно спасибо

Автор - VIDEO56
Дата добавления - 12.02.2016 в 10:20
китин Дата: Пятница, 12.02.2016, 10:25 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
не нужны 0 в пустых ячейках

а что мешает их скрыть либо параметрами либо форматом?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
не нужны 0 в пустых ячейках

а что мешает их скрыть либо параметрами либо форматом?

Автор - китин
Дата добавления - 12.02.2016 в 10:25
_Boroda_ Дата: Пятница, 12.02.2016, 10:35 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
избегая формулы суммеслимн.

А чем не понравилась? В 2003 отсутствует? Тогда можно СУММЕСЛИ использовать
Код
=СУММПРОИЗВ(СУММЕСЛИ(A2:A6;P2:P8;D2:D6))
Немассивная
К сообщению приложен файл: 9130449_1.xlsm(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
избегая формулы суммеслимн.

А чем не понравилась? В 2003 отсутствует? Тогда можно СУММЕСЛИ использовать
Код
=СУММПРОИЗВ(СУММЕСЛИ(A2:A6;P2:P8;D2:D6))
Немассивная

Автор - _Boroda_
Дата добавления - 12.02.2016 в 10:35
VIDEO56 Дата: Пятница, 12.02.2016, 11:53 | Сообщение № 12
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Александр, честно говоря не додумался до этой формулы!
Буду иметь в виду на будущее.
Спасибо!


Всем удачного дня!
 
Ответить
СообщениеАлександр, честно говоря не додумался до этой формулы!
Буду иметь в виду на будущее.
Спасибо!

Автор - VIDEO56
Дата добавления - 12.02.2016 в 11:53
pokaio Дата: Пятница, 12.02.2016, 12:09 | Сообщение № 13
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем доброго времени суток. Появилась проблема во вкладке "По дням и часам" сводная таблица разбивка часов/дням из вкладки "все заказы", необходимо в ячейках где красные цифры вставить формулу которая по 3м условиям будет собирать среднее значение. вот мои попытки, но работает не корректно(( файл большой поэтому дам ссылку на гугл таблицу куда выложил файл удалено злым модератором
[moder]Тема закрыта. Читайте Правила форума.


Сообщение отредактировал _Boroda_ - Пятница, 12.02.2016, 12:11
 
Ответить
СообщениеВсем доброго времени суток. Появилась проблема во вкладке "По дням и часам" сводная таблица разбивка часов/дням из вкладки "все заказы", необходимо в ячейках где красные цифры вставить формулу которая по 3м условиям будет собирать среднее значение. вот мои попытки, но работает не корректно(( файл большой поэтому дам ссылку на гугл таблицу куда выложил файл удалено злым модератором
[moder]Тема закрыта. Читайте Правила форума.

Автор - pokaio
Дата добавления - 12.02.2016 в 12:09
pokaio Дата: Пятница, 12.02.2016, 12:10 | Сообщение № 14
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=iferror((AVERAGEIFS('все заказы'!$M:$M;'все заказы'!$L:$L;"="&G$2;'все заказы'!$K:$K;"="&$A7));" ") - мои попытки
 
Ответить
Сообщение=iferror((AVERAGEIFS('все заказы'!$M:$M;'все заказы'!$L:$L;"="&G$2;'все заказы'!$K:$K;"="&$A7));" ") - мои попытки

Автор - pokaio
Дата добавления - 12.02.2016 в 12:10
pokaio Дата: Пятница, 12.02.2016, 12:10 | Сообщение № 15
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Ну еще значения что больше ноля
 
Ответить
СообщениеНу еще значения что больше ноля

Автор - pokaio
Дата добавления - 12.02.2016 в 12:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборочное суммирование (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!