Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/присвоить определенное значение в зависимости от признаков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » присвоить определенное значение в зависимости от признаков (Формулы/Formulas)
присвоить определенное значение в зависимости от признаков
Lexx614 Дата: Пятница, 12.02.2016, 16:01 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем доброго времени суток. Помогите с формулой. В столбце А исходные данные собственно нужно соотнести к какой марке авто относится запрос. в массиве D3:F12 признаки марок. для каждой марки свой столбец. Нужно определить какой из признаков присутсвует и подставить в столбец B соответсвующее значение из D2:F2. Массивы естественно существенно шире.
К сообщению приложен файл: 1659919.xlsx(9Kb)
 
Ответить
СообщениеВсем доброго времени суток. Помогите с формулой. В столбце А исходные данные собственно нужно соотнести к какой марке авто относится запрос. в массиве D3:F12 признаки марок. для каждой марки свой столбец. Нужно определить какой из признаков присутсвует и подставить в столбец B соответсвующее значение из D2:F2. Массивы естественно существенно шире.

Автор - Lexx614
Дата добавления - 12.02.2016 в 16:01
Udik Дата: Пятница, 12.02.2016, 17:26 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1209
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
Как-то не очень понятно. Вы бы пример поразвёрнутей привели: что есть, что должно получиться.


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеКак-то не очень понятно. Вы бы пример поразвёрнутей привели: что есть, что должно получиться.

Автор - Udik
Дата добавления - 12.02.2016 в 17:26
Lexx614 Дата: Пятница, 12.02.2016, 17:45 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
пример файла переделал.
Есть куча запросов желтым выделил. нужно понять к какой марке авто какой запрос относится. зеленое поле
есть список марок (красным) и под каждой маркой слова признаки относящиеся к конкретной марке (синим). т.е. когда в запросе написанно: "сломался ВАЗ", нужно что б появился признак ВАЗ. а если написанно: "ошибка чек 2110" то все равно ВАЗ.На запросы "ошибка Ford", "ошибка Форд", "ошибка фокус 2" признак Ford. Люди разные кто то указывает марку на русском а кто то на английском, кто только модель пишет, а кто то с ошибками.
К сообщению приложен файл: 8280435.xlsx(9Kb)
 
Ответить
Сообщениепример файла переделал.
Есть куча запросов желтым выделил. нужно понять к какой марке авто какой запрос относится. зеленое поле
есть список марок (красным) и под каждой маркой слова признаки относящиеся к конкретной марке (синим). т.е. когда в запросе написанно: "сломался ВАЗ", нужно что б появился признак ВАЗ. а если написанно: "ошибка чек 2110" то все равно ВАЗ.На запросы "ошибка Ford", "ошибка Форд", "ошибка фокус 2" признак Ford. Люди разные кто то указывает марку на русском а кто то на английском, кто только модель пишет, а кто то с ошибками.

Автор - Lexx614
Дата добавления - 12.02.2016 в 17:45
SLAVICK Дата: Пятница, 12.02.2016, 17:51 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1836
Репутация: 613 ±
Замечаний: 0% ±

2007,2010,2013,2016
Так?
Формула массива
Код
=ИНДЕКС($A$2:$F$2;1;МАКС(ЕСЛИ(ЕЧИСЛО(ПОИСК($D$2:$F$17;A3;1))*(ДЛСТР($D$2:$F$17)>1);СТОЛБЕЦ($D$2:$F$17);0)))

И немного короче
Код
=ИНДЕКС($A$2:$F$2;1;МАКС(ЕЧИСЛО(ПОИСК($D$2:$F$17;A3;1))*(ДЛСТР($D$2:$F$17)>1)*СТОЛБЕЦ($D$2:$F$17)))
К сообщению приложен файл: 3188150.xlsx(11Kb)


Иногда все проще чем кажется с первого взгляда.

Сообщение отредактировал SLAVICK - Пятница, 12.02.2016, 17:54
 
Ответить
СообщениеТак?
Формула массива
Код
=ИНДЕКС($A$2:$F$2;1;МАКС(ЕСЛИ(ЕЧИСЛО(ПОИСК($D$2:$F$17;A3;1))*(ДЛСТР($D$2:$F$17)>1);СТОЛБЕЦ($D$2:$F$17);0)))

И немного короче
Код
=ИНДЕКС($A$2:$F$2;1;МАКС(ЕЧИСЛО(ПОИСК($D$2:$F$17;A3;1))*(ДЛСТР($D$2:$F$17)>1)*СТОЛБЕЦ($D$2:$F$17)))

Автор - SLAVICK
Дата добавления - 12.02.2016 в 17:51
Udik Дата: Пятница, 12.02.2016, 18:34 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1209
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
или так
Код
{=ИНДЕКС($D$14:$F$14;;МАКС(ЕСЛИОШИБКА(ПОИСК($D$14:$F$23;A15)>0;0)*СТОЛБЕЦ($D$14:$F$23)*($D$14:$F$23<>""))-3)}

тоже массивка
[p.s.]но если слово в условном словаре отсутствует (привет грамматике), то индейская изба построится :)
К сообщению приложен файл: 0t.xlsx(12Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Пятница, 12.02.2016, 18:40
 
Ответить
Сообщениеили так
Код
{=ИНДЕКС($D$14:$F$14;;МАКС(ЕСЛИОШИБКА(ПОИСК($D$14:$F$23;A15)>0;0)*СТОЛБЕЦ($D$14:$F$23)*($D$14:$F$23<>""))-3)}

тоже массивка
[p.s.]но если слово в условном словаре отсутствует (привет грамматике), то индейская изба построится :)

Автор - Udik
Дата добавления - 12.02.2016 в 18:34
Lexx614 Дата: Пятница, 12.02.2016, 18:35 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
SLAVICK, странно, у вас вроде все получилось. В вашем же файле, если в ячеку с формулой курсором ткнуть то #знач появляется.
 
Ответить
СообщениеSLAVICK, странно, у вас вроде все получилось. В вашем же файле, если в ячеку с формулой курсором ткнуть то #знач появляется.

Автор - Lexx614
Дата добавления - 12.02.2016 в 18:35
buchlotnik Дата: Пятница, 12.02.2016, 18:37 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
сказано же
Цитата
Формула массива
формулу вводить <ctrl>+<shift>+<enter>


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениесказано же
Цитата
Формула массива
формулу вводить <ctrl>+<shift>+<enter>

Автор - buchlotnik
Дата добавления - 12.02.2016 в 18:37
Lexx614 Дата: Пятница, 12.02.2016, 18:41 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
buchlotnik, Ладно ладно. кто ж знал как их вводить. Шучу. Спасибо за подсказку.
SLAVICK, Спасибо за формулу. Сам бы ни за что не написал. Тем более про формулы массива сегодня только узнал.
 
Ответить
Сообщениеbuchlotnik, Ладно ладно. кто ж знал как их вводить. Шучу. Спасибо за подсказку.
SLAVICK, Спасибо за формулу. Сам бы ни за что не написал. Тем более про формулы массива сегодня только узнал.

Автор - Lexx614
Дата добавления - 12.02.2016 в 18:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » присвоить определенное значение в зависимости от признаков (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!