Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Office 2010. Сравнение двух таблиц по номеру. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Office 2010. Сравнение двух таблиц по номеру. (Формулы/Formulas)
Office 2010. Сравнение двух таблиц по номеру.
diego Дата: Понедельник, 15.02.2016, 10:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, уважаемые знатоки Эксель.
Много тем уже создано, с которой я сталкиваюсь, но так и не смог разобраться. Подскажите как сообразить, либо дайте ссылку на похожий источник, пожалуйста.
Вопрос: есть два файла 1 и 2. Необходимо их сравнить по номенклатурному номеру. Номера, которые есть в таблице 1 добавить в таблицу 2 с сохранением данных в строке. Проще говоря, перенести три выделенных столбца таблицы 1 в таблицу 2. Те номера таблицы 2, которых нет в таблице 1 оставить без изменения.
Номенклатурных номеров в оригинальной таблице более 3000, какой способ лучше? Желательно формулу.
зы: не судите строго, я здесь недавно, ваш опыт мне очень нужен.
К сообщению приложен файл: 0844346.xlsx(11Kb) · 8016072.xlsx(11Kb)


Спасибо за хороший сервис сайта.
 
Ответить
СообщениеЗдравствуйте, уважаемые знатоки Эксель.
Много тем уже создано, с которой я сталкиваюсь, но так и не смог разобраться. Подскажите как сообразить, либо дайте ссылку на похожий источник, пожалуйста.
Вопрос: есть два файла 1 и 2. Необходимо их сравнить по номенклатурному номеру. Номера, которые есть в таблице 1 добавить в таблицу 2 с сохранением данных в строке. Проще говоря, перенести три выделенных столбца таблицы 1 в таблицу 2. Те номера таблицы 2, которых нет в таблице 1 оставить без изменения.
Номенклатурных номеров в оригинальной таблице более 3000, какой способ лучше? Желательно формулу.
зы: не судите строго, я здесь недавно, ваш опыт мне очень нужен.

Автор - diego
Дата добавления - 15.02.2016 в 10:49
SLAVICK Дата: Понедельник, 15.02.2016, 10:54 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1849
Репутация: 614 ±
Замечаний: 0% ±

2007,2010,2013,2016
Используйте ВПР().
Посмотрите тут видео есть.
Да и поиском по сайту можно пользоваться. Такие темы по несколько в день.


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеИспользуйте ВПР().
Посмотрите тут видео есть.
Да и поиском по сайту можно пользоваться. Такие темы по несколько в день.

Автор - SLAVICK
Дата добавления - 15.02.2016 в 10:54
Roman777 Дата: Понедельник, 15.02.2016, 11:00 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 703
Репутация: 75 ±
Замечаний: 0% ±

Excel 2007, Excel 2013
diego,
Код
=ЕСЛИОШИБКА(ЕСЛИ(ВПР(A2;[0844346.xlsx]Лист1!$A:$G;7;0)="";"";ВПР(A2;[0844346.xlsx]Лист1!$A:$G;7;0));"")

Код
=ЕСЛИОШИБКА(ЕСЛИ(ВПР(A2;[0844346.xlsx]Лист1!$A:$H;8;0)="";"";ВПР(A2;[0844346.xlsx]Лист1!$A:$H;8;0));"")

Код
=ЕСЛИОШИБКА(ЕСЛИ(ВПР(A2;[0844346.xlsx]Лист1!$A:$I;9;0)="";"";ВПР(A2;[0844346.xlsx]Лист1!$A:$I;9;0));"")

где 0844346.xlsx - книга, на которую ссылаетесь...
К сообщению приложен файл: diego.rar(20Kb)


Много чего не знаю!!!!

Сообщение отредактировал Roman777 - Понедельник, 15.02.2016, 11:02
 
Ответить
Сообщениеdiego,
Код
=ЕСЛИОШИБКА(ЕСЛИ(ВПР(A2;[0844346.xlsx]Лист1!$A:$G;7;0)="";"";ВПР(A2;[0844346.xlsx]Лист1!$A:$G;7;0));"")

Код
=ЕСЛИОШИБКА(ЕСЛИ(ВПР(A2;[0844346.xlsx]Лист1!$A:$H;8;0)="";"";ВПР(A2;[0844346.xlsx]Лист1!$A:$H;8;0));"")

Код
=ЕСЛИОШИБКА(ЕСЛИ(ВПР(A2;[0844346.xlsx]Лист1!$A:$I;9;0)="";"";ВПР(A2;[0844346.xlsx]Лист1!$A:$I;9;0));"")

где 0844346.xlsx - книга, на которую ссылаетесь...

Автор - Roman777
Дата добавления - 15.02.2016 в 11:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Office 2010. Сравнение двух таблиц по номеру. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!