Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск и подстановка строк при горизонтальном просмотре - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и подстановка строк при горизонтальном просмотре (Формулы/Formulas)
Поиск и подстановка строк при горизонтальном просмотре
VIDEO56 Дата: Вторник, 16.02.2016, 10:12 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Всем доброго дня.
Есть проблема при составлении договора. Имеется лист "Справочник" на котором 2 варианта договора. При выборе одного из них должна формироваться его фабула. Проблема в том что при использовании ГПР нужно в каждую ячейку влазить и менять номер строки вручную. Можно ли привязаться к строке из листа справочника и при протяжке формулы происходило смещение по строкам и в листе справочник
К сообщению приложен файл: 9509558.xlsm(21Kb)


Всем удачного дня!

Сообщение отредактировал VIDEO56 - Вторник, 16.02.2016, 10:12
 
Ответить
СообщениеВсем доброго дня.
Есть проблема при составлении договора. Имеется лист "Справочник" на котором 2 варианта договора. При выборе одного из них должна формироваться его фабула. Проблема в том что при использовании ГПР нужно в каждую ячейку влазить и менять номер строки вручную. Можно ли привязаться к строке из листа справочника и при протяжке формулы происходило смещение по строкам и в листе справочник

Автор - VIDEO56
Дата добавления - 16.02.2016 в 10:12
китин Дата: Вторник, 16.02.2016, 10:18 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
А может так ?
Код
=ЕСЛИОШИБКА(ГПР(ВПР(ИСТИНА;Справочник!$A$1:$B$2;2;ЛОЖЬ);Справочник!C:D;СТРОКА();ЛОЖЬ);"Выберите стороны договора")
К сообщению приложен файл: 9558.xlsm(27Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 16.02.2016, 10:18
 
Ответить
СообщениеА может так ?
Код
=ЕСЛИОШИБКА(ГПР(ВПР(ИСТИНА;Справочник!$A$1:$B$2;2;ЛОЖЬ);Справочник!C:D;СТРОКА();ЛОЖЬ);"Выберите стороны договора")

Автор - китин
Дата добавления - 16.02.2016 в 10:18
VIDEO56 Дата: Вторник, 16.02.2016, 10:24 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
китин, спасибо. Я уже голову сломал с индексом и поиском. Оказалось все проще.


Всем удачного дня!
 
Ответить
Сообщениекитин, спасибо. Я уже голову сломал с индексом и поиском. Оказалось все проще.

Автор - VIDEO56
Дата добавления - 16.02.2016 в 10:24
VIDEO56 Дата: Вторник, 16.02.2016, 10:29 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
китин, ан нет. Рано обрадовался. Нумерация строк в справочнике и в договоре не совпадает
Вот нумерация строк в файле
К сообщению приложен файл: 2431169.xlsm(21Kb)


Всем удачного дня!

Сообщение отредактировал VIDEO56 - Вторник, 16.02.2016, 10:29
 
Ответить
Сообщениекитин, ан нет. Рано обрадовался. Нумерация строк в справочнике и в договоре не совпадает
Вот нумерация строк в файле

Автор - VIDEO56
Дата добавления - 16.02.2016 в 10:29
Nic70y Дата: Вторник, 16.02.2016, 10:35 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
если правильно понял
Код
=ИНДЕКС(Справочник!$C$1:$D$47;СТРОКА(A1);ПОИСКПОЗ(1=1;Справочник!$A$1:$A$4;))&""
К сообщению приложен файл: 3665710.xlsm(24Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеесли правильно понял
Код
=ИНДЕКС(Справочник!$C$1:$D$47;СТРОКА(A1);ПОИСКПОЗ(1=1;Справочник!$A$1:$A$4;))&""

Автор - Nic70y
Дата добавления - 16.02.2016 в 10:35
китин Дата: Вторник, 16.02.2016, 10:36 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
VIDEO56, поставьте вместо СТРОКА() СТРОКА(A1)+1.то есть если табл.начинается со второй строки, то СТРОКА(A1)+1 если с третьей то СТРОКА(A1)+2.это про лист справочник
К сообщению приложен файл: 1169-1.xlsm(27Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеVIDEO56, поставьте вместо СТРОКА() СТРОКА(A1)+1.то есть если табл.начинается со второй строки, то СТРОКА(A1)+1 если с третьей то СТРОКА(A1)+2.это про лист справочник

Автор - китин
Дата добавления - 16.02.2016 в 10:36
VIDEO56 Дата: Вторник, 16.02.2016, 10:42 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
китин, вот теперь пестня! Спасибо еще раз.


Всем удачного дня!
 
Ответить
Сообщениекитин, вот теперь пестня! Спасибо еще раз.

Автор - VIDEO56
Дата добавления - 16.02.2016 в 10:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и подстановка строк при горизонтальном просмотре (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!