Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет пустых ячеек через неравные промежутки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет пустых ячеек через неравные промежутки (Формулы/Formulas)
Подсчет пустых ячеек через неравные промежутки
Тормозяка Дата: Среда, 17.02.2016, 09:28 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
В столбце подсчитать пустые ячейки через НЕРАВНЫЕ промежутки
К сообщению приложен файл: 3237905.xlsx(32Kb)


Эвольвенты одной эволюты- эквидистантны!
 
Ответить
СообщениеВ столбце подсчитать пустые ячейки через НЕРАВНЫЕ промежутки

Автор - Тормозяка
Дата добавления - 17.02.2016 в 09:28
Nic70y Дата: Среда, 17.02.2016, 09:33 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
у Вас их там нет, все ячейки заполнены.
Код
=СЧЁТЕСЛИ(B2:B1678;"<=3")
Код
=СЧЁТЕСЛИ(B2:B1678;"<4")
если не то, покажите что должно получиться


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Среда, 17.02.2016, 09:34
 
Ответить
Сообщениеу Вас их там нет, все ячейки заполнены.
Код
=СЧЁТЕСЛИ(B2:B1678;"<=3")
Код
=СЧЁТЕСЛИ(B2:B1678;"<4")
если не то, покажите что должно получиться

Автор - Nic70y
Дата добавления - 17.02.2016 в 09:33
Тормозяка Дата: Среда, 17.02.2016, 12:05 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, Да там у меня нули. Я их просто скрыл. Мне надо произвести подсчет этих скрытых нулей МЕЖДУ ЯЧЕЙКАМИ БОЛЬШЕ НУЛЯ. Ячейки больше нуля можно игнорировать. Результат должен получиться как в файле в столбце "С"
К сообщению приложен файл: 8682900.xlsx(34Kb)


Эвольвенты одной эволюты- эквидистантны!
 
Ответить
СообщениеNic70y, Да там у меня нули. Я их просто скрыл. Мне надо произвести подсчет этих скрытых нулей МЕЖДУ ЯЧЕЙКАМИ БОЛЬШЕ НУЛЯ. Ячейки больше нуля можно игнорировать. Результат должен получиться как в файле в столбце "С"

Автор - Тормозяка
Дата добавления - 17.02.2016 в 12:05
Manyasha Дата: Среда, 17.02.2016, 12:14 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1587
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
Тормозяка, так подойдет?
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($B$2:$B$1678>3;СТРОКА($B$2:$B$1678)-1;"");СТРОКА(B2))-НАИМЕНЬШИЙ(ЕСЛИ($B$2:$B$1678>3;СТРОКА($B$2:$B$1678)-1;"");СТРОКА(B1))-1;"")

формула массива, вводить через ctrl+shift+enter.
К сообщению приложен файл: 8682900-1.xlsx(41Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеТормозяка, так подойдет?
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($B$2:$B$1678>3;СТРОКА($B$2:$B$1678)-1;"");СТРОКА(B2))-НАИМЕНЬШИЙ(ЕСЛИ($B$2:$B$1678>3;СТРОКА($B$2:$B$1678)-1;"");СТРОКА(B1))-1;"")

формула массива, вводить через ctrl+shift+enter.

Автор - Manyasha
Дата добавления - 17.02.2016 в 12:14
Тормозяка Дата: Среда, 17.02.2016, 12:27 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Manyasha, Огромное спасибо. Все получилось. Вы меня избавили от тупой обработки 100000 ячеек! hands hands hands


Эвольвенты одной эволюты- эквидистантны!
 
Ответить
СообщениеManyasha, Огромное спасибо. Все получилось. Вы меня избавили от тупой обработки 100000 ячеек! hands hands hands

Автор - Тормозяка
Дата добавления - 17.02.2016 в 12:27
Тормозяка Дата: Четверг, 18.02.2016, 06:45 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Manyasha, Караул!!! С новыми данными Ваша формула не работает. Хотя шаманил и бил в бубен. Видимо сильно торможу.
К сообщению приложен файл: 9718725.xlsx(52Kb)


Эвольвенты одной эволюты- эквидистантны!
 
Ответить
СообщениеManyasha, Караул!!! С новыми данными Ваша формула не работает. Хотя шаманил и бил в бубен. Видимо сильно торможу.

Автор - Тормозяка
Дата добавления - 18.02.2016 в 06:45
Nic70y Дата: Четверг, 18.02.2016, 07:56 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
>3 замените на >0
и соот $B$2:$B$1678 на $B$2:$B$3001


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 18.02.2016, 07:58
 
Ответить
Сообщение>3 замените на >0
и соот $B$2:$B$1678 на $B$2:$B$3001

Автор - Nic70y
Дата добавления - 18.02.2016 в 07:56
Тормозяка Дата: Четверг, 18.02.2016, 08:06 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, Менял! и =1 ставил. Не работает, блин. :(


Эвольвенты одной эволюты- эквидистантны!
 
Ответить
СообщениеNic70y, Менял! и =1 ставил. Не работает, блин. :(

Автор - Тормозяка
Дата добавления - 18.02.2016 в 08:06
Nic70y Дата: Четверг, 18.02.2016, 08:11 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Смотрите файл (в формулу не вникал, просто поставил =1 и сменил диапазон)

добавил свою формулу (принцип тот же)
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(B$2:B$3001=1;A$2:A$3001);СТРОКА(A2))-НАИМЕНЬШИЙ(ЕСЛИ(B$2:B$3001=1;A$2:A$3001);СТРОКА(A1))-1;"")
файл перезалил
К сообщению приложен файл: 9718725-1-.xlsx(57Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 18.02.2016, 08:23
 
Ответить
СообщениеСмотрите файл (в формулу не вникал, просто поставил =1 и сменил диапазон)

добавил свою формулу (принцип тот же)
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(B$2:B$3001=1;A$2:A$3001);СТРОКА(A2))-НАИМЕНЬШИЙ(ЕСЛИ(B$2:B$3001=1;A$2:A$3001);СТРОКА(A1))-1;"")
файл перезалил

Автор - Nic70y
Дата добавления - 18.02.2016 в 08:11
Тормозяка Дата: Четверг, 18.02.2016, 08:23 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y,Спасибо!!! Заработало!!! А я явно торможу. С меня причитается. thumb respect pray


Эвольвенты одной эволюты- эквидистантны!
 
Ответить
СообщениеNic70y,Спасибо!!! Заработало!!! А я явно торможу. С меня причитается. thumb respect pray

Автор - Тормозяка
Дата добавления - 18.02.2016 в 08:23
Nic70y Дата: Четверг, 18.02.2016, 08:40 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Эх, чувствую зависнет :(
немассивный вариант в C1
Код
=ПОИСКПОЗ(1;B$2:B$100000;)
с C2 и далее
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(1;ИНДЕКС(B$2:B$100000;СУММ(C$1:C1)+A2):B$100000;)-1;"")
К сообщению приложен файл: 7471625.xlsx(50Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеЭх, чувствую зависнет :(
немассивный вариант в C1
Код
=ПОИСКПОЗ(1;B$2:B$100000;)
с C2 и далее
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(1;ИНДЕКС(B$2:B$100000;СУММ(C$1:C1)+A2):B$100000;)-1;"")

Автор - Nic70y
Дата добавления - 18.02.2016 в 08:40
Тормозяка Дата: Четверг, 18.02.2016, 13:16 | Сообщение № 12
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, Пока не виснет, но файл скачал на всяк случай. Спасибо большое. Может подскажете как избавится от #ДЕЛ/0!
[moder]Пора читать Правила форума.


Эвольвенты одной эволюты- эквидистантны!

Сообщение отредактировал _Boroda_ - Четверг, 18.02.2016, 13:31
 
Ответить
СообщениеNic70y, Пока не виснет, но файл скачал на всяк случай. Спасибо большое. Может подскажете как избавится от #ДЕЛ/0!
[moder]Пора читать Правила форума.

Автор - Тормозяка
Дата добавления - 18.02.2016 в 13:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет пустых ячеек через неравные промежутки (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!