Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/посчитать долю от ОПРЕДЕЛЕННОГО ЧИСЛА - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » посчитать долю от ОПРЕДЕЛЕННОГО ЧИСЛА (Формулы/Formulas)
посчитать долю от ОПРЕДЕЛЕННОГО ЧИСЛА
АЛЕКСАНДР1986 Дата: Среда, 17.02.2016, 09:53 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
доброе утро всем!
есть таблица с данными можно ли как-то посчитать долю допустим в рамках одного вопроса "автомобильный транспорт"
но не от суммы которые составляют эти вопросы(что уже сделано в примере в колонке доля) а от определенного числа записанного в строке "автомобильный транспорт Итог"
и так для каждого вопроса?
[moder]Можно. Файл где?
К сообщению приложен файл: 5232062.xlsx(18Kb)


Сообщение отредактировал АЛЕКСАНДР1986 - Среда, 17.02.2016, 10:03
 
Ответить
Сообщениедоброе утро всем!
есть таблица с данными можно ли как-то посчитать долю допустим в рамках одного вопроса "автомобильный транспорт"
но не от суммы которые составляют эти вопросы(что уже сделано в примере в колонке доля) а от определенного числа записанного в строке "автомобильный транспорт Итог"
и так для каждого вопроса?
[moder]Можно. Файл где?

Автор - АЛЕКСАНДР1986
Дата добавления - 17.02.2016 в 09:53
_Boroda_ Дата: Среда, 17.02.2016, 10:09 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=E3/СУММЕСЛИ(A$3:A$93;A3;E$3:E$93)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=E3/СУММЕСЛИ(A$3:A$93;A3;E$3:E$93)

Автор - _Boroda_
Дата добавления - 17.02.2016 в 10:09
АЛЕКСАНДР1986 Дата: Среда, 17.02.2016, 10:13 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Не немножко нето. Имелось ввиду то что нужно долю считать от желтой строки а она не равна сумме с 3 по 11 строку!
 
Ответить
СообщениеНе немножко нето. Имелось ввиду то что нужно долю считать от желтой строки а она не равна сумме с 3 по 11 строку!

Автор - АЛЕКСАНДР1986
Дата добавления - 17.02.2016 в 10:13
_Boroda_ Дата: Среда, 17.02.2016, 10:16 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да, не заметил. Тем более, что у ВАс тоже такая формула - ее я тоже не заметил.
Тогда так
Код
=E3/ИНДЕКС(E3:E$93;ПОИСКПОЗ(A3&" Итог";A3:A$93;))

Код
=ЕСЛИОШИБКА(E3/ИНДЕКС(E3:E$93;ПОИСКПОЗ(A3&" Итог";A3:A$93;));"")

ВПР, ПРОСМОТР, СУММЕСЛИ...
Код
=ЕСЛИОШИБКА(E3/ВПР(A3&" Итог";A3:E$93;5;);"")

Код
=E3/СУММЕСЛИ(A3:A$93;A3&" Итог";E3:E$93)

Код
=ЕСЛИОШИБКА(E3/ПРОСМОТР(;-1/(A3&" Итог"=A3:A$93);E3:E$93);"")
К сообщению приложен файл: 5232062_2.xlsx(20Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа, не заметил. Тем более, что у ВАс тоже такая формула - ее я тоже не заметил.
Тогда так
Код
=E3/ИНДЕКС(E3:E$93;ПОИСКПОЗ(A3&" Итог";A3:A$93;))

Код
=ЕСЛИОШИБКА(E3/ИНДЕКС(E3:E$93;ПОИСКПОЗ(A3&" Итог";A3:A$93;));"")

ВПР, ПРОСМОТР, СУММЕСЛИ...
Код
=ЕСЛИОШИБКА(E3/ВПР(A3&" Итог";A3:E$93;5;);"")

Код
=E3/СУММЕСЛИ(A3:A$93;A3&" Итог";E3:E$93)

Код
=ЕСЛИОШИБКА(E3/ПРОСМОТР(;-1/(A3&" Итог"=A3:A$93);E3:E$93);"")

Автор - _Boroda_
Дата добавления - 17.02.2016 в 10:16
АЛЕКСАНДР1986 Дата: Среда, 17.02.2016, 10:44 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
спасибо!
 
Ответить
Сообщениеспасибо!

Автор - АЛЕКСАНДР1986
Дата добавления - 17.02.2016 в 10:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » посчитать долю от ОПРЕДЕЛЕННОГО ЧИСЛА (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!