Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма ячеек содержащих числа и символ (букву) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма ячеек содержащих числа и символ (букву) (Формулы/Formulas)
Сумма ячеек содержащих числа и символ (букву)
KatiaW Дата: Пятница, 19.02.2016, 05:01 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте,

подскажите, какую формулу нужно использовать, чтобы суммировать ячейки с числами и буквенным знаком.
Похожую тему я не нашла, но если она существует буду благодарна за ссылку.
Пример в приложении.

заранее спасибо
Катя
К сообщению приложен файл: 1306215.xlsx(9Kb)
 
Ответить
СообщениеЗдравствуйте,

подскажите, какую формулу нужно использовать, чтобы суммировать ячейки с числами и буквенным знаком.
Похожую тему я не нашла, но если она существует буду благодарна за ссылку.
Пример в приложении.

заранее спасибо
Катя

Автор - KatiaW
Дата добавления - 19.02.2016 в 05:01
jakim Дата: Пятница, 19.02.2016, 05:34 | Сообщение № 2
Группа: Друзья
Ранг: Ветеран
Сообщений: 680
Репутация: 172 ±
Замечаний: 0% ±

Ctrl+h уберите сочетание" р.", затем также между цифрами пробел и через специальную вставку умножьте на "1" и сложите.
В этом случае можно обойтись без формул.
К сообщению приложен файл: of_1306215.xlsx(9Kb)
 
Ответить
Сообщение
Ctrl+h уберите сочетание" р.", затем также между цифрами пробел и через специальную вставку умножьте на "1" и сложите.
В этом случае можно обойтись без формул.

Автор - jakim
Дата добавления - 19.02.2016 в 05:34
Nic70y Дата: Пятница, 19.02.2016, 07:25 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(C3:C5;"р.";))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(C3:C5;"р.";))

Автор - Nic70y
Дата добавления - 19.02.2016 в 07:25
KatiaW Дата: Суббота, 20.02.2016, 03:18 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
jakim, в примере всего пара строк, но в реальном документе их слишком много чтобы убрать буквенное сочетание вручную.
Файл продаж, который я скачиваю из моей рабочей продажи сохраняется в формате .csv
После конвертации в эксель суммы остаются в формате, который я привела в примере.
Символ "р." обязательный, мне его не убрать, могу только заменить на другой.

Nic70v, скорее всего предложенная вами формула правильная, но пока все-равно не считает.
Может это из-за пробела?
Пример в приложении.

С этим можно что-то сделать?
К сообщению приложен файл: 8463727.xlsx(9Kb)
 
Ответить
Сообщениеjakim, в примере всего пара строк, но в реальном документе их слишком много чтобы убрать буквенное сочетание вручную.
Файл продаж, который я скачиваю из моей рабочей продажи сохраняется в формате .csv
После конвертации в эксель суммы остаются в формате, который я привела в примере.
Символ "р." обязательный, мне его не убрать, могу только заменить на другой.

Nic70v, скорее всего предложенная вами формула правильная, но пока все-равно не считает.
Может это из-за пробела?
Пример в приложении.

С этим можно что-то сделать?

Автор - KatiaW
Дата добавления - 20.02.2016 в 03:18
sv2014 Дата: Суббота, 20.02.2016, 05:49 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 156
Репутация: 37 ±
Замечаний: 0% ±

Excel 2013
KatiaW, попробуйте функцию yyy в E1

[vba]
Код
Function yyy#(r As Range)
    Dim c As Range
For Each c In r
    With CreateObject("VBScript.RegExp"): .Pattern = "(.+) р"
        If .test(c) Then yyy = yyy + .Execute(c)(0).Submatches(0)
    End With
Next
End Function
[/vba]
К сообщению приложен файл: example_21_02_2.xls(34Kb)


Сообщение отредактировал sv2014 - Суббота, 20.02.2016, 06:03
 
Ответить
СообщениеKatiaW, попробуйте функцию yyy в E1

[vba]
Код
Function yyy#(r As Range)
    Dim c As Range
For Each c In r
    With CreateObject("VBScript.RegExp"): .Pattern = "(.+) р"
        If .test(c) Then yyy = yyy + .Execute(c)(0).Submatches(0)
    End With
Next
End Function
[/vba]

Автор - sv2014
Дата добавления - 20.02.2016 в 05:49
sv2014 Дата: Суббота, 20.02.2016, 06:13 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 156
Репутация: 37 ±
Замечаний: 0% ±

Excel 2013
KatiaW, добавил функцию yyy1 в F1

[vba]
Код
Function yyy1#(r As Range)
    Dim c As Range
For Each c In r
          yyy1 = yyy1 + Split(c, "р")(0)
Next
End Function
[/vba]
К сообщению приложен файл: 6972942.xls(34Kb)


Сообщение отредактировал sv2014 - Суббота, 20.02.2016, 06:13
 
Ответить
СообщениеKatiaW, добавил функцию yyy1 в F1

[vba]
Код
Function yyy1#(r As Range)
    Dim c As Range
For Each c In r
          yyy1 = yyy1 + Split(c, "р")(0)
Next
End Function
[/vba]

Автор - sv2014
Дата добавления - 20.02.2016 в 06:13
Pelena Дата: Суббота, 20.02.2016, 07:01 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9869
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Символ "р." обязательный, мне его не убрать, могу только заменить на другой

А Вы в поле Заменить ничего не пишите, получится, что символ р. меняется на пусто, т.е. удаляется. То же самое можно сделать и с пробелом: Найти пробел -- Заменить на оставляете пустым.

Ну а если формулой, то добавьте ещё одну ПОДСТАВИТЬ() для удаления пробела
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(C3:C5;"р.";);" ";))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Символ "р." обязательный, мне его не убрать, могу только заменить на другой

А Вы в поле Заменить ничего не пишите, получится, что символ р. меняется на пусто, т.е. удаляется. То же самое можно сделать и с пробелом: Найти пробел -- Заменить на оставляете пустым.

Ну а если формулой, то добавьте ещё одну ПОДСТАВИТЬ() для удаления пробела
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(C3:C5;"р.";);" ";))

Автор - Pelena
Дата добавления - 20.02.2016 в 07:01
buchlotnik Дата: Суббота, 20.02.2016, 07:12 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
Может это из-за пробела?
так а что мешает его убрать?
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(C3:C5;" р.";))
К сообщению приложен файл: 1973196.xlsx(10Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Суббота, 20.02.2016, 07:16
 
Ответить
Сообщение
Цитата
Может это из-за пробела?
так а что мешает его убрать?
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(C3:C5;" р.";))

Автор - buchlotnik
Дата добавления - 20.02.2016 в 07:12
Pelena Дата: Суббота, 20.02.2016, 07:16 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9869
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Михаил, там ещё между тысячами пробел


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМихаил, там ещё между тысячами пробел

Автор - Pelena
Дата добавления - 20.02.2016 в 07:16
buchlotnik Дата: Суббота, 20.02.2016, 07:19 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Да, но пробел перед тысячами Excel благополучно проглатывает (ну и все бОльшие - миллионы, миллиарды и т.д.)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеДа, но пробел перед тысячами Excel благополучно проглатывает (ну и все бОльшие - миллионы, миллиарды и т.д.)

Автор - buchlotnik
Дата добавления - 20.02.2016 в 07:19
Pelena Дата: Суббота, 20.02.2016, 07:41 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9869
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Странно, у меня на исходном файле так не получается :(
Может, МАС чудит...


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеСтранно, у меня на исходном файле так не получается :(
Может, МАС чудит...

Автор - Pelena
Дата добавления - 20.02.2016 в 07:41
Nic70y Дата: Суббота, 20.02.2016, 07:50 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
но пока все-равно не считает
странно, у меня работает, но при открытии Вашего файла, до нажатия "разрешить редактирование" выдает #ЗНАЧ!
подозреваю, что разные версии ведут себя поразному.
воспользуйтесь формулой Pelena из сооб. №7 - так уж точно должно "всегда" сработать
[p.s.]у меня даже такие 1 000(много пробелов)р. обрабатывает
а Вы не пробовали денежный формат? тогда просто СУММ достаточно[/p.s.]


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Суббота, 20.02.2016, 08:05
 
Ответить
Сообщение
но пока все-равно не считает
странно, у меня работает, но при открытии Вашего файла, до нажатия "разрешить редактирование" выдает #ЗНАЧ!
подозреваю, что разные версии ведут себя поразному.
воспользуйтесь формулой Pelena из сооб. №7 - так уж точно должно "всегда" сработать
[p.s.]у меня даже такие 1 000(много пробелов)р. обрабатывает
а Вы не пробовали денежный формат? тогда просто СУММ достаточно[/p.s.]

Автор - Nic70y
Дата добавления - 20.02.2016 в 07:50
китин Дата: Суббота, 20.02.2016, 20:57 | Сообщение № 13
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3446
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
у меня и так
Код
=СУММ(--ПОДСТАВИТЬ($C$3:$C$5;" р.";""))
считает и так
Код
=СУММ(--ПОДСТАВИТЬ($C$3:$C$5;"р.";""))
( правда массивные) а вот
Код
=СУММ(--ЛЕВБ($C$3:$C$5;ПОИСК(" р";$C$3:$C$5)))
без пробела не хочет %)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеу меня и так
Код
=СУММ(--ПОДСТАВИТЬ($C$3:$C$5;" р.";""))
считает и так
Код
=СУММ(--ПОДСТАВИТЬ($C$3:$C$5;"р.";""))
( правда массивные) а вот
Код
=СУММ(--ЛЕВБ($C$3:$C$5;ПОИСК(" р";$C$3:$C$5)))
без пробела не хочет %)

Автор - китин
Дата добавления - 20.02.2016 в 20:57
KatiaW Дата: Суббота, 20.02.2016, 23:24 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, огромное спасибо!
Ваше решение помогло.
=)
 
Ответить
СообщениеPelena, огромное спасибо!
Ваше решение помогло.
=)

Автор - KatiaW
Дата добавления - 20.02.2016 в 23:24
Nic70y Дата: Воскресенье, 21.02.2016, 07:18 | Сообщение № 15
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
а вот ....... без пробела не хочет %)

значит у меня самый продвинутый Excel :p
К сообщению приложен файл: 0391445.jpg(51Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Воскресенье, 21.02.2016, 07:21
 
Ответить
Сообщение
а вот ....... без пробела не хочет %)

значит у меня самый продвинутый Excel :p

Автор - Nic70y
Дата добавления - 21.02.2016 в 07:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма ячеек содержащих числа и символ (букву) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!