Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложение положительных значений в диапазоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение положительных значений в диапазоне (Формулы/Formulas)
Сложение положительных значений в диапазоне
ZBestNub Дата: Пятница, 19.02.2016, 10:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте Уважаемые форумчане!

Обращаюсь со следующей ситуацией.
Есть 2 столбца, 1 с текстом (зачисление/списание/возврат и т.д.) другой со значениями числовыми.
Ищу функцию, которая бы позволила складывать все значения из 2 столбца при условии что в 1 столбце стоит "зачисление" и игнорировала бы все остальные числовые значения.

Заранее благодарю за любую помощь в данном вопросе! Спасибо!
К сообщению приложен файл: 9201588.xlsx(17Kb)
 
Ответить
СообщениеЗдравствуйте Уважаемые форумчане!

Обращаюсь со следующей ситуацией.
Есть 2 столбца, 1 с текстом (зачисление/списание/возврат и т.д.) другой со значениями числовыми.
Ищу функцию, которая бы позволила складывать все значения из 2 столбца при условии что в 1 столбце стоит "зачисление" и игнорировала бы все остальные числовые значения.

Заранее благодарю за любую помощь в данном вопросе! Спасибо!

Автор - ZBestNub
Дата добавления - 19.02.2016 в 10:46
Nic70y Дата: Пятница, 19.02.2016, 10:50 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3655
Репутация: 752 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММЕСЛИ(A1:A19;"зачисление";B1:B19)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММЕСЛИ(A1:A19;"зачисление";B1:B19)

Автор - Nic70y
Дата добавления - 19.02.2016 в 10:50
buchlotnik Дата: Пятница, 19.02.2016, 10:58 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 645 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
или так
Код
=СУММПРОИЗВ((A1:A19="Зачисление")*B1:B19)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеили так
Код
=СУММПРОИЗВ((A1:A19="Зачисление")*B1:B19)

Автор - buchlotnik
Дата добавления - 19.02.2016 в 10:58
_Boroda_ Дата: Пятница, 19.02.2016, 11:02 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9786
Репутация: 4135 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если названий операций, начинающихся на букву "з", больше нет, то можно
Код
=СУММЕСЛИ(A1:A19;"з*";B1:B19)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли названий операций, начинающихся на букву "з", больше нет, то можно
Код
=СУММЕСЛИ(A1:A19;"з*";B1:B19)

Автор - _Boroda_
Дата добавления - 19.02.2016 в 11:02
ZBestNub Дата: Пятница, 19.02.2016, 11:17 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
ой-ой-ой)) Спасибо большущее!!!

А что бы суммировались в 1 столбце ТОЛЬКО положительные значения? а отрицательные (имеют знак "-") игнорировались?


Сообщение отредактировал ZBestNub - Пятница, 19.02.2016, 11:20
 
Ответить
Сообщениеой-ой-ой)) Спасибо большущее!!!

А что бы суммировались в 1 столбце ТОЛЬКО положительные значения? а отрицательные (имеют знак "-") игнорировались?

Автор - ZBestNub
Дата добавления - 19.02.2016 в 11:17
buchlotnik Дата: Пятница, 19.02.2016, 11:24 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 645 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
ТОЛЬКО положительные
Код
=СУММПРОИЗВ((A1:A19="Зачисление")*(B1:B19>0)*B1:B19)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
ТОЛЬКО положительные
Код
=СУММПРОИЗВ((A1:A19="Зачисление")*(B1:B19>0)*B1:B19)

Автор - buchlotnik
Дата добавления - 19.02.2016 в 11:24
Nic70y Дата: Пятница, 19.02.2016, 11:24 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3655
Репутация: 752 ±
Замечаний: 0% ±

Excel 2013
все больше нуля:
Код
=СУММЕСЛИ(B1:B19;">0")
больше 0 и "зачисление"
Код
=СУММЕСЛИМН(B1:B19;A1:A19;"зачисление";B1:B19;">0")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениевсе больше нуля:
Код
=СУММЕСЛИ(B1:B19;">0")
больше 0 и "зачисление"
Код
=СУММЕСЛИМН(B1:B19;A1:A19;"зачисление";B1:B19;">0")

Автор - Nic70y
Дата добавления - 19.02.2016 в 11:24
_Boroda_ Дата: Пятница, 19.02.2016, 11:25 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9786
Репутация: 4135 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
отрицательные (имеют знак "-")

У Вас в файле таких нет
А вообще если - для сумм в столбце В
Код
=СУММЕСЛИ(B1:B19;">0")

Зачисление и отмена
Код
=СУММПРОИЗВ(СУММЕСЛИ(A1:A19;{"з*";"о*"};B1:B19))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
отрицательные (имеют знак "-")

У Вас в файле таких нет
А вообще если - для сумм в столбце В
Код
=СУММЕСЛИ(B1:B19;">0")

Зачисление и отмена
Код
=СУММПРОИЗВ(СУММЕСЛИ(A1:A19;{"з*";"о*"};B1:B19))

Автор - _Boroda_
Дата добавления - 19.02.2016 в 11:25
ZBestNub Дата: Пятница, 19.02.2016, 11:29 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Все, спасибо большое Мэтры!!! +)) Низкий поклон за оказанную помощь нубаське :)
 
Ответить
СообщениеВсе, спасибо большое Мэтры!!! +)) Низкий поклон за оказанную помощь нубаське :)

Автор - ZBestNub
Дата добавления - 19.02.2016 в 11:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение положительных значений в диапазоне (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!