Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма ячеек рядом с пустыми - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма ячеек рядом с пустыми (Формулы/Formulas)
Сумма ячеек рядом с пустыми
Zessus Дата: Пятница, 19.02.2016, 12:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Добрый день!
Вопрос следующий. Есть ряд ячеек. Необходимо посчитать сумму только тех, которые находяться рядом с пустыми. В данном случае сумму цифр в столбцах В и С рядом с которыми находятся пустые ячейки из столбца D. Желательно с помощью формулы.
Спасибо!
К сообщению приложен файл: 123.xls(26Kb)
 
Ответить
СообщениеДобрый день!
Вопрос следующий. Есть ряд ячеек. Необходимо посчитать сумму только тех, которые находяться рядом с пустыми. В данном случае сумму цифр в столбцах В и С рядом с которыми находятся пустые ячейки из столбца D. Желательно с помощью формулы.
Спасибо!

Автор - Zessus
Дата добавления - 19.02.2016 в 12:53
Manyasha Дата: Пятница, 19.02.2016, 12:57 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1582
Репутация: 659 ±
Замечаний: 0% ±

Excel 2007, 2010
Zessus, так?
Код
=ЕСЛИ(D1;"";СУММ(B1:C1))


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеZessus, так?
Код
=ЕСЛИ(D1;"";СУММ(B1:C1))

Автор - Manyasha
Дата добавления - 19.02.2016 в 12:57
Zessus Дата: Пятница, 19.02.2016, 13:04 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Manyasha, формула вполне подходит. Но можно сделать так, чтоб сумма охватывала весь массив (в данном случае В1:С34)?
И попутно - если ставишь 0, Excel "считает", что ячейка пуста. Этого можно избжать?


Сообщение отредактировал Zessus - Пятница, 19.02.2016, 13:08
 
Ответить
СообщениеManyasha, формула вполне подходит. Но можно сделать так, чтоб сумма охватывала весь массив (в данном случае В1:С34)?
И попутно - если ставишь 0, Excel "считает", что ячейка пуста. Этого можно избжать?

Автор - Zessus
Дата добавления - 19.02.2016 в 13:04
Che79 Дата: Пятница, 19.02.2016, 13:07 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 177
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
Zessus, добрый день!
Так нужно?
Код
=СУММПРОИЗВ(B1:C34*(D1:D34=""))


Делай нормально и будет нормально!
 
Ответить
СообщениеZessus, добрый день!
Так нужно?
Код
=СУММПРОИЗВ(B1:C34*(D1:D34=""))

Автор - Che79
Дата добавления - 19.02.2016 в 13:07
Zessus Дата: Пятница, 19.02.2016, 13:13 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Che79, когда считаешь по Вашей формуле, сумма выходит на 10 меньше, нежели фактическая
К сообщению приложен файл: 123_1.xls(27Kb)
 
Ответить
СообщениеChe79, когда считаешь по Вашей формуле, сумма выходит на 10 меньше, нежели фактическая

Автор - Zessus
Дата добавления - 19.02.2016 в 13:13
Zessus Дата: Пятница, 19.02.2016, 13:15 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Che79, Прошу прощения, Ваша формула отлично подходит. Спасибо!
 
Ответить
СообщениеChe79, Прошу прощения, Ваша формула отлично подходит. Спасибо!

Автор - Zessus
Дата добавления - 19.02.2016 в 13:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма ячеек рядом с пустыми (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!