Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенести повторяющиеся названия строк с данными в столбцы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенести повторяющиеся названия строк с данными в столбцы (Сводные таблицы/Pivot Table)
Перенести повторяющиеся названия строк с данными в столбцы
Jury_s Дата: Пятница, 19.02.2016, 23:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго времени суток!

Помоги пожалуйста с такой задачей: есть таблица, в первой колонке которой повторяются графы (имя, фамилия, дата рождения и т.п.), а в правой указаны данные по этим параметрам для разных людей. Нужно чтобы эти названия граф стали названиями столбцов, и данные для каждого человека были помещены в соответствующую графу по-порядку как они идут в первоначальном списке. Пробовал транспонированием и сводной таблицей, но результата не дало. В таблице больше 1000 человек, вручную переносить не вариант. Буду рад, если подскажете как это сделать. Заранее всем благодарен. Файл с образцом прикладываю.
К сообщению приложен файл: 7819976.xlsx(9Kb)
 
Ответить
СообщениеДоброго времени суток!

Помоги пожалуйста с такой задачей: есть таблица, в первой колонке которой повторяются графы (имя, фамилия, дата рождения и т.п.), а в правой указаны данные по этим параметрам для разных людей. Нужно чтобы эти названия граф стали названиями столбцов, и данные для каждого человека были помещены в соответствующую графу по-порядку как они идут в первоначальном списке. Пробовал транспонированием и сводной таблицей, но результата не дало. В таблице больше 1000 человек, вручную переносить не вариант. Буду рад, если подскажете как это сделать. Заранее всем благодарен. Файл с образцом прикладываю.

Автор - Jury_s
Дата добавления - 19.02.2016 в 23:06
_Boroda_ Дата: Пятница, 19.02.2016, 23:17 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС($B$1:$B$99;(СЧЁТЗ(E$1:E1)-1)*7+СЧЁТЗ($D2:D2)+1)

Код
=ИНДЕКС($B$1:$B$99;СЧЁТЗ($E$1:$K1)-7+СЧЁТЗ($D2:D2)+1)

Код
=ИНДЕКС($B$1:$B$99;СЧЁТЗ($E$1:$K1)-7+СЧЁТЗ($E1:E1))
К сообщению приложен файл: 7819976_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС($B$1:$B$99;(СЧЁТЗ(E$1:E1)-1)*7+СЧЁТЗ($D2:D2)+1)

Код
=ИНДЕКС($B$1:$B$99;СЧЁТЗ($E$1:$K1)-7+СЧЁТЗ($D2:D2)+1)

Код
=ИНДЕКС($B$1:$B$99;СЧЁТЗ($E$1:$K1)-7+СЧЁТЗ($E1:E1))

Автор - _Boroda_
Дата добавления - 19.02.2016 в 23:17
Jury_s Дата: Пятница, 19.02.2016, 23:36 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Да, именно! Огромное спасибо!
 
Ответить
СообщениеДа, именно! Огромное спасибо!

Автор - Jury_s
Дата добавления - 19.02.2016 в 23:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенести повторяющиеся названия строк с данными в столбцы (Сводные таблицы/Pivot Table)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!