Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет суммы средних значений без учета нуля - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет суммы средних значений без учета нуля (Формулы/Formulas)
Расчет суммы средних значений без учета нуля
MarinaT Дата: Понедельник, 22.02.2016, 11:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2003; 2007
Здравствуйте. Заранее прошу прощения за довольно корявое объяснение :'(

Есть таблица, в которой в ячейках A1:H1 рассчитывается среднее значение в определённом соотношении, которое зависит от соответствующих значений в столбцах A:H и I, по формуле вида:
Код
{=СУММ(A2:A7*$I$2:$I$7)/СУММ($I$2:$I$7)}

Нужно, чтобы эта формула в ячейках не учитывала значения из ячеек диапазона A2:H7, равные 0.

В примере приведены значения, которые должны получиться в результате и вообще суть вопроса видно более наглядно.
[moder]формулы оформляйте тегами (кнопка fx). На первый раз исправила.[/moder]
К сообщению приложен файл: 1405668.xlsx(13Kb)


Сообщение отредактировал Manyasha - Понедельник, 22.02.2016, 11:38
 
Ответить
СообщениеЗдравствуйте. Заранее прошу прощения за довольно корявое объяснение :'(

Есть таблица, в которой в ячейках A1:H1 рассчитывается среднее значение в определённом соотношении, которое зависит от соответствующих значений в столбцах A:H и I, по формуле вида:
Код
{=СУММ(A2:A7*$I$2:$I$7)/СУММ($I$2:$I$7)}

Нужно, чтобы эта формула в ячейках не учитывала значения из ячеек диапазона A2:H7, равные 0.

В примере приведены значения, которые должны получиться в результате и вообще суть вопроса видно более наглядно.
[moder]формулы оформляйте тегами (кнопка fx). На первый раз исправила.[/moder]

Автор - MarinaT
Дата добавления - 22.02.2016 в 11:33
Manyasha Дата: Понедельник, 22.02.2016, 11:45 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1587
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
MarinaT, добавьте условие >0 в формулу:
Код
=СУММ(A2:A7*$I$2:$I$7)/СУММ($I$2:$I$7*(A2:A7>0))
К сообщению приложен файл: 1405668-1.xlsx(13Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеMarinaT, добавьте условие >0 в формулу:
Код
=СУММ(A2:A7*$I$2:$I$7)/СУММ($I$2:$I$7*(A2:A7>0))

Автор - Manyasha
Дата добавления - 22.02.2016 в 11:45
MarinaT Дата: Понедельник, 22.02.2016, 11:50 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2003; 2007
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - MarinaT
Дата добавления - 22.02.2016 в 11:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет суммы средних значений без учета нуля (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!