Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск слова в строке и удаление строки в случае нахождения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск слова в строке и удаление строки в случае нахождения (Формулы/Formulas)
Поиск слова в строке и удаление строки в случае нахождения
Kamilio Дата: Четверг, 25.02.2016, 00:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здраствуйте, друзья!
Имеется длинная таблица(Т1) с одним столбиком, в каждой строчке - одно слово.
Имеется еще одна табличка(Т2) также с одним столбиком, в каждой строке по 3-4 слова.
Необходимо из таблицы Т1 взять каждое слово и проверить наличие в таблице Т2.
Если слово обнаружится, нужно удалить все строки, содержащие данное слово.
Это в элементарном виде.
И еще вариант посложнее (это то, что хотелось бы видеть в идеале, но необязательно, главное - хоть какое-то решение)
Есть процедура в VBA, которая ищет все слова и удаляет. Но в ней нужно вставлять вручную каждое слово.
Было бы круто, чтобы она автоматизированно всё проверила.
Код привожу ниже:

[moder]Код нужно в специальные теги обрамлять - кнопка #. Поправил Вам.


Сообщение отредактировал _Boroda_ - Четверг, 25.02.2016, 00:32
 
Ответить
СообщениеЗдраствуйте, друзья!
Имеется длинная таблица(Т1) с одним столбиком, в каждой строчке - одно слово.
Имеется еще одна табличка(Т2) также с одним столбиком, в каждой строке по 3-4 слова.
Необходимо из таблицы Т1 взять каждое слово и проверить наличие в таблице Т2.
Если слово обнаружится, нужно удалить все строки, содержащие данное слово.
Это в элементарном виде.
И еще вариант посложнее (это то, что хотелось бы видеть в идеале, но необязательно, главное - хоть какое-то решение)
Есть процедура в VBA, которая ищет все слова и удаляет. Но в ней нужно вставлять вручную каждое слово.
Было бы круто, чтобы она автоматизированно всё проверила.
Код привожу ниже:

[moder]Код нужно в специальные теги обрамлять - кнопка #. Поправил Вам.

Автор - Kamilio
Дата добавления - 25.02.2016 в 00:28
Kamilio Дата: Суббота, 27.02.2016, 19:55 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Прикрепляю другой пример, он более понятный.
Можно без VBA, главное решение.
К сообщению приложен файл: ___1.xlsx(8Kb)
 
Ответить
СообщениеПрикрепляю другой пример, он более понятный.
Можно без VBA, главное решение.

Автор - Kamilio
Дата добавления - 27.02.2016 в 19:55
Pelena Дата: Суббота, 27.02.2016, 20:04 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Доп. столбец с формулой массива
Код
=СЧЁТ(ПОИСК($D$2:$D$5;A2))

Затем фильтр по критерию =0 -- выделить строки -- Удалить
Невнимательно прочитала. Критерий >0
К сообщению приложен файл: _1-1-.xlsx(9Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДоп. столбец с формулой массива
Код
=СЧЁТ(ПОИСК($D$2:$D$5;A2))

Затем фильтр по критерию =0 -- выделить строки -- Удалить
Невнимательно прочитала. Критерий >0

Автор - Pelena
Дата добавления - 27.02.2016 в 20:04
gling Дата: Суббота, 27.02.2016, 20:08 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Так?
Код
=ЕСЛИ(СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК($B$2:$B$5;A2;1)));"";A2)
К сообщению приложен файл: _1.xlsx(9Kb)
 
Ответить
СообщениеТак?
Код
=ЕСЛИ(СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК($B$2:$B$5;A2;1)));"";A2)

Автор - gling
Дата добавления - 27.02.2016 в 20:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск слова в строке и удаление строки в случае нахождения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!